Need help restoring 1024x768 resolution to 11.4 KDE 64bit

Hello,

I am running opensuse 11.4 KDE 64 bit, kernel 3.1.0-rc9-2-desktop. Video card is GeForce 7300GT nvidia driver 285.05.09. Nouveau is blacklisted.

When I boot into the desktop kernel, the login menu is only 640x380 instead of the default 1024x768. When I boot into the failsafe mode, I got 1024x768 resolution.

The problem occurred after I installed Fedora 16 beta in this multiboot PC. After updating Fedora kernel to 3.1 rc9 and installing akmod-nvidia, the error message on screen says there seem to be a problem and I should log out and log back in. Re-installing Fedora that has the original kernel 3.1.0-0.rc6.git0-3.fc16.x86_64 still reboots to same error message. I didn’t think Fedora 16 has anything to do with openSUSE 11.4 display problem, but I could be wrong.

Since then I have re-installed nvidia driver 285.05.09 (via “the hard way”) but I am still stuck with 640x380 resolution unless I boot into failsafe mode of 11.4 desktop kernel and choose “KDE Plasma Workspace (failsafe)”. I had also looked at /etc/X11/xorg.conf.d/50-device.conf and found “Section Device” has no driver. Edited this file to add “Driver nvidia”, saved it and still get same problem after reboot.

Any suggestions? Thanks a lot for your help.

Are you sure that this isn’t directly related to the 3.1.0 kernel you’re using? More likely IMHO.

SDB:NVIDIA the hard way - openSUSE

Hello deano,

Thank you for your reply. Nvidia driver is installed “the hard way”. I did check every step but the problem remains.


#/sbin/lspci -nnk

01:00.0 VGA compatible controller [0300]: nVidia Corporation G73 [GeForce 7300 GT] [10de:0393] (rev a1)
        Subsystem: Device [19f1:04fb]
        Kernel driver in use: nvidia


lsmod | grep nv

nvidia              11909710  40 


# dmesg | grep nvidia
   10.176810] nvidia: module license 'NVIDIA' taints kernel.
   10.777299] nvidia 0000:01:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
   10.777312] nvidia 0000:01:00.0: setting latency timer to 64

I did switch to nvidia version 285.03, but the problem remains.

Post the contents of /var/log/Xorg.0.log

Upload it to SUSE Paste and post the link to it here.

Hi deano,


/var/log/Xorg.0.log
-bash: /var/log/Xorg.0.log: Permission denied

I then became root, and used Dolphin to look at the file. Here it is:
http:////paste.opensuse.org/15404304

It’s normal to require root privileges to view many system files. Here’s the relevant section

    38.761] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
    38.761] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.
    38.761] (--) NVIDIA(GPU-0):
    38.761] (--) NVIDIA(GPU-0): Raw EDID bytes:
    38.761] (--) NVIDIA(GPU-0):
    38.761] (--) NVIDIA(GPU-0):   00 ff ff ff ff ff ff 00  04 72 86 ad 80 01 51 83
    38.761] (--) NVIDIA(GPU-0):   23 12 01 03 68 28 19 6b  2a 67 60 a2 5a 49 9e 23
    38.761] (--) NVIDIA(GPU-0):   13 50 54 bf ef 00 81 8f  81 80 95 00 95 0f 01 01
    38.761] (--) NVIDIA(GPU-0):   01 01 01 01 01 01 9a 29  a0 d0 51 84 22 30 50 98
    38.761] (--) NVIDIA(GPU-0):   36 00 98 ff 10 00 00 ae  00 00 00 ff 00 4c 38 36
    38.761] (--) NVIDIA(GPU-0):   30 38 30 32 34 34 32 42  30 0a 00 00 00 fd 00 37
    38.761] (--) NVIDIA(GPU-0):   4b 1e 53 0e 00 0a 20 20  20 20 20 20 00 00 00 fc
    38.761] (--) NVIDIA(GPU-0):   00 41 63 65 72 20 41 4c  31 39 31 36 57 0a 00 1b
    38.761] (--) NVIDIA(GPU-0):
    38.763] (II) NVIDIA(0): NVIDIA GPU GeForce 7300 GT (G73) at PCI:1:0:0 (GPU-0)
    38.763] (--) NVIDIA(0): Memory: 524288 kBytes
    38.763] (--) NVIDIA(0): VideoBIOS: 05.73.22.51.61
    38.763] (II) NVIDIA(0): Detected PCI Express Link width: 16X
    38.763] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    38.763] (--) NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:1:0:0
    38.763] (--) NVIDIA(0):     CRT-1
    38.763] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
    38.763] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
    38.763] (**) NVIDIA(0):     enabled on all display devices.
    38.764] (II) NVIDIA(0): Assigned Display Device: CRT-1
    38.764] (==) NVIDIA(0):
    38.764] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    38.764] (==) NVIDIA(0):     will be used as the requested mode.
    38.764] (==) NVIDIA(0):
    38.764] (II) NVIDIA(0): Validated modes:
    38.764] (II) NVIDIA(0):     "nvidia-auto-select"
    38.764] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
    38.764] (WW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI
    38.764] (WW) NVIDIA(0):     from CRT-1's EDID.
    38.764] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
  1. So, for whatever reason your monitor’s EDID is reported as invalid. Did this ever work correctly (with previous nvidia drivers for example)? If so, maybe its a bug that needs reporting to NVIDIA

NVIDIA Linux - nV News Forums

  1. Have you tried using the ‘nvidia-settings’ utility (run as root) to select the preferred resolution? If not, open a terminal, and become root with
su -

Enter your root password when prompted, then

nvidia-settings

This guide is for TwinView issues, but may still be relevant to your situation:
SDB:NVIDIA troubleshooting - openSUSE

In particular, it will assist with creating a minimal xorg.conf that can be used to coax Xorg to provide the desired resolution manually.

shot in the dark… in the grub boot menu… is there an entry in the default append (at the bottom) of vga=0x345 ?

if not edit/add that and see if that affects your situation.

Hello j_xavier,

In my Grub menu, the kernel boot options has vga=0x317 and “nomodeset” and these codes have always given 1024x768 resolution until now.

Thank you for your suggestion.

Hello deano,

  1. yes.
  2. yes.

I will try to configure screen resolution manually and see what happens.

Can,t you set the disered resolution in kde-settings (personal-settings ~ display-monitor) ?

And also post ur xorg.conf or look if the line

Option “metamodes” “CRT-1: 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0”

exists in section screen

Hello unnamedopa,

I solved my display problem. Details are in Post #48 in this thread:

http://http://forums.opensuse.org/forums/english/get-technical-help-here/pre-release-beta/463949-linux-kernel-3-1-rcx-has-been-released-test-post-your-comments-here-5.html#post2393276

Cheers!

Hello,

The clue to solving the problem is in the link offered by deano in Post#49 in the thread of Post #13.

Cheers!