Need help installing programs

I’m a Linux newbie running Suse 10.0 with an i686 processor (I bought a machine pre-built with Suse, so I’d prefer to not reinstall an updated Suse version). I would like to install several programs but find that I’m missing rpm -python and python-elementtree. I was following the directions provided in this link for the installation of the aforementioned programs( but the ftp links are no longer functional. I’ve tried googling for these files, but I have not been able to determine if the ones I find are appropriate for my machine (OS version and processor).

Can anyone direct me to functional ftp files for rpm -python and python-elementtree? Thank you for any help you can provide.

python-elementtree: python-elementtree-1.2.6-2.i586.rpm - FTP Mirror Search (Downloads) (try any one of the mirrors)

rpm-python: rpm-python-4.1.1-222.i586.rpm - FTP Mirror Search (Downloads) (try any one of the mirrors)


Thank you very much for the help. I tried to install rpm-python, but now I find I need,, and I think I found the correct (RPM Search Do you know if there are machine/OS specific librpm programs?

Sorry for the dumb questions, but I appreciate the help.

Install this and see if the dependencies will disappear: rpm-4.1.1-222.i586.rpm - FTP Mirror Search (Downloads) (its suse 10.0 specific)

P.S- Why cant you upgrade to the latest and greatest opensuse 11.1? :slight_smile:

I don’t se the dumb question…:smiley:
I’m so dumb that you couldn’t imagine …

In openSuse there are several ways to install RPMs and all depends on how advanced you are in Linux. Fortunatelly we have so many tools for this.

The easiest way is to use YasT… so here goes my recomendation and How I would do it, ok?

Place all your Downloaded RPMs someplace in hour home directory… something like: /home/yourusername/Downloads/RPMs (it could be wherever you want)
Open YasT and Select Software Repositories
Select Add >Local directory and write the path where you stored your RPMs (somethng like /home/yourusername/Downloads/RPMs)
After that go to Install Software and search for the dowloaded package and install it.
This way you will assure that this package will have no dependencies, and in case it does it’s because you need to add some other repositories.

Good luck and Happy New Year


NOTE: Please, before this, try to follow **freedguy **suggestions

Well, thanks for all of the help. I tried installing the rpm-4.1.1 file but now I get a bunch of conflicts saying that this program conflicts with rpm-4.4.2.

Would installing suse 11 alleviate these problems? I’m very reluctant to do so since all of the pre-installed programs work (Evolution, wireless, Firefox, Open Office, etc) and I don’t have the knowledge base right now to fix any problems that might crop up with the OS upgrade.

Yes, this penguin is trying to learn how to walk…

After I re-read the whole post I’m starting to think that you have SLED 10 (SuSE Linux Enterprise Desktop)installed instead of openSuSE 10… is this right?

Installing individual rpm’s always gives dependancy headaches.

Its always good to install packages available in the repositories via YaST or Zypper or Smart.

To search for packages in the repositories either use or Webpin. You can make use of opensuse’s unique 1-click-install feature.

The last two versions of opensuse (11.0, 11.1) have seen tremendous improvements. Almost everything works out of the box. Using opensuse is now a breeze for all levels of users.

Obviously the latest versions have more packages in the repositories so you don’t have to go manually solve dependency issues. I suggest you to install 11.0 as some packages are still missing in 11.1 repositories 'cos of holidays. Or if you want to wait for a couple more weeks then install 11.1. Both are good releases.

To start with: Installation - openSUSE

I just installed openSUSE 11.1 and downloaded Thunderbird and Pidgin to my /home/username/Documents/

My question is how do I install the programs from the folders that are there? lots of files ,but I don’t see anything that resembles a setup icon. I am at present a Linux moron trying to navigate like I’m still in windows. I had some experience with Linux commands about 10 years ago using Slackware. HELP :open_mouth:


The best is to use YasT

Pidgin is already installed… so you dont need to do anything else.
Thunderbird is in the repos… I guess you must add Packman"'s repository to install thunderbird. —that’s the safest way…

good luck.


EDIT: 1. If you right click on the RPM you will see 2 installing options… if the package ends up with a *.sh, then you must run it in a console/terminal by sh or just ./
If the package ends up with *rpm then also in a console : rpm -Uvh nameofpckage.rpm. This must be mzade as root of course

EDIT: 2.----------

I placed the folder “pidgin-2.5.4” in the “tmp” folder on the root logged in as 'Super User" any suggestions on how I get this version of “pidgin” to install? I’m having trouble. Haven’t had any success with YaST when I search it only finds the older version of “pidgin” The latest version I have stored in a folder named Downloads in my “home” dir. I managed to install Thunderbird so I am making progress. Cheers! :open_mouth:


In my previus post I said to you to use YasT

If you use Yast You will get Pidgin 2.5.4 which is the latest, Just Add the repository from GNOME Community.and voilá… if you have problems to add a repository let me know to “link” you to the correct thread. you can add more repositories, just be carefull .


PS. If you want to install your dpwnloaded version just do as I sid before. open a termina/konsole and cd to that directory

#cd /tmp
#rpm -Uvh pidgin*.rpm

I Tried the terminal command and no luck :frowning:
I would appreciate the link to the Gnome community. I will add it to the repository.
I do have pidgin in a local directory in my repository, but it will not install from there either.

The pidgin file is in the tmp directory on the root so I’m not crazy.

drwxr-xr-x 9 User users 4096 2009-02-06 16:00 pidgin-2.5.4

Thanks for your help and patience. :slight_smile:


Sorry for not answering but I was out the city.

The GNOME Comunity repos must be added via Yast Sofware Repositories. So you have to open Yast >> Repositories >> Add and choose the option Comunity repositories… there you will see GNOME Stable and GNOME Comunity, mark the respective checkbox and accept the signature… after that, you have to go back to Sotware Install/Uninstall and choose pidgin… that’s it my friend…

Good luck


Greatly appreciated. It worked! :slight_smile: