Need help for installation on my macbook

Hi guys

Got some problem with installation here.
Actually I’ve installed SUSE on my PC before. And now I wanna install it on my Mac. I follow ever step on this one:

But after the installation I can’t boot into SUSE.
I tried “Boot from Hard Disk” option at installation but I got this error msg:

Then I checked eEFIt, here is the result:

Current GPT partition table:

Start LBA End LBA Type

1 ********* ********* Basic Data
2 ********* ********* Mac OS X HFS+
3 ********* ********* Mac OS X Boot
4 ********* ********* Basic Data

Current MBR partition table:
#A Start LBA End LBA Type
1 ********* ********* AF Mac OS X HFS+
2 ********* ********* AF Mac OS X HFS+
3 ********* ********* 0C FAT32(LBA)
4 1 1 EE EFI Protective

Status: Analysis inconclusive. will not touch this disk.
Error: Not found returned from gptsync.efi

Can anybody give me some help? Thank you!

Mac EFI is different I would us an older method.

What kind of older method, thanks!

Did you try native openSUSE 12.2 installation without rEFIt? It should support EFI natively.


Yes, try that please! I would be reallly interesting in reading your feedback.

Also notice that Mac OS X Lion uses one more partition than Leopard/Snow Leopard, as in the thread you referred to. See this thread: . Thus, AFAIK, it should not be possible to triple boot Lion or Mountain Lion with the older method - that invlolves rEFIt and hybrid MBR. You would need 5 partitions in hybrid MBR, and this is not possible.

Hi, Thank you!
What do you mean by native? Using bootcamp? Or clean install? I wanna keep my Mac OS…
One more thing… I tried Ubuntu. And already used gdisk to create a hybrid partition table. Still not working…

Here is the thread I posted on Ubuntu forum.

No bootcamp! bootcamp was never necessary to boot Linux. It was invented to create a partition and copy some drivers for Windows. Over time people started to use it to prepare the disk for non GTP aware Linux (such as openSUSE with Legacy Grub) - although Linux itseft can deal with GPT for about ten years, but the old boot loader could not. This is why people have installed openSUSE (most of the time successfully) on Mac hardware with rEFIt, while I believe in the same time, some Ubuntu users might have managed to install a ‘natively’ supported Linux - that’s what @arvidjaar meant: no bootcamp, no rEFIT, no hybrid MBRs. It was possible under Ubuntu (and Fedora) because they have been using an EFI aware boot loader for some years already (grub2-efi on Ubuntu and grub-efi on Fedora).

IMO, dangerous and not a good idea. True EFI systems don’t use hybrid but protective MBR. The EFI on Mac is older and different from the UEFI on Intel hardware. It might be a problem, I don’t know. I read that Windows 7 would not install in EFI mode for example. The other problem is to get Apple firmware boot the UEFI device and not the legacy one - and first off don’t try with an openSUSE live CD, because AFAIK it doesn’t include the UEFI boot loader at all. Well, I can not tell much more without having tried myself. I have some Macs in dual boot, but they are still legacy installation with hybrid MBR and rEFIt … :frowning: But I would like to change that at some point.

Thank you for your opinion. Then what I should do next? Now, I already created the hybrid MBR. Should I just delete the whole Linux partition? Uninstall rEFIt and do a “native” installation? Like:
• Partition using Disk Utility under Mac OS
• Install SUSE and install the boot loader at root partition
And that’s it?

I don’t know what you should do. Honestly if I knew, I would have done it myself. Well, I don’t really have time to think about it too. But if you don’t have Mac OS X on a DVD, you should download it and burn it first, so you will be able to reinstall OS X any time. You’ll find sites or blogs explaining how to do it. I don’t remember all the details. You have to update and cancel at some point. Otherwise it would just reinstall the system and delete the CD image. As for installing Linux boot loader in the root partition, that’s not how it works with GPT/EFI. All boot loaders are installed in subdirectories of the EFI partitions. One doesn’t install boot loaders in partition boot sectors anymore. If you install openSUSE with grub2-efi (you’ll have too if you want a GPT setup), the options will be different. But it might be complicated, @shawn_lyu, and I’m afraid I can’t help.

If I would get a MacBook Pro or a MacBook Air tomorrow, here’s what I would do (I do not say that it will work).

  • make sure I have OS X on DVD (update, download, cancel update and burn).
  • Use disk utilities (not bootcamp) to resize the OSX partition (the biggest one). Not sure I would (temporarily) create a DOS partition …maybe.
  • Boot openSUSE install DVD and make sure it boots in UEFI mode - but I have no idea if it’s going to work, and I should say that the openSUSE 12.2 setup confuses me. How come users have the choice between all these boot loaders? In fact you don’t have the choice between grub2 or grub2-efi. You have to install Grub2 on a BIOS machine with MBR and grub2-efi on a EFI/UEFI machine with GPT. The fact that both options are availalble in setup is pretty confusing. Well, I haven’t installed 12.2 very often yet, but I don’t remember that grub2-efi was greyed out on BIOS machines.
  • Finally install openSUSE and grub2-efi (not grub2!) which should normally be able to boot both Linux and OS X. Whether it works, I don’t know.

:slight_smile: Still I appreciate your help, thanks!

There is a good write-up on dual booting Fedora/OS X with EFI GRUB2: Installing Fedora 16 on Macs — Fedora Unity Project

Indeed. It might be a little bit easier with openSUSE 12.2 regarding grub2-efi, which is included in setup, while Fedora 16 used its own patched version of Legacy Grub (grub-efi), which works on UEFI Intel hardware but might not have worked with Apple firmware. IMO the tricky part will be to get the DVD to boot in UEFI mode. It’s possible that you have to use the 32bit version (as I read in some posts) and different models of Macbook might handle the Linux DVD differently. In order to install Windows in UEFI mode, some hackers had to remove the non UEFI boot loader completely from the Windows installation DVD. Otherwise it would have booted in CSM and installed a Legacy system (with hybrid MBR and requiring rEFIt to boot). We could have the same problem with Linux installation DVDs.

It might also not work because you already have a MBR. openSUSE setup - and Windows as well - would fail to create GUID partitions on Intel hardware if they find a MBR. You would have to blank it first. On a PC, in case of a Windows + Linux UEFI dual boot, I would just wipe out the first track, install Windows in UEFI and let it create a GPT, then install Linux (and make sure it boots in UEFI). I’m afraid it could be the same problem on a Macbook … unless you managed to uninstall rEFIt, undo bootcamp and replace the hybrid MBR with a protective MBR … kind of tricky.


I was wondering if any of you have any updates to this thread. In particular, successfully installing the latest openSUSE 12.2 on a macbook pro (dual-boot with Mac OSX). If so, were steps did you take? Did you need to install rEFIt (or the newer rEFInd) or did you install it “natively” using grub-efi??

Thanks for any tips!

Hi guys, i’d just like to add that i own a macbook pro 7.1 as well. I successfully tri boor Os X, Windows 7, and Opensuse 12.2.
Opensuse 12.2 runs very well on it with the exception of the battery life. The battery life in my experience of any os other than Os X, on a mac will be not as good as it is on Os X. It can’t be helped due to Apple optimizing there os for there hardware. On the bright side, it gets a fare bit more life than Windows on the mac.

@ The OP:
Installing on a mac really isn’t to much different to installing on any other machine. I recommend using Refit, because if you do a ‘native install’ without it, apparently you can not enable 3d acceleration. Here’s my tips. Written from scratch right now, just for you.

1) Boot into Os X. Remove all your partitions related to Gnu/Linux with disk utility and then remove refit.
2) Reboot
3) Run the updates tool for Os X and make sure the system is up to date.
4) reboot again back into Os X.
5) With disk utility make a partition for Linux again, and maybe even a swap.
6) I recommend another reboot just so the partition table can refresh
7) Boot Os X and install Refit again.
 8) reboot again just to make sure the Refit menu is appearing, and then load Os X; if Refit doesn't appear, reboot until it does, it has taken me two reboots before it has appeared.
7) insert Opensuse 12.2 installation disk and reboot, starting the install
8) proceed with the install, and select advanced partitioning, or what ever it's called at the partition part
9) Make sure you know which is the right partition you made for Linux and select '/' for it; and set swap for the swap partition, ect.
10) The partitioning part is very important to get right, if you don't know the technicalities behind the partitioning, and are just blindly following these steps, i suggest you tell us some more about your partition table so we can help you to avoid whipping out Os X or something.
11) continue with the install until you get to the summery part 'installation settings'. You will want to pay special attention to the bootloader location because this is the most important part
12) Make sure you have 'Grub2' selected under 'booting' and not GrubUEFI, or what ever the other one is called. 
13) Make sure the boot loader will be installed to '/' and not the mbr. "Status location: /dev/sda*"
once that's all done press proceed and let the install go. Once done, reboot and hopefully a little penguin comes up. If it does or doesn't select Os X anyways and make sure it boot fine.
14) reboot again, and this time see if Windows works fine.
15) finally reboot again and check out Opensuse.
16) Windows should **not** be loading Grub before it boots windows
17) If everything is good and working, then you're fine to proceed doing what ever you want, but if it's not, then try use the partition tool and see if it can fix the problem, reboot and see if it's working now.
18) Lastly if a partition isn't working and that stupid partition tool can't fix it again, reinstall Opensuse the exact same way onto the same partition again. It's stupid, but i've had to do that before and for god knows why it has fixed the issue.

Good luck mate, i hope i’ve helped

**Thanks, knightron!!!
I will try out your guide over this weekend and respond back with any updates that I have. Wish me luck! =)