Need Help Fixing Suspend to RAM

Nothing unusual noticed, but have a look at this:

NVidia Suspend HOWTO - openSUSE

There are a number of pm configurations listed. Have a look at the entires related to recent opensuse versions. For example, one nvidia user’s config strings:

Although SuSE defaults to userspace, let’s be explicit


Force because Dell M4300 is not in the white-list

Note: without the -p and -s, the GPU would run very hot when returning from s2ram

S2RAM_OPTS=“-f -p -s”

We need the following in order to s2ram


I’m not sure how accurate all that stuff in the HOW-TO is, since it was written for 10.1 and “not known if it still applies to 10.2”. I am using 11.0.
It really seems like I’m just shooting in the dark here trying to make this work. I was beating up on Vista about this (lack of) functionality, but I guess Linux is no better.
Something is getting trashed when I come back from suspend to RAM, but ONLY if I do so via the KDE menu buttons, which apparently use the file in etc/pm/config.d In that case, the system seems to come back, but when I try to run certain apps, like Firefox, the desktop appears unresponsive, and then finally locks up altogether, forcing a cold reboot.
On the other hand, if I just type s2ram -f from the console, I don’t have these problems at all. I’m going to try to make a desktop icon that just issues this command, but it’s frustrating that I can’t make this work the way it’s supposed to.

I agree it can be frustrating, but experimentation seems to be a necessary step for many. The nvidia suspend how to has been updated from time to time with comments from users with later versions of openSUSE, so you should give the above a go. I’ve read that some users have had success with userspace suspend enabled.

Also, check this out:

Userspace Software Suspend

It isn’t the “suspend to RAM” thing in general that is frustrating, as that seemed to be working fine from the outset via a terminal window. It was the apparent inconsistency between s2ram and the KDE buttons/pm-utils.
Anyway, I modified the config file in etc/pm/config.d as follows:


Now, it appears to be working ok. I have suspended and returned twice without any crashes. I can’t for the life of me figure out why adding the two statements above would make such a difference, but at least it appears to be (provisionally) working!

Glad to read the userspace option worked for you. Persevering with this paid off huh? :slight_smile:

Yeah, just wish it didn’t feel like black magic…

Just curious, what exactly ‘SUSPEND_MODULES=“button”’ does?I am not quite sure of it. Does it unloaded keyboard module before suspend and reload it while getting up?