Need help fixing Ardour package in OBS.

So I have been trying to maintain Ardour 5.12 here:
I manage to make it build in OBS with help from munix9.
But Ardour won’t start unless I run this command before starting it,

export GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc

I read many bug report on this issue and this is the recommended work around.

But this is inconvenient and could confuse other people, so I want to add the command into the desktop and start menu icon immediately after install. But I’m not sure how.
Is it in the .spec file or something?

Although you could write the command into the logged in User’s bashrc,
You could also make the change available to all users by either updating and existing or creating a new file


or, make it an entry in a script located in



I suppose you could install the application to “/usr/lib” or similar, instead of to “/usr/bin”. And then install a short shell script in “/usr/bin” which sets up the environment and then starts the application.

To help users:

Change the exec line in the .desktop file to contain the workaround:

Exec=export … ; ardour5

How to do this? Is this setting in the .spec build file?

Create a patch for the desktop file, create a new desktop file and overwrite the existing one? Get fixed upstream is the best way…

I think the work around is a bad idea/hack, adding it the background like that is likely to break a users system (using there own gtkrc files, I do…) or still not work if the user is using a different theme…

So, have you approached upstream to see what can be done, has this not been ported to gtk3 yet?

I do have to ask another couple of questions, why are you submitting direct to the development repository without peer review, making changes without updating the changelog (eg looks like the patch was rebased and no changelog entry)?

You should be branching and fixing/testing, when it’s all working then submit an SR. I also note it’s failing to build again :frowning: