Need Help Configuring SMB on openSUSE 42.1

Hello All,

EDIT: The problem is that I can’t connect to the SMB share from my Mac or my wife’s Mac (they’re from work).

I have openSUSE 42.1 installed on my desktop and I’m trying to host a SMB server on my SUSE install so I can share files between my Macbook and my desktop (ideally without logging in). I have been trying for the past two days to set it up and am at my wits end and am slowly going mad. I’m hoping the community will be able to give some guidance or at least teach me how to sensibly debug this issue. I have posted images of my YaST Samba Server config below and there’s a paste of my SMB.conf file as well.

So far I have:

  1. Opened the port in the firewall (external) by adding the service to allowed services and selected the option in YaST.
  2. I have added a smb user with my own account’s user name and changed the owner of the share (chown w0269804 : /home/w0269804/Shared/)
  3. I have changed the permission to 777 on that folder just to see if that was possibly it.
  4. I have enabled guest access on the share.

Anyone out there that can give a hand?

I cannot remember if smbclient is installed on Mac OS/X but if it is, it is probably easier to debug. Try running “smbclient -L //ip-of-your-openSUSE-box/share” and see if it throws an error.


I can only talk about Linux.
Forget about Yast configuring Samba.
You seem to be sharing the folder /home/w0269804/Shared and it belongs to user w0269804

I would recommend to copy the file smb.conf to a backup and then alter it grandly.

This will copy it correctly, use a console window: su -c “cp /etc/samba/smb.conf /etc/samba/smb.conf.Original”
Have a look in your file browser to make sure it worked.
Then edit the file smb.conf with this command:

  • if gnome: gnomesu gedit /etc/samba/smb.conf
  • if kde: kdesu kwrite /etc/samba/smb.conf

Put these into smb.conf and get rid of all the original text (it’s OK you have a backup)

workgroup = WORKGROUP
name resolve order = bcast host lmhosts wins
netbios name = Leap421
passdb backend = tdbsam
local master = yes
preferred master = yes
os level = 64
server string = 
printcap name = cups
cups options = raw
use client driver = yes
map to guest = Bad User
usershare allow guests = No

path = /home/w0269804/Shared
read only = No
force user = w0269804
guest ok = yes

You might need to change the workgroup name from “WORKGROUP” so as to align with what’s in the Mac (over to you on that)

Next make these settings in Yast Firewall: Yast ==> Security users ==> Firewall

  • Set the interfaces to External Zone
  • In Allowed Services make sure you have Allowed Services for Selected Zone to be “External Zone”
  • In Allowed Services ==> services to allow, make sure you have Samba Server, Samba Client and Netbios Server

Next check the daemons: Yast ==> System ==> Services

  • find nmb and set it to Enabled and Active
  • find smb and set it to Enabled and Active

Reboot Mac and Linux to let them see each other and decide who-is-who in the network

Good luck.

Afterthought: That share is a wide open share, accessible, readable and writeable to whoever browses by. If you want it accessible to w0269804 alone, you might make it this way:

path = /home/w0269804/Shared
read only = No
valid users = w0269804