Need Drivers for Radeon Xpress 200M

Rifester wrote:

> No, I re-clean installed Ubuntu. Old CPU suggested I should wait a few
> weeks for things to get sorted out and I did not want to leave my
> computer in a broken state.

I would agree with oldcpu’s recommendation.

While in previous threads on this article, I had said I was getting more
reliable startups, unfortunately, that is no longer the case. I am still
using the
repo and in fact, there were several xorg-x11* updates today, but black
screens are still happening for me and more often than not.

I hope the x11 repo will eventually provide reliable drivers - hopefully
sooner rather than later.

In the meantime, I find the best way to boot is to enter “3” (without the
double quotes) at the grub menu, login, then “init 5” .

OK, you don’t have openSUSE, so you can install it. For now, just install with the installation media and let the installation add the oss snd non-oss repositories automatically.

The card 200M is not supported by fglrx in 11.2, nor by radeonhd, nor by the new catalyst beta drivers, only by “radeon”. Your install should complete and maybe you’ll get a blank screen or a crummy screen.

Boot to a console by choosing “init 3” at the Grub prompt. You do this by pressing the integer 3 key when the Grub screen appears at startup, and then press enter. Log in as root. Run this command:

sxa2 -r -m 0=radeon

and pause there, that’s all there is for video with the 200M in openSUSE 11.2, as far as I’m aware.

“I need help testing a possible fix”](

This maybe a fix for the black screen issue in 11.2 for this card.

No promises, but we need testers to make sure it works.

O And Please post if it does or does not work.

Hello togehter,

i read you topic yesterday and made a few test.
I installed OpenSuse 11.2 with ATI Repo an fglrx drivers.

After starting system in normal mode, i had a blacksreen.
I’m working now with Debug Mode and this is the only way to start system.
Today i tried out your parameter to configure free radeon driver.

sxa2 -r -m 0=radeon
but corrected to
sax2 -r -m 0=radeon

After this, configuration started and i finished it without any problems.
To test installed drivers i logged out from system and start X-Server again. (remember, all in Debug Mode).
It works! :), also with Desktopeffects. rotfl!
After this, i start to reboot system, to switch to normal mode, to configure my Desktop. But the system, unfortunately runs to black screen.
I don’t know why, because in Debug Mode all worked fine (with effects a little bit slower, but it worked)

Has anybody an idea, how to activate radeon in normal mode?

Thanks a lot :slight_smile:


HP nx6325 - ATI Radeon Xpress200
OpenSuse 11.2 Release November 2009
AMD Sempron 1.8Ghz (1GB RAM)

I’m sure some users have recently reported there is a kernel option ‘vga=0x…’ in the grub boot entry that can cause problems for some. Have a read of this thread:

11.2 Fixes For Xpress 200 and other legacy Cards - openSUSE Forums

They have unified several other threads information on fixing the black screen issue for Xpress 200m into that thread.