Need authorization to change screen brightness?

Hi. I’ve had this problem for several months, but haven’t found a solution yet. When my laptop is on battery, I often get pop-up dialogues saying that authorization is needed to change the screen brightness. It doesn’t matter whether I give it authorization or not, this dialogue will keep coming up. I haven’t noticed any particular pattern or event to it, though I’m sure the computer has its reasons for doing this.

I have two questions about this: What can I do to stop this from happening, and why do I need to give it authorization to change the screen brightness? Shouldn’t that be something that can be adjusted by any user as needed?

I’m running OpenSUSE 12.1 KDE spin on an HP 2000 laptop, which was new back in February of this year.

Thanks!

Edit: The exact message is “System policies prevent you from setting the brightness level.”

I can’t find any system settings that I’m able to change in either Yast or KDE’s settings that have stopped these messages popping up. The account is an administrator’s account. I’ve also been having dialogues come up when I close the laptop lid saying that authorization is required to suspend the system, so I think there’s maybe something having to do with power management that’s requiring advanced privileges, but nothing I’ve found in KDE’s power management settings has solved it.

On 2012-04-30 00:16, rogue mouser wrote:
>
> Hi. I’ve had this problem for several months, but haven’t found a
> solution yet. When my laptop is on battery, I often get pop-up dialogues
> saying that authorization is needed to change the screen brightness. It
> doesn’t matter whether I give it authorization or not, this dialogue
> will keep coming up. I haven’t noticed any particular pattern or event
> to it, though I’m sure the computer has its reasons for doing this.

Absurd problem… Sorry, no idea how to solve it.

> I’m running OpenSUSE 12.1 KDE spin on an HP 2000 laptop, which was new
> back in February of this year.

Was it installed, or did you install it yourself?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I don’t necessarily know the answer here, but we can check your policykit settings. What is returned (if anything) by

pkaction --action-id org.kde.powerdevil.backlighthelper.brightness --verbose
pkaction --action-id org.kde.powerdevil.backlighthelper.setbrightness --verbose

For reference, I get

pkaction --action-id org.kde.powerdevil.backlighthelper.setbrightness --verbose
org.kde.powerdevil.backlighthelper.setbrightness:
  description:       Set brightness
  message:           System policies prevent you from setting the brightness level.
  vendor:            KDE
  vendor_url:        
  icon:              kde
  implicit any:      no
  implicit inactive: no
  implicit active:   yes

dean@linux-akl:~> pkaction --action-id org.kde.powerdevil.backlighthelper.brightness --verbose
org.kde.powerdevil.backlighthelper.brightness:
  description:       Get brightness
  message:           System policies prevent you from getting the brightness level.
  vendor:            KDE
  vendor_url:        
  icon:              kde
  implicit any:      no
  implicit inactive: no
  implicit active:   yes

Instead of running with an administrator account, have you considered using a normal user account? While having root access in theory allows you to do anything, most things are checked out as not being root. Since you can become root anytime that you wish, and most tasks, such as using the internet or reading mail don’t require root user authority, log in as a normal user and then see if the problem persists. I did search for the problem and found but one other instance of this reported problem and no solution given. Its seemed identical to yours except I did not see any reference to being a root user, but that is not always stated or even recommended.

Thank You,

On 2012-04-30 01:56, rogue mouser wrote:

> The
> account is an administrator’s account.

What? What do you mean, are you using root in KDE?

Then that’s the problem, never do that. Your system is broken now. >:-)


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I can’t find any system settings that I’m able to change in either Yast or KDE’s settings that have stopped these messages popping up. The account is an administrator’s account. I’ve also been having dialogues come up when I close the laptop lid saying that authorization is required to suspend the system, so I think there’s maybe something having to do with power management that’s requiring advanced privileges, but nothing I’ve found in KDE’s power management settings has solved it.

I missed that, although I’m still not sure (from the above) that the OP was running as root.
@rogue_mouser: Can you please clarity?

Sorry for the confusion. What I meant is that the account is a member of the admin group with no restrictions and has sudo privileges. I don’t run as root ever.

I installed openSUSE myself when I bought this laptop back in February. I’m new to OpenSUSE, less so to Linux.

In response to deano_ferrari: The output seems to be exactly like yours:

pkaction --action-id org.kde.powerdevil.backlighthelper.brighness --verbose
org.kde.powerdevil.backlighthelper.setbrightness:
  description:       Set brightness
  message:           System policies prevent you from setting the brightness level.
  vendor:            KDE
  vendor_url:        
  icon:              kde
  implicit any:      no
  implicit inactive: no
  implicit active:   yes



pkaction --action-id org.kde.powerdevil.backlighthelper.setbrighness --verbose
org.kde.powerdevil.backlighthelper.setbrightness:
  description:       Set brightness
  message:           System policies prevent you from setting the brightness level.
  vendor:            KDE
  vendor_url:        
  icon:              kde
  implicit any:      no
  implicit inactive: no
  implicit active:   yes

Hmmm…interesting. A quick search found the following

System Policies prevent you…

which links to this bug report

https://bugzilla.novell.com/show_bug.cgi?id=688267

You might like to try the workaround mentioned. By chance, do you have NVIDIA graphics hardware?

Sorry for the delay in my reply.

I missed that bug post in my searches.

I’ve got ATI Radeon video hardware, and my OS is a 64 bit installation.

That workaround did the job. Thanks for your help.

That workaround did the job. Thanks for your help.

Thanks for the update. I’m glad it did the trick.