Need advice on Windows-Linux printer sharing

Hi. Running a network consisting of my SuSE 10.3 main desktop, a Windows XP box for net-radio streaming, and a Vista box for my children. I have a Brother MFC-7820N and (to-be-retired-imminently) Epson Stylus Photo R200 attached to the Linux box and shared successfully with the others via Samba. (Although, to be honest, I’m a big ignorant Samba newbie.)

Problem is: I just got a new Samsung CLP-300 colour laser (USB only, no ethernet) to replace the Epson inkjet, and I’ve put it on the kids’ computer for use as their printer, but I want to access it now and again when I need colour printing myself. Don’t know how to network it properly so the Linux box can see it. Can anyone point me in the right direction?

So far, I’ve installed the printer as a local printer on the Vista box (not taking the network option); and then going to the printer properties, turning the printer into a shared printer (naming it samsung-clp-300 on the assumption it would come onto the network as \kidsbox\samsung-clp-300), but it’s a no-show either on the Linux box or the XP box.

Don’t know where to take it from here.

There are ‘standard’ and ‘custom’ installation options for a networked printer on the driver-installation software, but I’m not sure what kind of TCP, port, or other information to enter.

is there anywhere anyone can point me that will help me set up in fairly plain language?

Many thanks.

Check out swerdna’s guide:
Printer Sharing: Windows Print Server for Suse/openSUSE Linux Clients [Samba and LPD]

I don’t like samba, and hence if it were me, I would prefer the “Setting up a Linux client to print using **LPD protocol **(alternative to Samba)” toward the end of the page, but many users take the time to setup samba.

In our home LAN, we have the printer connected off of the openSUSE Linux PC (and my wife’s WinXP PC prints through the openSUSE Linux PC via IPP).

Yes, I’d normally have the printer set up on my Linux box, too, but the whole point of this is to have one for the boys, so it really needs to be on the Vista box, as chagrined as I may be about that that!

Thanks much for the link. We’re on our way, but not quite there.
I’m able to set up the printer description in CUPS and make it recognise the printer (and the printer recognise it, importantly!), but I can’t get any printing done. Details …

I tried setting up through both Samba and LPD directions. LPD didn’t work at all. Samba gets me a signal out, so to speak, and a response from the printer. However … when running a test page through the CUPS setup process, I get the following message back …

/usr/lib64/cups/filter/pstoraster failed

… and the test page stays in the queue.

Meanwhile, over at the printer, the printer warms up and prepares to print … and then spits out the following message:

SPL-C ERROR – Please use the proper driver
Position: 0x0 (0)
System: src/xl_image
Line: 462
Version SPL-C 5.24 06-28-2006

The latter bit suggests to me there may be something wrong on the windows end … but after re-installing the drivers, I didn’t get any joy. Could it be the Linux PPD file? (I’m on 64-bit architecture … could this make a difference?)

update: it appears to have been the driver. I d/l-ed and installed Samsung’s proprietary drivers, and that got me one step further. Only now the test page reports back …

unable to connect to CIFS host; trying again in 60 seconds.

hmm.

doctor-frog wrote:

>
> update: it appears to have been the driver. I d/l-ed and installed
> Samsung’s proprietary drivers, and that got me one step further. Only
> now the test page reports back …
>
> unable to connect to CIFS host; trying again in 60 seconds.
>
> hmm.
>
>

In the yast printer setup, I imagine you’re using the ‘smb’ printer type. Did
you put anything in the ‘workgroup / domain’ field? try defining the
printer again, and leave the workgroup field blank. Just enter hostname of
windows machine, and printer share name. My experience has been that
supplying the workgroup confuses something, and it never connects.

Loni

L R Nix
lornix@lornix.com

I’m not using YaST; I’ve been setting up through http://localhost:631. That said, I’ve tried it both with and without workgroup name … and now have done it both ways in YaST, since you mention it.

Same results.

I wonder if I’m missing a windows setting. I followed that tutorial as closely as I could; but it’s for XP, and vista is rather different.

PS – I’ve noticed that when I do control panels → printers and faxes → add printer on my XP box (same network), the XP box doesn’t even see the printer.

herm.

doctor-frog wrote:

>
> PS – I’ve noticed that when I do control panels → printers and faxes
> → add printer on my XP box (same network), the XP box doesn’t even
> see the printer.
>
> herm.
>
>

I really hate asking this…

Firewall?

Loni


L R Nix
lornix@lornix.com

no, don’t hate asking. always a worthwhile question.

SuSE firewall has cups enabled for the external zone. opened the port myself. I’ll go check the windows box … back in a sec …

… and, yep. TCP/IP printer sharing is opened. Must have been opened automatically when I set the box up initially or else when I opened up the Unix LPD stuff rougly (very roughly) as the tutorial given to me earlier describes it.

If there’s something further I’m missing, tell me. Even if it’s something obvious; I won’t hate you for it! :smiley:

doctor-frog wrote:

>
> no, don’t hate asking. always a worthwhile question.
>
> SuSE firewall has cups enabled for the external zone. opened the port
> myself. I’ll go check the windows box … back in a sec …
>
> … and, yep. TCP/IP printer sharing is opened. Must have been opened
> automatically when I set the box up initially or else when I opened up
> the Unix LPD stuff rougly (very roughly) as the tutorial given to me
> earlier describes it.
>
> If there’s something further I’m missing, tell me. Even if it’s
> something obvious; I won’t hate you for it! :smiley:
>
>

{Grin} always good to get the dumb stuff out of the way first…

XP not being able to see the printer is not a good sign. On XP, if you typed:

\kidsbox\samsung-clp-300

in the address bar (start->run, or IE, etc), does XP find the kid’s vista
machine?

And did we check firewall / file-print sharing on the VISTA box? If it’s a
typical Windows box… did it come with Norton or McAfee? They usually ALSO
supply a firewall.

Can you ping each machine from each other machine?

Keep playing with it until the XP box can see the Vista box. Then try the
linux box again.

Loni


L R Nix
lornix@lornix.com

ok, it’s definitely not the firewall. I tweaked a Samba address setting with the CUPS’s own-brand configuration tools … as suggested above with YaST … and now it seems to work. Sort of. Did Firewall on and off. But it worked either way … so what did it was the removal of the workgroup from the login settings, after all.

But …

now it only prints about the top inch or inch-and-a-half of the test pages from the Linux box. And in quality that I can only describe as truly vile. Printing a real thing (tested with an email) prints maybe an inch down, with vile resolution and washed out colour.

Just can’t win today!

doctor-frog wrote:

>
> ok, it’s definitely not the firewall. I tweaked a Samba address setting
> with the CUPS’s own-brand configuration tools … as suggested above
> with YaST … and now it seems to work. Sort of. Did Firewall on and
> off. But it worked either way … so what did it was the removal of
> the workgroup from the login settings, after all.
>
> But …
>
> now it only prints about the top inch or inch-and-a-half of the test
> pages from the Linux box. And in quality that I can only describe as
> truly vile. Printing a real thing (tested with an email) prints maybe
> an inch down, with vile resolution and washed out colour.
>
> Just can’t win today!
>
>

But you’re making progress… {Grin}

I had to try installing a Samsung-CLP-300 here both ways, CUPS and Yast.
Don’t have that printer of course, but you can fake things… :slight_smile:

The CUPS install system works very well, but can lack certain options you
might need. When I installed printer via CUPS, it didn’t ask if I wanted to
process the data locally or not, and a quick test shows that it doesn’t do
this by default either.

Installing via Yast could be needed. There is an option when installing the
printer, labelled ‘use local filtering’. Linux processes almost everything
in postscript, and if not told otherwise, will happily send postscript to a
windows machine… resultant output is undefined.

by selecting ‘use local filtering’, the print system should create the
appropriate data for the printer, as if it were hooked directly to the
machine, then send it.

Can you check that this option is enabled? It usually isn’t. I forget about
it often since all my machines are linux boxen and don’t have a problem with
postscript inputs to a non-postscript printer.

------long pause here-------------

surfed a bit, found some info about the CLP-300:

All talk about state of driver. list foo2qpdl driver as the best. of
course, it’s not part of suse. used some other ‘foo’ series drivers myself
in the past, installer is pretty good, and quality is great.

http://forums.linux-foundation.org/read.php?31,4186

http://forums.linux-foundation.org/read.php?31,6204
(this one is yours…)

http://www.linuxprinting.org/show_printer.cgi?recnum=Samsung-CLP-300
(major overview of Samsung CLP-300)

Ok… seems you’ve already read those… hmmmm.

Based on what I’ve seen, I’d recommend trying the foo2gpdl driver.

Obtainable from http://foo2qpdl.rkkda.com/

Yup, guess I’ve gone from help to repeat… now I’m quoting you… quoting
me… {sigh}

Loni


L R Nix
lornix@lornix.com

Lornix – you’re defintely my hero. Those drivers did the trick. Got nice crisp blacks. Some colours are a little fuzzier than I’d have expected, but perfectly acceptable for a module that has to be reverse-engineered to work. Life is now good once again – the sun is shining and the birds are singing … etc. etc.

Vista’s still playing silly buggers with network recognition: I still can’t get the XP box to see the printer (which isn’t a problem; I don’t print with that machine; just using it for testing). Meanwhile the Vista box has always had problems finding my Linux shares, and it’s decided to lose them altogether now. But that’s off-topic, I suppose. Maybe the next step is just to wipe the drive and downgrade to XP. Wish I could make it a Linux box, but for various reasons I can’t.

Anyway … that’s by the bye. The printer works. And there was much rejoicing.

doctor-frog wrote:

>
> Lornix – you’re defintely my hero. Those drivers did the trick. Got
> nice crisp blacks. Some colours are a little fuzzier than I’d have
> expected, but perfectly acceptable for a module that has to be
> reverse-engineered to work. Life is now good once again – the sun is
> shining and the birds are singing … etc. etc.
>
> Vista’s still playing silly buggers with network recognition: I still
> can’t get the XP box to see the printer (which isn’t a problem; I don’t
> print with that machine; just using it for testing). Meanwhile the
> Vista box has always had problems finding my Linux shares, and it’s
> decided to lose them altogether now. But that’s off-topic, I suppose.
> Maybe the next step is just to wipe the drive and downgrade to XP. Wish
> I could make it a Linux box, but for various reasons I can’t.
>
> Anyway … that’s by the bye. The printer works. And there was much
> rejoicing.
>
>

{Smile} Glad to help.

Loni


L R Nix
lornix@lornix.com