necflash dma question

Hello

I want to flash my Optiarc (Nec) 7173A dvdrom drive with Necflash but I got the following error: Error submitting checksum.
When searching google, I found the following:

Flashing Optiarc burners may abort with an “Error submitting checksum” message, if the drive is set to UDMA4 mode. In this case please switch the drive to PIO mode.

hdparm -i /dev/sg0

dev/sg0:

Model=Optiarc DVD RW AD-7173A , FwRev=1-02 , SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 *udma4
AdvancedPM=no

  • signifies the current active mode

As you can see, it is at udma4.

Can I change this? I use openSuse 11.1 x64. I’ve already checked my Bios but I’ve got no options. Bios is version F12 for Giga-byte GA-P35-DS3 mainboard.
I found several solution for Windows, devicemanager… but I hope linux can do it too. I already tried hdparm -p0 /dev/sg0 but it does nothing.:frowning:
Hope you can help me. Thanks

Try turning SMART off in the BIOS - it may work.

Smart wasn’t enabled. It is a strange thing, in the past, it was difficult to enable DMA and now, PIO mode can’t be set anymore? Is it possible with sdparm because hdparm doesn’t work?

I’ve done it another way. I had a old pclinuxos 2007 live-cd and booted it into save mode and logon as root. After that, I mounted the hdd where necflash and bin files are. First it won’t work because the DMA problem but after hdparm -X00 -p0 -d0 /dev/hda it works and the drive is flashed.
I think, pclinux has a very old kernel so my drive was on /dev/hda but with openSuse it is on /dev/sg0. Maybe the reason why hdparm doesn’t work. But I’m lucky for now.