Ndiswrapper worked in ubuntu, not working in Suse

I used to use ndiswrapper for Athero wireless card, it worked well under Ubuntu 8.04, what i did is to uninstall Athero drivers from “Restricted Hardware”(I cannot find this kind of application in Suse), then install using Ndiswrapper, however, there is no “Restricted Hardware” in Suse for me to delete system installed driver, then I got this from dmesg:

ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
ndiswrapper: driver net5211 (,06/21/2007, loaded
PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 19 (level, low) -> IRQ 19
ndiswrapper (ZwClose:2227): closing handle 0xce118be8 not implemented
PCI: Setting latency timer of device 0000:06:00.0 to 64
ndiswrapper (NdisWriteErrorLogEntry:191): log: C0001389, count: 4, return_address: f994a0b4
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xce105000
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x28
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xf94fe000
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xf94fe000
ndiswrapper (mp_init:216): couldn’t initialize device: C000009A
ndiswrapper (pnp_start_device:439): Windows driver couldn’t initialize the device (C0000001)
ndiswrapper (mp_halt:259): device d2cac500 is not initialized - not halting
ndiswrapper: device eth%d removed
ACPI: PCI interrupt for device 0000:06:00.0 disabled
ndiswrapper: probe of 0000:06:00.0 failed with error -22
usbcore: registered new interface driver ndiswrapper

My question is, how to do a remove of driver under OpenSUSE such like unchecking drivers in “Restricted Hardware” in ubuntu, I opened Network devices in Yast, the Athero one is “Not Configured” and i cannot edit it or delete it.

Thanks a lot!

  • hzxu