ndiswrapper error free but no wlan0

Hi people,

Recently got the desire to try a new distro. Been having trouble with both I have tried on my desktop. I have to use ndiswrapper to get my wireless card to work (Cheap D-link usb wireless). I have never had a problem in ubuntu releases with getting it up and going, but in Fedora and now Opensuse I am struggling. I have everything setup with no errors. Ndiswrapper lists my drivers as installed and my hardware present. lsusb also has it listed. but when I modprobe ndiswrapper, I am getting no errors, but I am also not getting wlan0 to show when using iwconfig. I also noticed when modprobed the wireless card’s light isn’t coming on like ubuntu. I reallllllly want to get this working though and was wondering if anyone had experianced a similar problem and solved it.

What is it, make, model, version? And what’s the device ID.

/me Smells some “Bad Magic” in the air.

But this is only a guess, more info needed

Getting Your Wireless to Work - openSUSE Forums

(script linked in 3rd post)

sorry I was typing that away from my desktop. Now that I am home, I can give you more info. It’s a D-link WUA-2340 usb wireless. Device ID is 07d1:3a08. I am just finding this issue strange. I followed the exact same steps that I would on ubuntu, minus sudo since I used su to gain root privalages. I am gonna see if I can’t create wlan0 by hand. Tried using yast to do it but to no success.

It’s listed as OK on the ndiswrapper site. And it has workerd for you earlier, so you should ty it in Yast as you suggested. Just switch to “traditional method with ifup”. If you don’t see it, try the “Add” button. Here’s an old pictorial that includes mention of ndiswrapper: Madwifi or Ndiswrapper Wireless Network Drivers - Suse/openSUSE 10, 11 - LAN & Internet access

As long as there is no wireless interface created on loading the module, whatever method to use for configuring the interface (which does not exist!) is completely irrelevant.

But as my suggestions seem to be ignored, why bother about this one either?

Akoehl has it right, Yast is a no go because it is not creating a wireless interface. It knows in a sense that it is there because after a restart, yast asked me if I wanted to modprobe it. After another restart, I did a dmsg after modprobing. Apearently the problem lies there because it is not showing up as even attempting which explains how it isn’t turning on yet not giving me an error. It is frustrating not getting it to work. I guess I might have to go back to Ubuntu, but it is a shame. I really don’t understand what is changing between Ubuntu and Opensuse and Fedora that is causing this issue. I really would have liked to get it going Suse had me really intrigued and I was so anxious to try something new. I will keep working on it for a bit again.

I will keep working on it for a bit again.

That’s the spirit! But hey… Akoellh has pointed you to a very helpful script that will help you to analyze which part of your configuration is faulty, why not using it? Take a look →here. I have seen many threads were the output of this script has cleared the sky.

And there in lies the issue. I am still unsure why it never gave me the error for it when I checked, but it finally hit me. It was bad magic. I must have grabbed the wrong disc when I went to install it. I downloaded both versions, one for my desktop with the wireless card that wasn’t working and one for my laptop which has native drivers. So this problem is solved and from the things I am gathering, I am not the first to make such a simple mistake of trying to use ndiswrapper on a 64 bit system.