ncurses library missing

Hi,

I’m attempting to compile rtorrent on openSuse 11.1
the configure script fails with the message: “The ncurses library is required!”

However according to yast ‘libncurses5’ is installed on my system.

I tried installing libncurses6 and reinstalling libncurses5 to no avail.

any ideas?

thanks.

If you are trying to compile any programs that use ncurses calls, you will need ncurses-devel package to be installed. (Just search in Yast and it is there).


zypper se -s rtorrent

S | Name                 | Typ        | Version      | Arch   | Repository
--+----------------------+------------+--------------+--------+-----------------------------------
  | rtorrent             | Paket      | 0.8.4-0.pm.1 | x86_64 | Packman repository (openSUSE_11.1)
  | rtorrent             | Paket      | 0.8.4-0.pm.1 | i586   | Packman repository (openSUSE_11.1)
  | rtorrent             | Quellpaket | 0.8.4-0.pm.1 | noarch | Packman repository (openSUSE_11.1)
  | rtorrent-debuginfo   | Paket      | 0.8.4-0.pm.1 | x86_64 | Packman repository (openSUSE_11.1)
  | rtorrent-debuginfo   | Paket      | 0.8.4-0.pm.1 | i586   | Packman repository (openSUSE_11.1)
  | rtorrent-debugsource | Paket      | 0.8.4-0.pm.1 | x86_64 | Packman repository (openSUSE_11.1)
  | rtorrent-debugsource | Paket      | 0.8.4-0.pm.1 | i586   | Packman repository (openSUSE_11.1)

Akoellh wants to say that rtorrent is available in Packman repositories! You don’t need to compile your own.
Select a Packman repo here (try the closest one):Additional YaST Package Repositories - openSUSE. - right click to on of the listed repositories and select Copy Link Location.
How to add the repository:
Add Package Repositories to YaST - openSUSE
Good luck.