Nautlus share will not allow sharing in LEAP

Prepare for a bit of a rant.
I am using Opensuse and have been for about two years now (after a brief trip to Ubuntu Land). I was quite happy with Opensuse 13.2 which I had setup just as I liked it. unfortunately one day when running a zypper up it decided to change me to LEAP. Took me a few days to iron out the bugs after the migration, but Leap seems fairly good and stable in the end. However on Opensuse I have always had massive issues with getting a stable Samba server to work. I had just about cracked it on Opensuse 13.2 and this was one of the main reasons why I didn’t want to upgrade to Leap.
My network is WIFI based which brings a whole other set of issues to the mix.
However even back with 13.2 I had very flaky Samba performance when sharing a whole disk with my Ubuntu Kodi media centre. The best way I could find to do this was to mount the disk in my home directory and then create a Nautilus share to it which the Kodi computer generally found. Using the YAST server setup was always very hit and miss and would generally break things along the way. The real issue i seem to encounter is that every few week the regular security updates bork my Samba share and I have to reset the server from scratch. The breaks are random and difficult to work out and I usually end up deleting my smb.conf file and starting over.

This happened a few days ago and I have had flaky shares ever since. i need to turn on the Kodi client before the samba server to get things working and sometimes it takes a few reboots to get them to mesh. The latest few security updates have just broken it and I attempted to YAST a new server configuration from scratch. No joy. Basic security updates just seem to randomly wipe my settings from the smb.config file.
I next tried to use the Nautilus share to do the same thing, but I have just discovered that the system has changed the ownership of the disk mounted in my home directory to root ownership so it refuses to create the share due to ownership issues. I trying to resolve this i have also discovered that “sudo nautilus” and “sudo gedit” have been disabled so I cannot implement the share from within my own account and when I tried to change the smb option “usershare owner only = false” it seems that this functionality has also been disabled so I cannot change permissions from within my own account and creating the share within the root account doesn’t free up permissions to general users.

Here is the ranty bit, it seems to me that what has happened with the migration to Leap is that security settings and lockouts have been upgraded to Enterprise level’s which are totally inappropriate to a single user desktop and rather difficult to work around. The functionality that is available within Windows via a single click on a file is a horrible minefield of command line and config modification with horribly unpredictable and unstable results with a near weekly need to rebuild samba from scratch. That such basic functionality is so horribly difficult to achieve is a massive black mark against anyone trying to migrate from Windows and is enough to drive any adopter away (I am a Linux user for over a decade at this stage and still find networks in Linux a pain in the ass).

As it stands my Samba is completely broken and I am seriously looking at other better and more reliable options that doesn’t suck up so much of my time and my will to live. I am considering a migration to NFS but this is by no ways an obvious solution given that configuring a NFS client on Ubuntu is very version specific and not straightforward when using a non-static WIFI network over NETWORK_MANAGER.

I am just a little bit pissed off that in Opensuse’s obsession with Enterprise levels of security they make changes without considering the consequences for many home users who constantly seem to be driven to fix broken basic functionality. I would have to cautiously advise that some user friendly equivalent of the Windows share GUI be developed for the sanity of the average user base. Nautilus Share seemed to be that option, but Opensuse has hamstrung it with its obsession with security and it has effectively been left out to dry and abandoned as basic functionality. This sort of thing is killing the drive to promote Linux to the world - network sharing over WIFI is essential and basic functionality these days and it should be just a click away to achieve.

I am ready to dump Samba as a waste of time, but want to know what is the best alternative option for a simple basic sharing of media over a WIFI Network ??


It turns out that on closer inspection that the latest security update has somehow wiped the mount of my shared music disk and reverted it to a root ownership which needs to be mounted via nautilus with a root password. As I said this is the Nazi application of security with total disregard for the actual functional setup of a users space. This sort of indiscriminate trashing of a users settings is totally unacceptable.
Now I am going to have to relearn the involved steps it to to setup my Music Disk mount in the first place and will probably waste half a day in the process.

Needless to say I am not impressed with this sort of behaviour.


When you want to rant (to whom?, your fellow openSUSE uers here?), you better start a thread in Soapbox. When you want technical help, you better stick to the pure technical facts and questions. I doubt that many people feel the urge to try to help you when they first have to dig deep in a post to find the technical information they have to work with.

While this might be seen as some of the technical information hidden inside your story, in my opinion it is complete nonsense. A simple zypper up will never update you from one version of openSUSE to the next.

While this might be seen as some of the technical information hidden inside your story, in my opinion it is complete nonsense. A simple zypper up will never update you from one version of openSUSE to the next.

It did - but it didn’t do a complete upgrade. it trashed certain basic functionality which meant that I subsequently had to perform a zypper dup to get a stable system back. Before I did the zypper dup it reported in Gnome settings that it was Leap 42.1.

Go figure why this happened because I took great care to avoid doing a zypper dup because I wanted to avoid moving to Leap. This seem to be a fine example of exactly the behaviour I was talking about.

I am currently trying to recreate my automount of my hard drive, which as I remember from last time i had to do it, is not as straightforward as it could be. But here’s the point - do you think its good practice to have an update process which routinely takes a user setting which has functioned flawlessly for over a year and randomly changes it without notice. how do you think that would be received in a real Enterprise environment where the loss of access to a shared harddrive for a day whilst a tech repaired the damage would cost real money to the end user ??


Maybe a moderator would move this to the soapbox where it can be duly ignored by the development team.


It seems that you have a misunderstatding about the openSUSE forums. The members here are predominantly openSUSE users (like you). Not developers. Thus when you rant, your audience consists of your fellow openSUSE users.

The openSUSE users that roam the Technical Help forums spend their spare time as volunteers in trying to help other openSUSE users. Thus, in my opinion, those who ask for help, should try to provide the maximum of technical information to make efficient helping possible. Else their requests might simply be ignored by potential helpers because they see a more fruitfull cooperation in other threads.

Please think this over and maybe start another thread here when you want technical help. I will move this to Soapbox. I have no idea if there are poeple there interested in your rant.

This is CLOSED for the moment.

Moved from network/Internet and open again.

I’m sorry to hear of your experience. For me by far the easiest way of sharing stuff is via scp. Simply set up an sshd server, allow port 22 on firewall on you’re good to go. Also it’s easy to test if the server is working with any ssh client by simply trying to log in. The problem with this is that because of encryption this way of file sharing may not be fast.

If you want to mount something you need to look into SSHFS setup.

Regarding Samba it should be quite easy. Once you set it up properly just back up your smb.conf and copy it over again whenever some system updates break something.

So I solved the problem, which was only indirectly related to Samba. i created a mount point for my shared Fat32 drive using the partitioner. i then added the following line to my fstab file to allow all user access:

/dev/disk/by-uuid/4A9E-89E8 /home/stephen/Music_drive vfat user,rw,umask=111,dmask=000 0 0

I added the following lines to my smb.conf

usershare owner only = false

guest ok = Yes
inherit acls = Yes
path = /home/stephen/Music_drive
read only = No

That got things back up and running again and all looked good and stable for 4 days. Today I switched on and the share was down again. Two reboots of both the Kodi and Leap 42.1 system failed to get it running again.
I reran the Yast samba server util changing no settings - which started the share over again. There have been 2 or 3 updates since I did the repair work so my guestimate (based on previous experience) is that each update has about a 33% chance of breaking Samba.

I will look into setting up a ssh share system and other alternatives.


Seems this is a persistent and ignored issue for Opensuse:

People wonder why Linux in general and Opensuse in particular remain floundering in the backwaters of OS usage. Its no surprise to me and I have been an exclusive Linux user (mainly Opensuse) for over a decade. Shame.


It hasn’t fallen over in about two weeks so maybe LEAP has resolved some of these persistent problems.

I have noticed that Bluetooth (something that I could never get working reliably before) is working fairly constistently since the upgrade to LEAP.

Things might be looking up.

If we could just get MTP recognition working easily then I could call myself satisfied.