Nautilus Will Not Open, GNOME 3.14.1

I am using OpenSuse 13.2, Gnome 3.14.1. I’m brand new to Linux. Nautilus was working fine for a month or so. I could open it from the Favorites in the Activities sidebar. Now it will not open from the Favorites sidebar anymore. I don’t know why. If I open the Terminal and issue

killall nautilus

It then opens fine from the Favorites sidebar.

About a week ago, I found myself in the Tweak Tool. Therein, under Desktop, I turned on the HOME desktop icon, which I wonder if that was the cause. I’ve since turned it off, turned it on, turned it off, restarted dozens of times. No dice.

Any help would be greatly appreciated. And please, I’m new, so provide answers in simple terms with clear explanation, since I’m trying to learn and get a better understanding.

M Ridzon

If you create a new user via YaST and then login as this test user, does the issue duplicate?

If it doesn’t then it’s probably a funky gsetting with enabling desktop icons which we should be able to sort out once you confirm above.

You can restart the desktop via pressing ctrl+F2 and enter r then press enter rather than logging out or restarting this will restart your shell.

Have a look at

I created a test user and the problem did not exist for that new user account.

Is there a way to fix it for my existing user account?

M Ridzon

There is a tool called dconf-editor (you may need to install) then press alt+F2 and enter dconf-editor press enter and then browse to org->gnome->desktop->applications->background what is the status of ‘show-desktop-icons’?

The other place to look is further down in the nautilus heading, but it may mean comparing between this and your test user.

Finally got it! I installed dconf-editor. Therein, ‘show-desktop-icons’ was checked (i.e., turned ON). I compared it against the TEST user account, which showed it as OFF. When I turned it OFF for my primary user account, everything went back to normal.

I messed around a little more in the Tweak Tool > Desktop. I found that the dconf-editor checkbox was simply changing the ON/OFF position of the slider control to turn desktop icons on or off. So in short, I could have foregone the dconf-editor and just changed the slider position in Tweak Tool > Desktop to OFF, had I noticed that was the root cause of the issue.

Nevertheless, I have it figured out now! I’m still new and I learned something else here. Thanks a ton! lol!

M Ridzon