Nautilus Slow Startup

I’m very happy with openSUSE 12.1 and Gnome 3.21 overall. One small glitch I can’t figure out is why Nautilus always seems to show me the spinning beach ball every time I open it. I realize my system isn’t super powerful, but the rest of the OS runs fine. It’s not like I can’t use it while the beach ball is spinning, it just kinda bugs me. I usually wait for it unless I’m in a hurry or feeling impatient. Is Nautilus that big of a resource hog? If so, what file manager can I use instead? I don’t like Thunar. Can anybody relate or is something maybe amiss with my Nautilus install.

System info
**openSUSE 12.1
Intel Pentium 4 CPU 2.20GHz
nVidia GeForce GT 430
MemTotal: 2061820 kB **

It is not usual
Try starting from a terminal and see if you get any feedback that you can report here

Starting “nautilus.” from a terminal works perfectly. Instantly. Starting from the dock shortcut yields a 15 second spinning cursor. Every time. Advise?

So. I just installed gnome-terminal to see if it might fix the issue in the process of installing something to nautilus. The bad new is it didn’t fix it. The good news is gnome terminal is cool!

You are using Gnome
Yet you had to install Gnome Terminal?

Sorry. I meant to type nautilus-terminal…

Nautilus Terminal is an integrated terminal for the Nautilus file browser.

http://i403.photobucket.com/albums/pp120/gldfshkpr/gnome-terminal.png

I’m wondering if it would be okay to uninstall Nautilus and re-install… would I even have a GUI to do that?

gnome-commander?

IME, that’s not going to change anything. What was meant, is that you open gnome-terminal, and then start Nautilus from the command prompt in the terminal by typing “nautilus”. This will start Nautilus, and throw a lot of info in the terminal window, that could be used to find out what’s causing the slow starting.

I already did that. Like I typed in a previous post… “Starting “nautilus.” from a terminal works perfectly. Instantly. Starting from the dock shortcut yields a 15 second spinning cursor. Every time.”

It’s very puzzling. I found this fix elsewhere.

January 13th, 2011, 08:58 AM
I had the same problem.
It was nautilus issue, segmentation fault after update.

The solution:

  1. delete cached packages from /var/cache/apt
  2. disable all third party repositories
  3. completely remove nautilus and gnome-session packages
  4. reload package data
  5. install nautilus and gnome-session
  6. reboot

Steps 2-5 easily done from synaptic.

Good luck.

I’d really like to not have to jump through all those hoops! I mean, I haven’t updated. This is a fresh install.

Edit: Oh, and “…throw a lot of info in the terminal window, that could be used to find out what’s causing the slow starting.” Terminal just starts Nautilus. I don’t get any info after that unless I should be looking somewhere else?

Well, if something’s missing, it will definitely “throw” info :smiley:
On the solution provided: its for a debian system, and I personally doubt the solution provided. Reinstalling when you know you removed files, OK, but since this is a clean install it should work OOTB.

Question: do you have the NVIDIA proprietary driver installed?
Question2: did you try to remove Nautilus from the dock, then readd it again?

I do have the nVidia driver installed. No issues with that. I just removed the Nautilus shortcut from the dock and added. No joy. Same behavior exists. It’s worth noting this behavior exists launching from the Gnome shell Applications shortcut as well. The only time I don’t get the spinning cursor is when I launch from Gnome Terminal. Is there a cache I can clean? As far as I know this has acted this way since I installed openSUSE. About a week ago.

Sorry, I’m out of options now. Phenomenon does not exist on my laptop.

Can I restart Nautilus? Kill it then restart it? How would I attempt that?

More clues…

Once Nautilus is started up completely (the spinning cursor stops) I’m able to open a new window instantly (no spinning cursor). It really is an annoyance more than anything.

Kind of a bummer they never “report(ed) back”…
http://forums.opensuse.org/english/get-technical-help-here/applications/467804-nautilus-impossibly-slow.html

I do have a bunch of this error in my .xsession-errors log

(exe:6655): Gdk-WARNING **: XID collision, trouble ahead

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): Clutter-WARNING **: The actor ‘uiGroup’ is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(nautilus:3880): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)’ failed

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

(gnome-shell:3860): St-WARNING **: Couldn’t parse family in font property

I seemed to have solved it by setting all themes to default and turning off “User Themes Extension”.

UPDATE

I’ve narrowed down the behavior to turning off (in) Advanced Settings>Desktop>“Have file manager handle the desktop”. With this extension switched on I get a spinning cursor in Nautilus. Turning it off, Nautilus starts right up without the spinning cursor. The downside is with it off, I can’t manage my wallpaper. For some reason it’s defaulting to the green SUSE wallpaper. I’ll investigate this phenomenon further. If anybody has any fixes for that please chime in here.

openSUSE 12.1
Gnome 3.2.1

-Kirk

I can confirm this. When I switch the above function “On” I get the reported behavior. When I switch it back “Off” the problem disappears.

I cannot replicate this problem. Whether “Have file manager handle the desktop” is switched “On” or “Off,” User Menu → System Settings → Background works as expected on the two systems I’ve tested.