Nautilus does not work after updating to 11.3


The reason why I’m asking help here is because I’m being continuously ignored in #opensuse-irc-channel in freenode.

I updated from 11.2 to 11.3 couple of days ago. I have always used gnome and loved it. Update from 11.1 to 11.2 didn’t bring any problems and neither did from 11.2 to 11.3. Update went fine, no errors whatsoever occurred. Of course I had some problems with nvidia drivers and it was hard to get dual screen to work, but I managed.

After that I figured out that nautilus is missing, because my desktop was empty and no right clicks worked.

So I tried to run it from command line to see what it prints out:

[03:39:33] peikko ~ $ nautilus
nautilus: symbol lookup error: nautilus: undefined symbol: nautilus_file_info_getter

In irc they said me before that I have mixed packages or something. I don’t know what’s the case but my nautilus just won’t work. I ran “zypper dup” and synced the packages, and after reboot I figured maybe nautilus from 11.2 would work, so I one-click-installed it from without adding the repo of course. And for some reason it worked, maybe because I had zypper dupped before.

Being happily using my computers couple of days I noticed video thumbnails don’t work any longer, so I killed nautilus. And duh, it didn’t start again. I reinstalled nautilus from 11.2, and it looked like this: (say if the url does not work, but it’s like all ripped out -version of nautilus, acting really weird…)

I decided to update it back, and live without nautilus until I find the solution. This is also my server, so reinstalling the system is not an option because I have all those confs and I don’t have hard drive for backuping.

I also tried again zypper dup from official repo with no joy. I also tried zypper dup & reboot from couple of other repos, like gnome latest for opensuse 11.3, but nothing changed.

I’m hoping some of you can help me. Maybe it was a bad idea to update after all…

Please help me (god),


I fixed this by downloading nautilus source, and configuring it like this:

./configure --prefix="/home/rolle/nautilus-from-source"

and installing it and running from home directory. Then:

ln -s /home/rolle/nautilus-from-source/bin/nautilus /usr/bin/nautilus

Only solution for now… any ideas are welcome.