Nautilus cannot handle computer: network: etc. -links

Howdy,

I’m writing here because google results only showed ubuntu related bugs and similar, and since I have OpenSUSE 11.0… (gnome)

My problem is that I cannot open Computer, Network, or Trash, because nautilus is saying it cannot handle those kind of places… “Can’t view “computer:” location - Nautilus cannot handle computer:-locations” roughly translated from my finnish suse.

I don’t know in which point this is happened… automount also doesn’t work, and I’m thinking maybe it’s related to this problem. Every time I plug removable device to usb (for example memory stick, flash drive, or memory card reader), nothing happens! it used to mount automatically and pop up the folder. It’s frustrating to mount as root from command-line every time I want to upload photos from my camera etc, and type as root “mount /dev/sdd1 /media/memorycard” and so…

Somebody said that gvfs-update is behind this bug or something, but it is safe to reinstall or install the older version, and I guess that advice was for ubuntu only, like I said before…?

Do anyone else have these problems? Can somebody give a hint? I’m dying for an answer. Thanks in advance, I really appreciate if you can help!

ps. My suse is probably a complete mess since I have done some of my own modifications, but I think this one is solvable…

Yours,

Roni Laukkarinen

Bump, anyone? Please. :frowning:

Waiting for someone to react. Do any of readers know? I need just a little hint which direction to go next. I’m totally out of ideas right now.

Hi
If you create a test user do you see the same issues? The other thought
is to have a browse through your gconf file with the gconf-editor.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.23-0.1-default
up 3 days 4:35, 2 users, load average: 1.10, 0.53, 0.53
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14

Hello!

Long time no talk here. Anyways, I reinstalled whole system and updated to OpenSUSE 11.1 at the same time, and everything worked fine. Now I have installed some security updates, and unfortunately again some packages from source… can’t recall what exactly, webkit or something? when tried to get facebook-notify for gnome to work. Didn’t work out.

So, “can’t handle computer:” -links again! In 11.1! I googled around and found this article which is surprisely started by me. What to do? or wait to 11.2 to solve this?

Thanks,

Rolle

If you know what you are doing, from the Linux terminal as root, rename your home directory, use YaST to delete and recreate your user account with the same UID and GID, this should give you a fresh home folder and Nautilus should work when you login. Then move your data across from the original renamed home folder.

The above assumes “something” is wrong with your Gnome configuration, perhaps from too many updates, so starts afresh. Obviously, don’t move across your old Gnome stuff, so you will have to spend an hour or so tweaking your new desktop settings.

If this isn’t clear, sorry, but if you’re not 100% sure, don’t do this.

Got all back by reinstalling glib, gtk, libwebkit, python-webkit.