Nautilus address bar does not show the filesystem path / Text Location Bar

Hi I have openSUSE 11.3 Gnome installed. The nautilus address bar shows the “Button Bar” and if I press Ctrl+L it swaps to the “Text Location Bar”. The Text Location bar is where you see the full path to the directory that you’re viewing.

But I can’t set the default addressing to the Text Location Bar. The help file says to do this:

To always use the text location bar, click on the toggle button at the left of the location bar.
Unfortunately there is no working “toggle button” in my Nautilus.

Here’s a screenshot showing what I see.

There is a button there I suppose, but when I click it nothing happens.

What else should I do to get the text location bar (i.e. the full path) to be the default view in the address bar?


Hello swerdna,

<CTRL> l

It’s just tempory, enough for cut and paste and manual entry of a uri … maybe something in gconf to change the default … not sure!

Have fun!


Thanks oxala.
That’s what I said in the intro post. The trouble is that the “text location bar” won’t stick. If I click another folder in the browser, Nautilus reverts immediately to the “button bar”.

Hello swerdna,

Sorry I did not read your original post more carefully …

Toggle “text” location ON

gconftool-2 --type=Boolean --set /apps/nautilus/preferences/always_use_location_entry true

Toggle “text” location OFF

gconftool-2 --type=Boolean --set /apps/nautilus/preferences/always_use_location_entry false

Let’s hope the gnome devs put a push-button toggle back.

Be well!


Excellent. Thank you.