natural scrolling in Gnome doesn't stay enabled

I have an Asus ultrabook and am trying to use natural scrolling for the touchpad. I can enable it in gnome mouse settings but the action isn’t preserved after a reboot. the check mark is still there, but it has no effect. it’s been like this throughout the 13.1 beta cycle, i forgot to report it earlier. thanks

I have a similar issue on a Lenovo T440p. Enabling natural scrolling does nothing at all - even the test app in the mouse settings. I have logged out and in again - nothing helps.

Same issue, on a Lenovo Thinkpad L440. I have never, ever encountered this problem on other distros, and am pretty clueless on what’s causing this.

What type of touchpad?

/usr/sbin/hwinfo --mouse

I have a “SynPS/2 Synaptics TouchPad” which works fine, both via the GUI and via gsettings from the CLI;

gsettings list-keys org.gnome.settings-daemon.peripherals.touchpad

gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'two-finger-scrolling'
gsettings get org.gnome.settings-daemon.peripherals.touchpad scroll-method

gsettings get org.gnome.settings-daemon.peripherals.touchpad natural-scroll
gsettings set org.gnome.settings-daemon.peripherals.touchpad natural-scroll true
gsettings get org.gnome.settings-daemon.peripherals.touchpad natural-scroll

Why is this thread in Beta?

Anyway - if you are using synaptics and have problem, check that horizontal scroll is disabled (synclient | grep Scroll). Apparently it fails to change VerticalScrollDelta (required for switching between scrolling modes) if horizontal scroll is disabled (HorizontalScrollDelta = 0).

Yep, confirmed – HorizontalScrollDelta was set at 0. I didn’t want to meddle with the text config files, so I used gsynaptics to simply enable horizontal scrolling, and that made HorizontalScrollDelta non-zero, enabling “natural scrolling”.

I can’t say this issue exists in pre-release, since I’m only on Tumbleweed. Maybe it’s best to lock this thread.