Nasty video problem!

I was watching a very high-res video this evening, when this happened to my screen](

I tried killing the x-server and re-logging back in, but it was the same.

I then tried turning the laptop off for a few seconds, but when I got back to the desktop I had artifacts on the screen! Not many, but definitely plenty of missing pixels.

I then booted into Windows and that got rid of the problem.

I’m using -

openSUSE 11.2 32bit
Nvidia driver v190.42 (compiled)
Nvidia 8400m gs

Anyone seen this before or have any ideas what is going on? It’s quite scary when something persists after a power down!

Some folks have had issues with the nvidia .42 driver and have rolled back. Myself though, no problems so far.
Easy enough to try.

By compiled do you mean init 3 and ran the installer?
190.42 is the current nvidia approved driver but if the problem persists then roll back to a previous as suggested may prove usefull. You may also want to check the nvidia forums for assistance too.
A friend is having a similar issue but instead of a garbled screen and after one click install the reboot drop to a tty and fails to boot the desktop.
I’m leaning towards the driver as the issue as it is not suse specific. Any ideas on the best driver as he has an 8200 which is similar to the 1st posters card.
Possible the driver may have issue.

Yeah, I’ll give it a try. Although I haven’t had a repeat of the problem since, and I managed to watch the TV show the whole way through!

Although the 2nd time, I disabled desktop effects before I tried to play it again, that could have had something to do with it.

My laptop was really struggling to play the video file, it was a Matroska with that x264 encoding.

Giving that I have home folder encryption too, it was really taxing the poor old HP.

It was very scary that the screen artifacts survived a power off, I was starting to think I knackered the video card :O.