NAS mount doen't work after uodate

Hi, I’m using an older and reliable NAS for my backup purposes.
It is user mounted at startup of system (script). Up to Kernel 6.06 everything worked fine.
NAS only supports SMB V1 / NT1 and the mountpoint in /etc/fstab mounts it with option vers=1.0
(see fstab snippet below).
After update to higher kernel versions, this doen’t work anymore.
Anyone out there any suggestions to fix this?

/etc/fstab entry:
//nas/backup /srv/nas/backup cifs rw,user,noauto,uid=username,gid=usergroup,credentials=/home/user/.nas,vers=1.0 0 0

mount script:
mount /srv/nas/backup

It is a deprecated protocol…

1 Like

Time has come to upgrade the software of the NAS. If not feasible consider upgrading the hardware. I used a Fritz!Box 7360 for eight years. Two months ago I replaced it by a 7530 AX.

Well, as mentioned in related upstream bug, current kernel should work with SMB1 server in guest sharing mode (no user authentication). This could be an option.

Well, that is for the OP to determine. :wink:

Thank you for your answers. There was an alternative possibbility to use the NAS furtheron: NAS supports a NFS server so I switched to mount NAS via NFS share.

That is a sensible option for a Linux environment. :slight_smile:

Like deano_ferrari (when there is no Microsoft involved in your shop and the NAS supports NFS, you should never have used SAMBA IMHO :wink: . And take care, it is not called a “share”. om the server it is an NFS export and on the client it is an NFS mount.

1 Like