Name resolution on local network.

Hi all

I’ve installed opensuse 11.0 on an old server, and currently can’t get it to ping the name of any windows hosts on the local network. When I ping my DC, I get this :-

ping: unknown host shserver1

I can, however run an nslookup command succesfully on the same name, so it does resolve.
This is the output of ‘dig shserver1’

; <<>> DiG 9.4.2 <<>> shserver1
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 1296
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;shserver1. IN A

;; Query time: 4 msec
;; WHEN: Fri Aug 1 16:32:07 2008
;; MSG SIZE rcvd: 27

This is the output of ‘cat /etc/resolve.conf’

search xxxx.local

where ‘xxxx’ is my local domain, naturally. I can ping web URLs no problem, and both ‘dig’ and ‘nslookup’ work fine.

To summarise, I can resolve to web urls no problem, but can’t get near my local machines. I previously ran Ubuntu on this machine and had no problems. PLEASE HELP!

Thanks in anticipation.

Try making your resolv.conf file list the domain as well as the search. IE:

domain xxxxx.local

search xxxxx.local


dig and nslookup are working because you have the search parameter correct. If you do not have the domain parameter selected, then other applications, such as your browser, will not check that domain.

Hmmm, thanks for the suggestion but that didn’t appear to work. Are you sure my dig is working if I’m getting status:servfail on local resolution? I get status:noerror when I dig web URLs.

It appears as though your bind server has a problem in the local zone files. What is your DNS configuration? Are you using bind to pull a slave copy of the .local zone from the AD DNS server?

Ermm, not sure. Do you mean Bind on Linux box? I only have the one local DNS Server on my W2k3 SBS box.

So your linux box is pointed at your win2k3 sbs box for DNS?

That’s right. That’s the address in resolv.conf. This is the first time I’ve had a DNS problem, and I’ve used windows and an Ubuntu Linux box before. I read somewhere that stopping the Avahi-daemon fixes this problem, but it didn’t work for me :frowning:

I know that there’s a problem with pinging hostnames that end with .local

And there is a fix for that (because I had the same problem), unfortunately I can’t find it at the moment.

And here’s the solution:

Name Resolution Problems with “.local” Domains

it is because you use .local


mdns off

into /etc/host.conf

Oh wow! Thanks so much for that!:slight_smile: