nagios 3.0.6-1 install on OpenSUSE 10.3

I downloaded nagios 3.0.6-1 tarball and made an RPM (rpmbuild -ba
/path/to/nagios.spec). I now have the RPMs under
/usr/src/packages/RPMS/i586/. If I run “rpm -ivh
nagios-3.0.6-1.i586.rpm” I get error:

error: Failed dependencies:
/usr/bin/logger is needed by nagios-3.0.6-1.i586
chkconfig is needed by nagios-3.0.6-1.i586
initscripts is needed by nagios-3.0.6-1.i586

I symlinked /bin/logger to /usr/bin/logger to no avail. chkconfig
installed in /sbin/chkconfig. Couldn’t find any RPM for initscripts.

Thanks for any help with resolving this issue.


henders254

henders254’s Profile: http://forums.opensuse.org/member.php?userid=3146
View this thread: http://forums.opensuse.org/showthread.php?t=405143

Hi
3.0.6 is available in the repositories;
http://download.opensuse.org/repositories/server:/monitoring/openSUSE_11.1/

Have a search here if your looking for a package;
Get It
or run


/sbin/yast2 webpin_package_search

Since openSUSE does things a certain way, what I normally do is grab a
src rpm from an earlier version and just update the tarball and build
from that.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 9:45, 2 users, load average: 0.45, 0.25, 0.14
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

This might also help you on your way with openSUSE specific
configuration and options…: ‘Installing Nagios on openSUSE’
(http://www.diwi.nl/node/3)

Cheers,
Wj


Have a lot of fun! WJM

Magic31’s Profile: http://forums.opensuse.org/member.php?userid=289
View this thread: http://forums.opensuse.org/showthread.php?t=405143

henders254;1928261 Wrote:
> I downloaded nagios 3.0.6-1 tarball and made an RPM (rpmbuild -ba
> /path/to/nagios.spec). I now have the RPMs under
> /usr/src/packages/RPMS/i586/. If I run “rpm -ivh
> nagios-3.0.6-1.i586.rpm” I get error:
>
> error: Failed dependencies:
> /usr/bin/logger is needed by nagios-3.0.6-1.i586
> chkconfig is needed by nagios-3.0.6-1.i586
> initscripts is needed by nagios-3.0.6-1.i586
>
> I symlinked /bin/logger to /usr/bin/logger to no avail. chkconfig
> installed in /sbin/chkconfig. Couldn’t find any RPM for initscripts.
>
> Thanks for any help with resolving this issue.

AFAIK nagios was in the 10.3 repo already so why did you have to
compile from source? Is it because you needed a newer version? Remember
that the spec file provided by the upstream source is often modified
somewhat by the distro vendor. If you really wanted to build from
source, it would be better to start from a SRPM for OpenSUSE first,
usually taking one from a more recent release works.


ken_yap

ken_yap’s Profile: http://forums.opensuse.org/member.php?userid=221
View this thread: http://forums.opensuse.org/showthread.php?t=405143

Also you should try the software search at software.opensuse.org. I just
did and I see that at least two people have built 3.0.6 for 10.3 and
are providing the packages.


ken_yap

ken_yap’s Profile: http://forums.opensuse.org/member.php?userid=221
View this thread: http://forums.opensuse.org/showthread.php?t=405143