N00b here: I can't get the most simple LAN File Sharing to work

Hi there, I want to transfer large amounts of data between a Windows 7 Desktop and an OpenSUSE Laptop (KDE, latest version) via LAN. They are connected, but can not find each other. Please note that both are also connected to the same wifi network for internet access. After following this tutorial: Quickly Access Windows Shares From openSUSE Linux With Samba | Liberian Geek I can transfer files over wifi, but I desire gigabit speed over LAN. Please help/tell which additional info you need.

There are two ways I do such. One is through FTP using VSFTP. The other is through SAMBA. Samba can be a little tough for the uninitiated as I was. So I was recommended this site which I pass on to you. Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x aka: Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x

b
On 10/24/2012 2:36 PM, CrisisCorE wrote:
>
> Hi there, I want to transfer large amounts of data between a Windows 7
> Desktop and an OpenSUSE Laptop (KDE, latest version) via LAN. They are
> connected, but can not find each other. Please note that both are also
> connected to the same wifi network for internet access. After following
> this tutorial: ‘Quickly Access Windows Shares From openSUSE Linux With
> Samba | Liberian Geek’ (http://tinyurl.com/26omqqm) I can transfer files
> over wifi, but I desire gigabit speed over LAN. Please help/tell which
> additional info you need.
>
>
CrisisCorE;

As Samba works just fine over wireless, I think your problem may be how the machines are
connected. First turn off the firewall for testing.

Can you explain more just how you connected the two machines over your wired LAN?
Did you use a cross over cable? Did you connect via a switch or hub? If so did you
assign static IPs?
It might help if you posted the results of:


/sbin/ifconfig -a

You may also force samba to use a particular interface with the following parameter in the
Global section of /etc/samba/smb.conf. For example:


interfaces = eth0

See the writeup on the interfaces parameter in: man smb.conf

As far as I know Samba listens on all the interfaces (unless the above parameter is set),
so this should not be needed. However I have not tested this.


P.V.
“We’re all in this together, I’m pulling for you” Red Green

Thanks for trying to help me.

eth0 Link encap:Ethernet HWaddr 00:22:15:84:EA:AE
inet6 addr: fe80::222:15ff:fe84:eaae/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:156 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:20977 (20.4 Kb) TX bytes:11975 (11.6 Kb)

this is the ifconfig output for eth0.
The machines are connected directly over one short wire (I tried a different one as well)
I dont think its a crossover cable since it doesnt have a label saying so. I also tried connecting with one of these resulting in the computers not recognizing each other at all: http://www.kabelstudio.de/images/product_images/info_images/26_0.jpg

On 2012-10-25 19:06, CrisisCorE wrote:
>
> Thanks for trying to help me.
>
>> eth0 Link encap:Ethernet HWaddr 00:22:15:84:EA:AE
>> inet6 addr: fe80::222:15ff:fe84:eaae/64 Scope:Link
>> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
>> RX packets:156 errors:0 dropped:0 overruns:0 frame:0
>> TX packets:48 errors:0 dropped:0 overruns:0 carrier:1
>> collisions:0 txqueuelen:1000
>> RX bytes:20977 (20.4 Kb) TX bytes:11975 (11.6 Kb)
>>
>>
>
> this is the ifconfig output for eth0.

which shows no Ipv4 address, so no go.

> I dont think its a crossover cable since it doesnt have a label saying
> so.

And you trust the labels? :-p

Easiest is to disable the wifi and activate the cable, either in yast or in network manager - which
depends on which one you use.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

On 10/25/2012 12:06 PM, CrisisCorE wrote:
>
> Thanks for trying to help me.
>
>> eth0 Link encap:Ethernet HWaddr 00:22:15:84:EA:AE
>> inet6 addr: fe80::222:15ff:fe84:eaae/64 Scope:Link
>> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
>> RX packets:156 errors:0 dropped:0 overruns:0 frame:0
>> TX packets:48 errors:0 dropped:0 overruns:0 carrier:1
>> collisions:0 txqueuelen:1000
>> RX bytes:20977 (20.4 Kb) TX bytes:11975 (11.6 Kb)
>>
>>
>
> this is the ifconfig output for eth0.
> The machines are connected directly over one short wire (I tried a
> different one as well)
> I dont think its a crossover cable since it doesnt have a label saying
> so. I also tried connecting with one of these resulting in the computers
> not recognizing each other at all:
> http://www.kabelstudio.de/images/product_images/info_images/26_0.jpg
>
>
CrisisCoreE;

There are two problems I see here. The first is with cabling and the second with IP address.

Cabling:
An Ethernet connection has two connections, one for sending data Tx and one for receiving
Data Rx. Tx on the first machine must connect to Rx on the second and vice versa. This
is accomplished by either using a switch (or hub) in between the machines or using a
crossover cable. A crossover cable connects Tx to Rx and Rx to Tx. A switch does this
internally. Most computer stores will carry at least a few crossover cables and a couple
of lines of switches. So first get either a switch or the right cable.

IP Address:
Each NIC needs an IP address. This is given out by dhcp or set statically. Your router
probably is assigning IP addresses to your wireless cards (acting as a dhcp server). Since
there is no dhcp server for your wired LAN you must manually assign the IPs and a Subnet
Mask. I suggest you use the private class C subnet where IPs have the form 192.168.0.x
where x is a number of your choosing, 1<x<255; and the network mask 255.255.255.0. Each
NIC needs a unique IP but the same mask.

In OpenSuse, go to YaST > Network Devices > Network Settings, select your LAN card, there
you can set the IP say 192.168.0.5 and your network mask, 255.255.255.0.

On a Windows machine go to: Settings>Network connections, select your LAN card, then
choose the Networking Tab and “Internet Protocol Version 4”, here you can set your IP, say
192.168.0.10 and the subnet mask, 255.255.255.0. The Default gate way is unimportant for
this usage. Different releases of Windows may be slightly different but all follow the
same general path.

This should get the two machines talking to one another. Note if you use your wired LAN
over another network be sure to set them back to using dhcp. Best of luck!


P.V.
“We’re all in this together, I’m pulling for you” Red Green

You guys=awesome. How could I forget to assign an IP?