Mythtv

Hi all,
I am having a problem getting Mythtv to run on Opensuse 12.2. I am having a few problems in getting the database up and running. I am installing as per OpenSuSE 11.3 - MythTV Official Wiki and everying seems to go well until I start setting up the database. Also I am trying to get the readme file for mythtv. Any help would be appreciated. Cheers PS mythtv has been working has been a long term project (years).:frowning:

My way for install MythTv with Opensuse 12.2 was:

For the MySql Database

  1. The script mc.sql wasn’t in * /usr/local/share/mythtv/* , but in */usr/share/doc/packages/mythtv-0.26-docs/database
  1. The script mysql_tzinfo_to_sql also not found, but in* /usr/share/mysql-community-server/* exist **mysql_test_data_timezone.sql **. I think that the script insert all informations in the timezone tables.

Now /usr/bin/mythtv-setup start.

Hope that helps

Michael

Thanks Micheal. Your reply has been a great help. At the moment I am working through the mythtv install from the start and will let you know the results.
Cheers fred108;)

Hi,
Regarding item 2) I ran into a similar problem in that I had to do a complete system re-install of Suse 12.2, and then mythtv_0-26.

I had the timezone working the day before, but not after reinstalling. It turns out that the Mysql-Community-Server version had been changed to version 5.5.25a-1.2.1, and I was missing the file mysql_tzinfo_to_sql.
I reinstalled mysql with version 5.5.25-3.9.2, I then ended up with the missing file in /usr/bin/mysql_tzinfo_to_sql. I then followed the instructions on the mythtv wiki. It seems ok now and so I am moving to finish my MythTV installation.

Best wiishes,
John

There’s no need to install another version of MySql. Just install packet mysql-community-server-tools. It contains mysql_tzinfo_to_sql.

BR,
Jaska

Thanks ajaska for the tip. The only problem is that when I run “mysql_tzinfo_to_sql /usr/bin/ | mysql -u root -p mysql” as root from the terminal, it goes into the command without stopping for the password. I feel that I’m close, but my stupidity is getting in way. Please help. Cheers fred108

Hi Jaska,

Thanks for that information, it was very timely. I just had to do a fresh install on an empty drive, and couldn’t find a copy of mysql_tzinfo_to_sql
after reading your note I had another look and realised I hadn’t installed the tools.

It’s amazing that having the right tool at the right time makes things so much easier!

Best wishes,

John

Problem solved. I did a fresh install on an unencrypted partition and all went well. Many thanks to all who helped. I can now leave the .deb distributions alone. Cheers fred108