Mystery messages when 42.1 loads

On every bootup, I receive the following message:

linux-3:~ # dmesg>dump-of-dmesg.txt
. . .
    1.485681] systemd-journald[104]: [/etc/systemd/journald.conf:11] Failed to parse storage setting, ignoring: persisten
. . .
    3.776528] systemd-journald[493]: [/etc/systemd/journald.conf:11] Failed to parse storage setting, ignoring: persisten
. . .
linux-3:~ #

The system functions without error, but I wish to learn why these messages are being generated. Has anyone seen this?

Maybe you should post your journald.conf file here for others to review/advise.

Thanks - here’s the journald.conf file (less the prefatory comments):

[Journal]
Storage=persisten 
# was Storage=auto - changed 07-10-16
#Compress=yes
#Seal=yes
#SplitMode=login
#SyncIntervalSec=5m
#RateLimitInterval=30s
#RateLimitBurst=1000
#SystemMaxUse=
#SystemKeepFree=
#SystemMaxFileSize=
#RuntimeMaxUse=
#RuntimeKeepFree=
#RuntimeMaxFileSize=
#MaxRetentionSec=
#MaxFileSec=1month
#ForwardToSyslog=yes
#ForwardToKMsg=no
#ForwardToConsole=no
#TTYPath=/dev/tty10
#MaxLevelStore=debug
#MaxLevelSyslog=debug
#MaxLevelKMsg=notice
#MaxLevelConsole=info

…and here’s the problem

[Journal]
Storage=persisten

It should be ‘persistent’

More info…

man journald.conf

Thanks! I wondered about that spelling (or more correctly misspelling) every time it appeared. It did strike me as somewhat odd. And the man page you directed me to makes that pretty clear. Thanks for the reference.

I will correct it and report back after I boot up tomorrow morning.

Thanks again for your help.

Glad to have been of assistance. :slight_smile:

After several cold reboots over the past few days, the following still appears (only one line instead of two as originally occurred):

    1.485872] systemd-journald[104]: [/etc/systemd/journald.conf:11] Failed to parse storage setting, ignoring: persisten

Checking journald.conf, the typo was fixed and it now reads “storage=persistent”. Nonetheless, the error – probably harmless – won’t go away.

Is there another location where this setting resides (besides /etc/systemd/journald.conf)? I read the relevant man pages and searched for this, but did not find anything. And a search of the file system for “storage=persisten”
did not turn up anything.

First, you can see if there is anything useful in the log output displayed by

systemctl status systemd-journald

If you cold booted the following should not be necessary but you can try force re-loading the configuration anyway

systemctl force-reload systemd-journald

And, although the above command forces re-loading/re-reading the changed configuration specifically, the following will force the entire systemd to reload all its configurations

systemctl daemon-reload

If the above don’t provide new clues or a resolution, then you might try re-installing with the following

zypper up

I suspect that although you fixed the source of the problem, something has cached the setting so is continuing to throw the error. Note that the error is still referring to the same source (journald.conf) so as long as it’s clean there’s probably not more to do there.

HTH,
TSU

TSU -

Thank you. I gather that the value is floating around in a cache. Here is the output from systemctl status systemd-journald:

linux-3:~ # systemctl status systemd-journald -l
systemd-journald.service - Journal Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-journald.service; static)
   Active: active (running) since Wed 2016-11-23 06:06:30 EST; 7h ago
     Docs: man:systemd-journald.service(8)
           man:journald.conf(5)
 Main PID: 487 (systemd-journal)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-journald.service
           ������487 /usr/lib/systemd/systemd-journald

Nov 23 06:06:30 linux-3 systemd-journal[487]: Runtime journal is using 8.0M (max allowed 197.5M, trying to leave 296.3M free of 1.9G available ��� current limit 197.5M).
Nov 23 06:06:30 linux-3 systemd-journal[487]: Runtime journal is using 8.0M (max allowed 197.5M, trying to leave 296.3M free of 1.9G available ��� current limit 197.5M).
Nov 23 06:06:30 linux-3 systemd-journal[487]: Journal started
Nov 23 06:06:31 linux-3 systemd-journal[487]: Permanent journal is using 872.0M (max allowed 4.0G, trying to leave 4.0G free of 453.6G available ��� current limit 4.0G).
Nov 23 06:06:32 linux-3 systemd-journal[487]: Time spent on flushing to /var is 980.644ms for 1077 entries.

Nothing jumps out at me, but I note that the fourth line includes “Permanent journal.”