MYsterious Bridge and unknown network status

When I installed 11.2 Kde I configured network via yast manually, there are two cards, eth0 and eth1 (unplugged). I set eth0 with static address, dns servers etc and everything worked fine.

Yesterday, however, I noticed in sysinfo:/ in Konqueror “Unknown Network Status”, and when I checked in Yast I saw a mysterious “Network Bridge”, br0, that has all my static settings while eth0 stays “not configured” but is listed under bridged devices.

I wouldn’t care so much but this configuration might be the source of other problems, most notably zypper not being able to download repos, or other computers not being able to “fish:/” to this machine.

How can I safely get rid of the “bridge” and use eth0 instead, no operating system on this machine has ever used a bridge, it plugs straight into the router.

I guess I could just delete it, but OpenSuse put it there for a reason, and might do it again. Should I just go with Kde Network Manager instead of Yast “with ifup”?

I can not answer your main question (hope someone else will do that), but when you are using a static configuration, using network manager instead of ifup will only bring you disadvantages. To name one: your network will not be started until someone logs in instead that it will be started on runlevel 3 and/or 5, which will not be nice if the system runs any services.

@OP: I rather suspect you configured it in by accident. It’s normally only associated with virtual machines or special network setups. Try just removing it and setting up a normal eth0 interface.

One of my workstations running opensuse has two ethernetports and sysinfo had some troubles in detecting if i had connection or not.

It seems it only will detect the online status if I use ifup instead of networkmanager to manage my connection and shutdown the other port completely.

If not, sysinfo is returning ‘unknown networkstatus’

Is it just me, or is opensuse a bit difficult in networksettings?
I’ve been using opensuse for years now since 10.0 and I’m used to having troubles with networksettings?

I know other distros, some Redmond stuff. openSUSE is not difficult in networksettings IMHO. Maybe you missed something somewhere, can’t tell.

AFAIK ken_yap is right, you accidently misconfigured. I tried, cannot reproduce.

Use ‘ifup’, configure IP, use and for DNS (Google’s public ones, just to make sure it’s not your ISP that’s bothering you with new DNS’s -met that this week-) and your router’s IP as the standard gateway. Check and check again, save and exit.

Sorry for abandoning the thread, I started it to resolve updating issues but they’d been solved independently.

Now I’ve deleted the “bridge” and reset network to eth0. So far everything works just fine - Internet, local browsing, but Network status in sysinfo is still “unknown”.

It doesn’t affect anything else, as far as I can see.

Originally the bridge could have been installed by Xen virtual box, which I have removed now. On uninstall it erased Xen option from grub but could have left “bridge” setting somewhere else.

Yeah, I think Xen uses a bridge. VBox can but it’s hidden.

Well, Xen is gone, “unknown network status” remains. There’s also occasional “fragmentation error” that, I suspect, prevents me from logging in automatically.

Perhaps Xen left some garbage, perhaps it’s something else.

Network itself works fine in every respect, btw.