MySQL

1 Речь идёт о репе MySQL —> Index of /repositories/server:/database/openSUSE_Tumbleweed
Не устанавливается из него mysql-workbench так как просит libzip.so.1(64bit), а в системе libzip2 предоставляет libzip.so.2

2 Наболевшая тема… Почему с такими задержками обновляется mysql-community-server ?
И 5.5.18 Кто то думает собирать?

Предлагаю обмануть систему и создать символическую ссылку.

  1. Надо просить майтейнеров пакета libzip собрать версию под Tumbleweed.
  2. На русскоязычной ветке форума, я не встречал людей занимающихся этим пакетом, не уверен что вам тут смогут ответить.

to aliaksei1818 они собираются в разных пакетах, не думаю что они взаимозаменяемы и совместимы.

Но это вообще бред :slight_smile:

При сильном желании я могу уйти с Tumbleweed и вернуться на 12.1, но я хочу что бы пакет собрали нормально под актуальную версию libzip, а то получается что пакеты на Tumbleweed старее обычных.

Запостил http://forums.opensuse.org/english/get-technical-help-here/tumbleweed/469045-mysql.html Посмотрим кто что ответит…

А что горит так 5.18 ?
Там что новое и вкусное ?

Желание иметь всегда свежее и стабильное ПО из реп, как это организовано в ArchLinux.
Tumbleweed был создан именно для этого, но толку с него щас не то что нуль, а вообще отрицательное число.
Конкретно в 5.5.18 по сравнению с 5.5.16 ничего особо-нового нет, но например перехода на 5.5, я ждал очень долго, а переход на 5.6, когда его выпустят стабильным, на openSUSE точно выйдет только в следующем релизе.
P.S. Капец, полез на MySQL за change log-ом, уже 5.5.19…

Вы немгого заблуждаетесь по поводу того что для Tumbleweed ПО из дополнительных репозиториев будет\должно быть новее. Это не так, версии ПО в доп репозиториях, что для обычной openSUSE, что для Tumbleweed будут одинаковые. Тут Переход на Tumbleweed - Page 3](http://forums.opensuse.org/forums/showthread.php?t=463726&page=3#post2373312) я пытался объяснить как это работает и что такое Tumbleweed.