MySQL Workbench update on 11.3

I’m running OpenSuse 11.3 which comes with MySQL Workbench V 5.12.16-8.2. This version hangs on connections and has several other behavior problems that others have reported. For several reasons, I need 5.2+ .

As a relatively new regular user of OpenSuse, I’ve learned that it’s much better for me if I work within the package environment (read: I’ve made mistakes and am willing to learn) so I’m reluctant to try to just load the Suse rpm off the site.


  1. is there a more recent release of Workbench in a repository I’ve not found yet?
  2. if not, what’s the safest way to install this as an rpm that will not impact the rest of the package management system?

Thanx for all your help and interest.


It’s in UNSTABLE - Download openSUSE 11.3

Well, I know that it’s all about UNSTABLE and unsupported and all that but, when I tried to install it, YAST complained about missing:

Not surprisingly, when I installed it anyway, it had prolbems with making connectings. linking to other versions of the connection libraries, I still get errors.

Any clue about where to get libmysqlcppconn4? I looked at official and unofficial areas and in checking on google, I see where others have had the same problem but find nothing that “fixes” the error or gets workbench working.



Looks as if it is only available as a .deb at the moment; so you will need to get the .deb package and use alien to convert it to an .rpm. Then get YaST to install the rpm before you reinstall Workbench.

Looks like there are issues with the building…

Suggest you contact the maintainer under the ‘Actions’ dropdown.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 6:41, 2 users, load average: 0.33, 0.20, 0.07
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

YUK!! and likely to create more issues. IMHO there is an issue with the
package and needs to have a bug reported against it.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 3:06, 2 users, load average: 0.13, 0.11, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12

I found the package:

on the download page and it seem to have loaded and runs ok. I don’t have time today to figure out how to file a bug report at this moment but wanted to let you know what I found. If I find this breaks something else, I will, reply back on this thread.