mysql-workbench replacement

Hi, there!
I just installed openSuse 13.1.
I installed MySQL Community Server 5.6, uninstalling previously mariaDB.
But I can’t install and get to run properly, any workbench.

Can somebody tell me about a tool for openSuse 13.1 similar to MySQL-Workbench?

I made ​​many diagrams with workbench and I’d like to continue using them.

Thank you very much.

What have you tried to install it?

Try this: Install package server:database / mysql-workbench

I tried with MySQL site (]( :: Download MySQL Workbench) for Fedora and RedHat platforms, but I can’t install it.
Also, I installed it from -> openSUSE Factory -> official release, but I couldn’t connect to databases.

Thank you, for reply.

Why Factory? Why didn’t you take the package for 13.1 (from server:database, where I linked to as well) if that’s what you’re using?

And: is MySQL even running?

systemctl status mysql.service

Or check in YaST->System->Service Manager.

OK, you’re right. I’ll try with the package you sugest.

Thank you, very much.

I had the same problem, thanks for the solution.

I also used factory repo - and the explanation “why” is very simple. Always if i want to add some package that does not show up in my yast i go to and search for it there and do 1-click install

If You write “workbench” the main button for 1-click install is giving you the factory repo instead of 13.1

I think it’s a bug in the www

Not really, I think.
OK. Factory is shown on top of the list, but 13.1 is expanded by default here.

Btw, you can change for which openSUSE version to seach for in the settings:

I tried to install each package for 13.1, but I can’t resolve needed dependencies.

Thank you again.

Using Yast or zypper it should resolve dependencies for you.

But they can’t do it!

I wonder how others are installing then??

When I installed the version from server:database, it only required one additional package, which is also contained in server:database.
So add that repo to your system and the dependencies should get resolved automatically.
The easiest thing is to just click on the 1-click install on that search page, this will add the repo to your system and install mysql-workbench.

Since MySQL Workbench CE (GPL) 6.0.8 11354 build 833 on 13.1 64-bit gives a segmentation fault for me, I am using Squirrel (version 3.5.1) and am finding it to be a reasonable alternative.