MySQL wont start

OpenSUSE 11.1 / KDE 4.1

After my filesystem was corrupted for the zillionth time it seems to have caused some more serious problems this time. Was getting a lot of segfault errors and had to rebuild the rpm database.
Reinstalled all packaged to ensure everything should at least be complete.

Trying to start MySQL via YaST Control Center > System Services I’m getting the error:
“/etc/init.d/mysql start returned 1 (unspecified error):”

So I thought I’d just reinstall the **** thing and tried to run
mysql_install_db --user=mysql
But it came up with:

Installing MySQL system tables...                                                                      
ERROR: 1136  Column count doesn't match value count at row 1                                           
090424 19:21:47 [ERROR] Aborting                                                                       

090424 19:21:47 [Warning] Forcing shutdown of 2 plugins                                                
090424 19:21:47 [Note] /usr/sbin/mysqld: Shutdown complete                                             

Installation of system tables failed!  Examine the logs in                                             
/var/lib/mysql for more information.                                                                   
You can try to start the mysqld daemon with:                                                           

    shell> /usr/sbin/mysqld --skip-grant &

and use the command line tool /usr/bin/mysql
to connect to the mysql database and look at the grant tables:

    shell> /usr/bin/mysql -u root mysql
    mysql> show tables                 

Try 'mysqld --help' if you have problems with paths.  Using --log
gives you a log in /var/lib/mysql that may be helpful.

The latest information about MySQL is available on the web at  Please consult the MySQL manual section
'Problems running mysql_install_db', and the manual section that
describes problems on your OS.  Another information source are the
MySQL email archives available at

Please check all of the above before mailing us!  And remember, if
you do mail us, you MUST use the /usr/bin/mysqlbug script!

So as suggested tried (as root)
shell> /usr/sbin/mysqld --skip-grant &
but it comes up with:

090424 19:22:25 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!                                                                

090424 19:22:25 [ERROR] Aborting

090424 19:22:25 [Note] /usr/sbin/mysqld: Shutdown complete

[1]+  Exit 1                  /usr/sbin/mysqld --skip-grant

Then tried as a normal user:

[1] 6513
090424 19:30:07 [Warning] Can't create test file /var/lib/mysql/Bakhuis-Server.lower-test
090424 19:30:07 [Warning] Can't create test file /var/lib/mysql/Bakhuis-Server.lower-test
Bakhuis@Bakhuis-Server:~/Shared/Anime/Archive> 090424 19:30:07  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.

Can’t seem to open any of the logs, get a permission error even after chmodding to 666 / kdesu kwrite.

Nevermind, seems like there is a whole lot more wrong (or well, at the very least my PHP DOM isn’t working…)

I’ll just reinstall everything as it’s most likely a lot faster than piecing all the parts together.

You are saying that your disk is getting corrupted frequently. Don’t you think you should find the cause of that?

are you sure you have the InnoDB storage engine activated in /etc/my.cnf ?

Well if you got any ideas as to why… I’d love to hear them.

  • Replaced nearly all hardware (Motherboard, Ram, CPU, Harddisk, Videocard)

No improvement

  • Reinstalled the OS

(was kinda forced to with the massive hardware differences) No luck

  • Played around with ktorrent ‘reserve diskspace’ options

Thought it worked for a second, but didn’t.

Don’t really want to spend money on a new power supply just to see if it’s the possible cause as it’s the only part left untouched compared to the ‘old’ system

And I’ve no idea what’s activated and what’s not, currently reinstalling the entire OS after backing up all my data to the raid 5 config.
Formatting the entire disk, including the home partition as that’s the only possible cause I can think of that’s causing the corruption… some dodgy seting in the home directory.

The disk content can get “corrupted” in 2 ways:
(1) Due to hardware problems of the disk. Since you have already replaced most of the hardware components, I doubt this.
(2) You have malicious programs that write to the disk. Here, the disk is OK but the content becomes useless.

One option is to try using a RAID-1 configuration to investigate this. (Of course, you will effectively get less disk space). Once RAID-1 is setup, if you notice any corruption in one of the RAID components, 99% of the cases, it will be the problem with the hardware. If you see that both the RAID-1 components are corrupted, then the culprit is some software.