MySQL upgrade crashed

I have been running an older version of Suse and MySQL for years and someone tried to upgrade it and now my production server is crashed.

This is the error message… any help would be greatly appreicated:

linux-syslog:/home/root/mysql # systemctl status mysql.service
mysql.service - MySQL server
Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled)
Active: failed (Result: start-limit) since Wed 2017-09-20 09:08:02 MST; 5min ago
Process: 9292 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper upgrade default (code=exited, status=1/FAILURE)
Process: 9282 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper install default (code=exited, status=0/SUCCESS)

Sep 20 09:08:02 systemd[1]: Failed to start MySQL server.

I am running OpenSuse 13.1
MySQL is version 14.14 distribution 5.6.28

Thank you

I’m assuming you are using the default datadir of /var/lib/mysql - if so, check for the existence of a hidden file;


If this file exists, remove it and try starting mysql with systemctl start mysql

If this fails, please check /var/log/mysql/mysqld.log and post the relevant contents from the end here.

Holy cow!! It looks like that fixed it!

I was just about ready to tear it down and rebuild from scratch…

I can’t thank you enough

Good to hear that it worked - if possible, you should look into upgrading the box to 42.3 as 13.1 no longer receives any security patches. Please make sure you have backups of all important data before you try it and because it’s a massive jump, I would suggest upgrading offline (ie. USB stick or DVD)

This is of course only really important if this box is facing the internet somehow and not inside a secured LAN.

Thanks Miuku… you’re a life saver on this one.

This server is used for network monitoring and graphing and is not Internet facing… it’s running on a VM.

To be truthful, I have so many Ruby and Python scripts running on this machine that I’m totally paranoid about ever upgrading anything on it because of issues like what I just encountered :slight_smile:

Be aware that because your machine is not Internet facing does not protect you against potentially catastrophic attack.

If you’re running 13.1,
There have been published “once in a lifetime” kernel vulnerabilities which it would still be subject to, which can result in arbitrary data written.
There have been published “once in a lifetime” vulnerabilities to the Diffie Hellman key exchange which affects practically all network encryption including SSL, SSH, VPNs and more.

In other words, if an attacker gained some kind of foothold in your network, this one machine could then be one juicy target to provide a stepping stone to very quick and immediate full network compromise. It’s also just sitting there which could be devastating if you even make a mistake one day.

You’d have to be certain that other machines with access to this machine wouldn’t be compromised by a phishing attack and more.

Depending on the nature and design/security of your network a fully vulnerable machine might be “only” an acceptable risk in some eyes but it won’t be long if not already that it’s a really, really questionable risk.