My Youtube and all Adobe Flash Player based videos are crashing

Hi all,

I am sorry if there is another post about this problem or if the category of my post is not appropriate.
I am new to OpenSuse for almost 1 week and I am doing my best to learn everything about this OS.
Please help me with my following problem: I have installed Adobe Flash Player using YaST and Wine (I didn’t know at first that I could install Flash Player using Yast) and I keep getting crashes on Youtube or other sites that have videos when navigating or going to other videos on youtube.
My Firefox is getting stuck for almost 5 seconds, then it works but without my youtube videos (I get errors such as “Please reload this page, Adobe Flash Player has encountered an error”).
I am using OpenSuse 13.1 on an Acer Aspire e1-571g with a graphical card nVidia GF 710M.
Is there any solution also to see full size videos from other sites beside Youtube? I mean sites like gorillavid or videoweed

Thank you,
Sersson

On Wed 19 Nov 2014 11:26:02 PM CST, sersson wrote:

Hi all,

I am sorry if there is another post about this problem or if the
category of my post is not appropriate.
I am new to OpenSuse for almost 1 week and I am doing my best to learn
everything about this OS.
Please help me with my following problem: I have installed Adobe Flash
Player using YaST and Wine (I didn’t know at first that I could install
Flash Player using Yast) and I keep getting crashes on Youtube or other
sites that have videos when navigating or going to other videos on
youtube.
My Firefox is getting stuck for almost 5 seconds, then it works but
without my youtube videos (I get errors such as “Please reload this
page, Adobe Flash Player has encountered an error”).
I am using OpenSuse 13.1 on an Acer Aspire e1-571g with a graphical card
nVidia GF 710M.
Is there any solution also to see full size videos from other sites
beside Youtube? I mean sites like gorillavid or videoweed

Thank you,
Sersson

Hi
Got to youtube and set your browser to use html5 instead, no flash
needed.
https://www.youtube.com/html5

Else you should consider using pipelight instead;
https://forums.opensuse.org/showthread.php/502519-Pipelight-for-13-2?highlight=pipelight


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

But what graphics driver is in use?

You didn’t mention, but could the laptop have switchable graphics

Same issue here on Acer AO722 with ATI graphics.I haven’t find a solution yet except using Chrome

You can install pepper-flash to make flash player on chromium work on Firefox. For me (Acer TimelineX with ATI/Intel), it works well.
However, I recommend using HTML5

I used HTML5 for a while as you recommended and switched back to flash as a test.The video played normaly without any problems.
Thank you

Firefox can not use pepper-flash.

But there’s this:
http://software.opensuse.org/package/freshplayerplugin

Hi,

Just installed pipelight last week, that was my second option in trying to repair my youtube problem.
But I will try it again.
Also, I’ve just modified the standard on youtube from HTML4 to HTML5, hope that will make my problem go away.

Cheers,
Sersson

Hi,

I have the latest driver from the nvidia site installed, I don’t know how to make the switch between the graphical card and the graphical card incorporated on my processor. How can I find that out?

Cheers,
Sersson

In the BIOS settings, if you are lucky.

Anyway, which GPU are you using currently?
If it’s the intel (used by default on an Optimus setup), you should not install the nvidia driver, as it breaks the intel driver’s OpenGL support (and all other Mesa drivers), which most likely would be the cause of your problem.

So please install the package “Mesa-demo-x” and post the output of:

glxinfo | grep render

The output is:

direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent

As I can see, I am using the integrated GPU from my CPU.

Then you should uninstall the nvidia driver and use Bumblebee instead.
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Or, if possible, disable the intel graphics in the BIOS settings and only use nvidia.

If you still get crashes then, you might also try to disable hardware acceleration in flash-player (right-click on a flash video and choose “Settings”).

Hey guys,

This is my first post here, I thought I’d share my experience on this. Skip to the end if you just want to find out how I “fixed” it.

I was happily running linux mint as my single OS for a couple years until I got sick of cinnamon and had a crave for gnome-shell + extensions. Tried installing debian on my root partition but things went bad and lost my mbr (their partition manager is the worst thing I’ve seen since I tried red hat back in 1997). Couldn’t recover with testdisk or gpart because my whole disk was encrypted and they don’t support that yet.

Anyways, I had already lost all my data and accepted my fate so I installed debian jessie. I installed bumblebee and got everything running (optirun and primusrun both showed my nvidia card being used correctly) until I started to experience the same crashes you mention when flash was full screen. I also installed steam and dota 2 but could never get dota 2 to run, it would crash after a few seconds/minutes in game.

I thought the problem was debian jessie, so I searched the web and couldn’t find many answers (except some devilspie trick for flash full screen that didn’t work 100%). Since this was a fresh install I just decided F*** it and went on to try fedora and opensuse. Both had the exact same issues (optirun and primusrun working but flash fullscreen and dota 2 not working).

At this point I thought the problem was bumblebee and I read how ubuntu (and mint which I used) apparently managed to do a trick to get those laptops with dual cards working without bumblebee, making them somehow use just the nvidia card (my laptop doesn’t have any options in bios to turn off the intel card). I never had to deal with bumblebee in mint, I just clicked the drivers tab in settings and clicked “install nvidia proprietary drivers” and everything worked out of the box! Flash fullscreen and dota 2 both ran perfectly! No tricks or configurations needed.

So I decided to try ubuntugnome to get gnome-shell and the nvidia drivers working out of the box. As expected I didn’t have to deal with any bumblebee, just went in the settings tab -> drivers and clicked install nvidia-proprietary-drivers and it was installed. Then I installed dota 2 and it didn’t work. Then I played flash videos full screen and the same exact bugs started happening. (I dunno what ubuntu/mint does behind the scenes, if it’s installing bumblebee and calling it nvidia-proprietary). I was happy it was not a debian/fedora/opensuse problem and out of the 3 I liked opensuse the most, so I came back.

Long story short, the problem is not bumblebee (at least for flash full screen videos not working), it’s the interaction between gnome-shell and flash plugin. I tried some trick like i said using a program called devilspie to set the focus on the flash fullscreen every time it runs. It works for some time (you won’t get the blank screen after a few seconds) but after a few minutes running the video your flash just crashes, and when it does it makes gnome-shell memory consumption jump from ~80-130mb to 400+. Even after killing the firefox and plugin-container processes it still somehow keeps the high memory consumption. It also displays a weird behavior, if you alt+f2 and then type “r” and enter to refresh gnome, normally you would see a black screen in-between, but when this happens you just see some frozen image from the video you were watching full screen. It only stops this behavior if you relog.

So how did I fix it? Well I didn’t really fix it. Like I said, devilspie only worked partially but you are free to try it (just google devilspie flash fullscreen and you’ll see people doing it for ubuntu/debian but it works for opensuse).
What really “fixed” my fullscreen issue was installing chromium and it’s pepper flash plugin. I was never a fan of chromium because privacy/google concerns and I think firefox has much better extensions, but I gotta say it’s working out of the box, no need for any tricks/devilspie. As for the extensions, my main concern was the lack of “noscript” for chromium but “HTTP switchboard” is doing a great job (it might even be better). It’s also worth mentioning adobe has ceased development for linux flash-plugin. It’s stuck in version 11.2, they only release security fixes. Google is still developing pepper-flash for linux so sooner or later we all might have to switch to chromium if we want to watch flash. That or mozilla starts to use pepper-flash or pushes html5 development so far flash becomes a thing of the past. Until then, I’ll be using chromium.

PS: After using mint for 2 years and trying debian/fedora/opensuse for a couple days, decided to make opensuse my new home. Hooray!
PS2: Dota 2 is still not working. I’m not sure yet if it’s a new bug non-gnome related or something gnome-shell related.

There’s “freshplayerplugin” which allows you to use chromium-pepper-flash in Firefox.
It is available on Packman.

PS2: Dota 2 is still not working. I’m not sure yet if it’s a new bug non-gnome related or something gnome-shell related.

You could try a different X session (IceWM e.g.) to see whether it’s related to gnome-shell.
Just logout and select something else on the login screen (click on the spanner icon).

Thank you for your tips. I read somewhere that freshplayerplugin is still alpha and not working properly (sound chopping) so I didn’t try it.

I’ll try the different X session though, thanks!

Just a small update (forum won’t let me edit my last post to add it there)

I installed pipelight to try playing flash using firefox. It required some configuration to get running, once it did get running it didn’t play videos correctly in full screen (played like half the video, leaving the other half of the screen empty). So I’ll stick to my chromium + pepperflash recommendation

I also managed to get dota 2 running. All I did was install steam and dota and it ran fine. I dunno what happened, last time I tried was with a different opensuse install (before I installed ubuntu gnome) and it didn’t work (even with bumblebee working fine). Valve just released a big patch for dota, I dunno if that’s what fixed or if I did something wrong/different the first time. Anyways, it’s working now and it even has better FPS than with my previous linux mint install.

I’m very satisfied with opensuse so far :slight_smile: