My X wont start.

Hey! First off im new at SUSE but i have come to like it a lot in just a few days. My problem is that i can’t get my NVIDIA card going, i’ve read all forumposts i could find regarding this issue. I laid my last hope to the one-click-install at, Yast was finished everything installed fine. Then i rebooted into failsafe and did the following as i read in another thread:


–add-argb-glx-visuals -d 24.

shutdown -r now

After the restart i just get a message that x has to many errors and can’t start. My xorg.conf can be found here and the log here.

Thank you in advance, Afnaf.

Well, as a matter of fact you do not use nvidia-xconfig in openSUSE. You use sax2 -r -m 0=nvidia

Of course it will work ONLY if you have the proper drivers which can be found in YaST -->>Software Repositories -->> Add -->> Community Repositories and tick Nvidia (and Packman alongiside it :). Then install G02 version of nvidia when searching in that repo.

P.S. Have a look here

Ty for your quick answer. Another question then should i uninstall the drivers i installed then or should u just run Yast again?

You have the right drivers, don’t worry.

When starting the PC clear the boot options with backspace and type 3
Just run as root sax2 -r -m 0=nvidia
after checking that settings are ok save them and press yes. You do not need to restart the pc.

After that type /etc/init.d/xdm start

It should start graphical interface, if it won’t come back here.

It worked as you said Master :wink: Thank you very much.

Then have phun and start discovering the world of Linux;)