My video problems have gotten worse.........

Hi all,

Well I posted earlier this month about me losing my 1680x1050 on my 22" monitors. You tried to help, but I could not get it to 1680x1050, even though YAST said I was already at 1680x1050.

Anyways, I did a fresh install of 11.1 with KDE4.1 last night. It is even worse, now, kind of…

I went into YAST because everything was huge. I set the resolution to 1680x1050, from the default 800x600. It didn’t change nothing upon reboot.

Next I change the monitor settings from vesa800x600 to LCD1680x1050 (My monitor isn’t listed in the list). Upon reboot, everything changed, and the picture was absolutely vivid, but it only took up about 2/3 of my total screen. There are these huge black bars on either side of the screen. Oh Well.

I am at a total loss…


Sounds like you need to install video card drivers.

Thanks Foresthill

I use onboard D945 chipset, which is being recognized by Opensuse. I can use and enable compiz. The video is listed as “Onboard D945 Intel” and “3D enabled” in the sysinfo:/


So everything is working except you are not getting the correct resolution?

Have you considered buying a cheap ATI or Nvidia card? Or are you using a notebook and can’t add a video card?

It’s not going well for you is it Heeter.

Google seems to bring some issues about with this - I was wondering how you fare with other distros, if you have tried them?

There is not a great deal in the SUSE HCL on intel chipsets either. I have intel myself but 965GM and it’s using 1.4 Mesa 7.2

full showing is:

Vendor: Tungsten Graphics, Inc
Model: Mesa DRI Intel(R) 965GM 20080716 x86/MMX/SSE2
Driver: 1.4 Mesa 7.2

Can’t think what to recommend friend

Hi Caf, thanks for your responses all the time.

I have the same Tungsten graphics, Mesa driver showing up myself, but the D945 listed.

Last night, I downloaded Ubuntu 8.10, gonna try it out. Not a big fan of Ubuntu myself.

I do have video cards laying around here (8500GT, 8600GT, X300, and so forth…) But I have issues with all vid cards as well.


Hi Heeter,

Sorry to hear you’re still having problems. This problem very much looks like incorrect EDID data being obtained from your display. I’m wondering if the following idea may help.

The intel driver has a ‘DDC’ option (default is enabled) that you can set like this:

Option “DDC” “false”

Then add

Option “PreferredMode” “1680x1050”

Make sure you have a valid modeline included.

See similar thread here.

That is strange. I get brilliant results with my Intel.

And my Main Box uses nvidia 8500GT, perfectly. Maybe the monitor is causing the problem? But it shouldn’t. And with the Yast LCD— setting it should work fine. There is a 1680x1050 setting to with the LCD option and with the correct refresh rate isn’t there??

I’ll be interest to hear what you find from Deano’s advice, interesting! Might be the solution??

Hey Guys,

I am using UbuntuStudio8.10 :frowning:

My monitor is working great at 1680x1050. I had a couple of issues correcting the xorg.conf, but the ubuntu forums helped out.

I know that I am only one user, but if there was someway that OpenSuse would figure this out, I would reload OS in a heartbeat.

For now, I am not straining my eyes looking at blurry, fuzzy resolution. (it has been nearly 6 months of this, since 10.2, and 10.3)

Thanks guys for all your help.

Thanks Caf…


Hey forgot to mention, here is my final working xorg.conf file:

Section "Monitor"
       Identifier      "Monitor0"
       Vendorname      "Acer"
       Modelname       "Acer AL2216W"
       Horizsync       30.0-82.0
       Vertrefresh     56.0-76.0
       Gamma   1.0
       Option         "DPMS"
       Option         "ConnectedMonitor" "DFP"
       Option         "ExactModeTimingsDVI" "true"
       Option         "PreferredMode" "1680x1050@60"

Section "Screen"
       Identifier      "Screen0"
       Device          "Device0"
       Monitor         "Monitor0"
       Option "ModeValidation" "NoMaxPClkCheck"
       DefaultDepth    24

Section "Module"
       Load            "extmod"
       Load            "type1"
       Load            "freetype"
       Load            "glx"
       Load            "v4l"

Section "Extensions"
       Option          "Composite"     "Enable"

Section "ServerLayout"
       Identifier      "Layout0"
       screen 0 "Screen0" 0 0

Section "Device"
       Identifier      "Device0"
       Boardname       "NVIDIA GeForce FX (generic)"
       Option          "NvAGP""1"
       Screen  0
       Vendorname      "NVIDIA"
       Option       "MonitorLayout" "TDMS"
       Option "ModeValidation" "NoDFPNativeResolutionCheck"
       Driver  "nvidia"


Well, the problem was the driver! You’re using an nvidia chipset. Everyone has been working around this being an intel issue.

No I am using the onboard D945 VGA chipset.

It lists that, I don’t know why, as I copied and pasted it from the ubuntu forums.

Thanks Deano


You know I would be tempted to use the xorg.conf and try in OS

I know it’s lot’s of work, but hey you’ll have time on your hands this week.

I just tried a Live CD of F10, was really nice. And I put it in a VM too from a DVD. Both Gnome which I don’t go for myself. But I have used Fedora’s kde in the past (F7) and it was pretty good, better than kbuntu.

When I was googling for you the other day I noticed most of the references to the chipset you have did not mention it in a graphics context but more the mainboard. So it’s all a bit confusing.

Anyway, see how you get on. I would be very sad myself to leave openSUSE behind.

You know I would be tempted to use the xorg.conf and try in OS

I agree. Now that we know a little more about the graphics chipset, there is nothing to lose. You should get the same results with opensuse given the correct nvidia driver installed.

I am trying it this weekend, once the christmas hang over is overcome…

I really want to get back to Opensuse/KDE

I do want to mention, caf, the mainboard gpu is what I am using, the D945.

I never lost my 3d acceleration, just my screen res. I still had compiz working properly off the D945 gpu.

ALthough I do have a 8500GT sitting collecting dust, might throw that into the tower this coming weekend for xorg.conf testing.


The configuration shows a NVIDEO driver instead of Intel?