My trying out openSUSE saga

I have been using Linux OS’s off and on for about 15 years. I never really understood Linux, and I still don’t, but I’m trying to learn. This go round I bought a really inexpensive ASUS Essentio at one of our local thrift stores. I set my mind to upgrade it as much as I could. When I got the computer home and booted it up, I found that the Windows 7 system was all locked. The BIOS had a password. The admin account had a password. The only available use option to log in as a guest on Windows 7. Bummer. I searched around on the internet for possible solutions and found that they were mostly buried.
It seems like there has been nothing but roadblocks in my putting the desktop back into service. I mean, it’s literally been one thing after another. I am constantly getting input that my computer is too old to do anything with. I considered taking the computer back to the thrift store to get my $45 dollars back, but I decided to open the computer up instead. To my surprise I found another Hard Drive and 16GB of RAM. Delighted with my hardware Easter egg find, I was motivated to keep on trying to make this computer my own.
I removed the bios battery to reset the bios. I changed the admin password using sys32 terminal. I found a way to install Windows 10 by downloading the ios on my Mac. And used the Windows 7 key on the computer to upgrade to Windows 10. I filled every available slot with inexpensive cards: USB 3 card, 1394 card, Pinnacle Bendino capture card, a $30 NVIDIA GT 620 card. I installed a couple more hard drives that I had sitting around the house. I upgraded the CPU from 2.7 Ghz to 3.2 Ghz. This computer has been a fun project machine.
So, now I have installed openSUSE Leap 15.5 on an old 100GB SSD as the master drive, Windows 10 as the slave, EDUBUNTU on an old Sata Drive I found, and LUBUNU on the extra 1TB Easter egg hard drive I found in the machine.
I had to install the driver for my old NVIDIA GPU in openSUSE because the video quality was totally unacceptable. After I got the driver installed, the Wayland took over and made my resolution 480p, FRUSTRATING, I could find not option to get X11 back so I installed GNOME along side KDE, and installed Chrome. And wow, magic! My openSUSE install is lightening quick with excellent video quality, not dropping 15 fps in youtube anymore.
I accomplished all this by just googling questions, but I am excited to be a part of this forum because now I can communicate with others who know, rather than finding some random instruction on the internet that may be good or may be faulty :-/

This not being a technical question, will be moved to Open Chat.

BTW: welcome to the openSUSE forums.

1 Like

Re Wayland, there do seem to be some inconsistent results with Wayland. A friend who was having problems with X11 Plasma accidentally tried Wayland and found that it worked fine. I cannot get Wayland to work but X11 Plasma works fine.
Both of us are using All-in-one desktop computers of a similar vintage but from different manufacturers.

1 Like

I don’t think Wayland provided NVIDIA a method for me to accept the terms of using the proprietary driver and that’s why I got stuck with the 480p resolution until I downloaded GNOME. Then they made me keep accepting the terms like 5 times, lol, and Shazam I have full use of my video card.

If you update the Nvidia drivers on the command line with sudo zypper update it will only have one EULA to agree to for all of the driver sub-packages instead of having for agree for each one in the GUI.

1 Like

I was concerned about doing it that way because I trusted Edubuntu to automatically install the correct NVIDIA driver and it bricked the system. Then I had to reinstall Edubuntu. I am tired of doing reinstalls.

Wayland is a protocol. If you had KDE Plasma, then it’s the KDE components that didn’t work well with NVIDIA. You will find the X11 session at the bottom left at the login manager.

Gnome implements their own Wayland components.

1 Like