My test of openSUSE 12.1 RC1

I’m an happy user of openSUSE for many years now. I started with openSUSE 11.1, and I decided to test 12.1 RC1 to help improving it. openSUSE 11.4 is a good distribution, but it suffers of many small issues which gives a bad first impression to new users. That’s only after a few tweaks that you finally feel at home. I think it is a pity and I would like 12.1 to be more polished. Therefore I download the KDE LiveCD (openSUSE-KDE-LiveCD-Build0379-i686) to make a feedback. This is more a general review so I didn’t open bug reports, so I hope that some developpers will stop by and read that.

LiveUSB with Unetbootin

I had no CD on hand, so I wanted to make a LiveUSB using Unetbootin. To make it short, it didn’t work at all. When you boot on the USB key, you get the following message :

Could not find kernel image: gfxboot

Hitting the Tab button, a list appears :

openSUSE_Live_KDE linux harddisk memtest

If you enter one of the first two options, the system boots, but quickly fails to start :

Checking CD/DVD device(s)........not found
Checking Hybrid disk device(s)...not found
Couldn’t find Live image configuration file

It starts very badly…

Test under Virtualbox
As a result, I had to fall back on Vistualbox. A test with a LiveUSB would have enable me to report bugs related to my hardware, but without LiveUSB, openSUSE does without a tester, and I don’t think I am the only one in that situation in 2011, while LiveUSB work like a charm on most of the other distributions.

So with Virtualbox, openSUSE 12.1 RC1 boots perfectly. Internet and hardware acceleration works without any problem.

First impressions from the LiveCD

The new theme is nice, but it reminded me of Windows Vista’s one, released 5 years ago. I liked better the theme in 11.4, but it is mainly a matter of taste and I know many people didn’t like it at all. It was more unusual, whereas this one is more classic, but also more looks maybe more professional, which is a good thing. For me, the green is too light, I would have prefer the same green as on LibreOffice’s loading screen.
The default font is still SansSerif. I prefer DejaVu Sans or Droid Sans which are prettier, but it is also a matter of taste and it is easy to change it.
Finally, the welcome screen is still the same as many years ago. I find it not very informative and not very useful. It seems to me that there is no clear target user for it.

User experience
openSUSE 12.1 ships KDE Plasma Desktop (KDP) in version 4.7. It is more or less as the vanilla KDP, except that there are two virtual desktops (they are disabled by default in KDP 4.7, to promote activities). Concerning language, after choosing French in the bootloader, I end up with KDP in English. Only English and German are fully included on the LiveCD, but some apps like Firefox are available in more languages (strange).

Next to the Kickoff menu icon, there is a button to trigger the activiry manager. By default, there are two activities named “Desktop Icons”,in addition of the “Desktop” activity which is activated by default. I am not sure that having these three activities (even two if there was no duplicate) would help users figuring out the concept of activities.

Moreover, the fact that both virtual desktops and activities are enabled is disrupting. Either you trust KDE developpers and consider that activities are now user-friendly enough to be promoted, and then you set virtual desktops aside for advanced users who will know how to activate them, or you hide activites and keep the virtual desktops only. In my mind, having both of them is a wrong decision.

Using the Office icon on the desktop, you get an error message :
*LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.
Clicking Ok, LibreOffice starts still…

By default, Firefox’s menu bar is visible. While Dolphin’s one is hidden in KDP 4.7, it seems to me logical to do the same for Firefox. Especially as it is the default in Windows and new users are used to that.

Strangely, YaST modules’ theme is not the same as the other applications (Oxygen). This was already the case in openSUSE 11.4 by default. I set it back to Oxygen and use it for more than a year without a single issue. I don’t understand this choice, that make YaST appear as not integrated whereas it is developped in Qt !!!

Installation on the harddrive
Clicking on the “Install” icon on the desktop, the installation processus is launched.

First deception : the installation is in English !
I can understand that there is no room for including all the translations for all the application on the LiveCD, but the ones of the installation app is essential. Partionning the harddrive is a very stressful task for someone not used to doing that. If the tool is not in your native language, you have even more doubts that you will not erase all your data. It seems that it is a bug as some éléments are translated in French.

Lack of polish
During the first boot, you can see some command lines before the automatic configuration. That’s not a big issue, but it is in part because of these things that people feel that openSUSE is not polished. I hoped that the switch to systemd would have improved that, but apparently not.

No network
While the network was working on the LiveCD, that is not the case anymore once installed. In YaST module “Network Settings”, “Traditional Method with ifup” is selected, while KPD only supports Network Manager. Selecting Network Manager brings about a segfault of Plasma Desktop Shell, which might explain the default. Selecting ifup again in YaST, the network finally works, but it is impossible to configure it through the plasmoid.

Language selection
As there was no network, the system was not updated during the configuration phase, so my system is still in English, even if I selected French as my primary language. I launched the update tool to fix that, but it only downloaded the test package, used during the development phase. Using YaST Language module, I’m warned that there is only a partial French support, but impossible to install the missing packages from there. Then, I installed manually the packages “bundle-lang-common-fr” and “bundle-lang-kde-fr”, but my system was still in English and I couldn’t select French in KDE’s system settings. I had to look for “kde4-l10n-fr” and “yast2-trans-fr” packages (the latter one is only 600 ko, so it could be included by default on the LiveCD). Now, KDE is in French but YaST is still in English, despite “French” being selecting in the Language module…

I am quite disappointed by openSUSE 12.1 RC1. There are still huge bugs for a RC, such as the one with network. I am afraid that the few days left before the release will be spent on fixing those bugs, and that it will not be possible to fix the small details that count, that could make openSUSE more polished. I will not go to another distribution only because of that, as I am used to openSUSE, zypper and YaST, and I am sure that once set up, it will be an amazing OS, just like 11.4. But I think that the lesson from 11.4 have not been learned, and I would certainly tend to advise another distribution to someone who is looking for an operating system looking as finished and professionnal as the proprietary competitors which are Windows and Mac OS X or even as some other distributions like the last Ubuntu 11.10. I really hope that the final release will make me change my mind.

I’ll comment on several points.

USB: All of my installs and tests have been using a USB. I did not run into any problems. Perhaps you did it wrongly.

When using the iso for the KDE-live version, I simply copied that directly to the USB. I used “dd_rescue”, though using “dd” should also work. That iso is already in the appropriate hybrid form for direct use on a USB. From your description, it sounds as if you did something different (with unetbootin), and perhaps something went wrong at that step.
When using a DVD iso, I used “isohybrid” on it before copying to the USB.

THEME: Personally, I think there’s a bit too much yellow in the green color of the theme. The version used in the Gnome 3 default wallpaper looks better to me. But it’s a minor point and doesn’t really bother me.

USER EXPERIENCE: Hmm, I haven’t played with the different activities yet. Something to do.

FIREFOX: Since firefox is a gtk application, it is not surprising that it doesn’t completely match the KDE theme.

LIBREOFFICE: I think you just ran into the problem of limited space on the CD, so they did not include java because there was not enough room. You could install it over the internet (from the repos).

YAST: I thought the theme a bit strange, but nothing that causes me concerns.

LACK OF POLISH: That doesn’t bother me, but I can see that it would bother some people.

NO NETWORK: For my installs, it defaulted to using NetworkManager on all but one system. It is probably trying to decide whether the system is a laptop, and using NetworkManager for laptops and similar portable systems but using “ifup” for desktops. It got that right for my systems, but it doesn’t surprise me if it gets it wrong on some systems.

There’s also the problem that the network doesn’t actually function until you do a reboot.

CONCLUSION: I hope you give it another try with rc2 or with the final release. I have seen several bugs closed in the last couple of days. It looks to me as if the team is working hard to provided a polished final release.

Unetbootin has never worked for me with openSUSE live cd’s. You can use the dd command as previously mentioned, or you can follow the guide here:

SDB:Live USB stick - openSUSE

Another option is ImageWriter.


Sometimes UNetbootin works for me, sometimes it doesn’t. I’ve had better luck with openSUSE and Imagewriter, but UNetbootin with other distros.

Thank you for your comments. It seems to me I already used Unetbootin with openSUSE, but actually I can’t remember very well. That’s true however that I’m used to making LiveUSB with Unetbootin which usually works, so I didn’t look for another solution when it failed, as I believed it was specific to this RC release. I’ll give ImageWriter a try.

The biggest concern for me is the language support in the installer. Not every openSUSE user speaks English or German. I think this is very essential. It may be an issue with French only, I don’t know.

My point with this review was mainly to show what could be improved, that’s why I pinpointed only the bad aspects. There is also of course many good things in it. I’ll test RC2 once it is released and I’ll give a feedback on this same thread.

Tried the Gnome 3 64 bit Live CD today. Had similar issues to the OP regarding USB install, and ended up having to use a disc instead. Neither Unetbootin, dd, the instructions on the website linked above, nor several Windows apps would successfully create a bootable USB. Never mind, I have plenty of discs…

I remain massively impressed by Gnome 3 on openSUSE. It just feels so right and complete. I’m really looking forward to this release after a brilliant spell with Gnome 3 on 11.4. I didn’t have any issues with the theme or appearance personally, and thought it looked amazing frankly. I did notice YasT looked a bit different, but I’m sure it will work the same.

Bring on the final! I can’t wait. :slight_smile:

On the point of the bootable USB, I think it would useful if the developers made the liveCD compatible with Unetbootin; I avoided installing openSUSE simply due to the case of not being able to boot through Unetbootin in the past, and I’m assuming others are in the same boat as well.

I testeed openSUSE 12.1 RC1 with Gnome3:

Crashes when you change software or remove software from default but everything else works fine. In fact finally my encrypted devices are mounted and decrypted
during install procedure. This was broken since 11.3. Yast doesn’t look much different but they changed a lot of small things under the hood. For example during the installation when showing the how much GB are going to be installed they changed to 4 digits after the “.” so you dont stare at 2,0 gb to install
for like 2 minutes and actually can see more details when it says 2.0423 to install.

Changing form Sys-V-Init is a big change. The startup of the computer is very fast. my pc boots up in notime now and so is the change to an other runlevel. But however this doesn’t bother me since i usually do not reboot often or change runlevels. since you usually do this for maintenance reasons. However changing to systemd was not the best choise. In the description it says it’s backwards compatible to Sys-V-Init. Well its not. For one reason there is no shutdown -F any more. which forces the check of your filesystem when you boot up next time in sys-V-init. I think this is not acceptable.

Has some good ideas and needs more improvements. So far it works fine but i think it takes some time to get used to it.

The Nouveau driver does work. But installation of nvidia proprietary driver does not. Well the installation works fine but Gnome3 crashes. And the nouveau driver has not the same performance as the proprietary one has. For example cpu is at 20 % when actually when desktop effects are in action and 3d games like trine or shadowgrounds don’t even start.
Maybe somebody has some ideas about this?

My test of OpenSUSE 12.1 RC1 didn’t even happen. I downloaded and burned the live DVD, booted it, but it didn’t get past loading udev. (Dell Inspiron 14z, an i3 based machine, see stats here at Slackware64 on Dell Inspiron 14z).

That was an excellent write-up AGui. Aside from the language issues (which should be easy to fix) and the other technical matters, your perception of how easy or hard it was to use is also very significant.

But those kinds of issues are not nearly as easily addressed as purely technical ones are because it’s largely a matter of aesthetics and ease of use, which is why many of us use openSUSE in the first place – yast is a wonderful tool.

There are some other very tricky issues here as well that are “technically” technical, but not really. And that’s the dependency tracking which has to be done in the RPMs. Obviously Firefox had a dependency that the RPM specfile hadn’t listed (and it’s the same deal with the language files, I’d think).

So I do hope some of the developers get wind of your post here too. I think there’s at least five points that could get knocked off before the next deadline.

Anyway, your hard work is certainly appreciated by some of us who are wondering about the entire direction KDE and Gnome are heading. :slight_smile: We at least want to be able to get these things up and running so we can see if we like them or not.

I still use my old suse 10, albeit mosly to fix my 11.4… cuz I do some pretty radical stuff trying to figure out what I can do to get this thing to do what I want. I’ve written up some stuff about my successes, but something happened to those posts.

But this one you wrote is good – and it’s timely.



I am back to 11.4. You can read the wohle story on my blog: geistreicher Papierkorb: Testing and ranting openSUSE 12.1 RC1