My sound went away :(

I’m running OpenSUSE 11.1 32-bit. I don’t listen to music or watch video every day that I’m in Linux, so what I think happened was a recent update killed my sound. It was working about a month ago. But now, nothing. It’s not muted, and it works fine in Windows. Is there a known fix?

Kernel updates can cause this problem. (It has happened to me on occasion). Have a read of this ALSA update how to. It explains how to add a temporary multimedia repository, which you use to update alsa via zypper, then remove when done. Post back if you have problems. :slight_smile:

It tried that, and when I restarted and picked the new entry in the GRUB menu, OpenSUSE 11.1 - 2.6.27.23-0.1 (pae), it would not start the X server. Tried logging in and then startx, but it would not load and it gave me an error. I had to Ctrl+z and restart. Here is the error:

xauth:  creating new authority file /home/randybob/.serverauth.4020


X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux actionfrank 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686
Build Date: 27 February 2009  02:03:33PM
 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 30 17:42:58 2009
(==) Using config file: "/etc/X11/xorg.conf"
FATAL: Module nvidia not found.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When I choose the default instead of the pae from the GRUB menu, I do get my X server, but I still get no sound.

When I choose the default instead of the pae from the GRUB menu, I do get my X server, but I still get no sound.

This will happen, because the nvidia module is compiled against a particular kernel version. (If you want to change kernel, you will need to install matching video driver, but for now I would avoid introducing more problems).

Now back to the audio problem. After updating alsa drivers, you may need to configure sound with YaST > Hardware > Sound again. After this the sound system should restart if all is well.

If you still have problems, post output of

rpm -qa |grep alsa

uname -r

so we can see where your at.

I would also work through this troubleshooting guide. Read carefully, and be methodical in your diagnostics.

SDB:AudioTroubleshooting - openSUSE

The fix was only temporary and would not survive a restart. Step 2 in your link did work, until I restarted the computer to make sure the fix was permanent. YAST tells me my audio controller is not configured, after the restart.

The outputs as you requested:

randybob@actionfrank:~> rpm -qa |grep alsa
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.18-8.7
alsa-oss-1.0.17-1.37
alsa-driver-kmp-pae-1.0.20.20090630_2.6.27.23_0.1-2.1
alsa-firmware-1.0.17-1.42
alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.12
alsa-driver-unstable-kmp-pae-1.0.20.20090630_2.6.27.23_0.1-1.
randybob@actionfrank:~> uname -r
2.6.27.23-0.1-default

You have 2 alsa drivers:

alsa-driver-kmp-pae
alsa-driver-unstable-kmp-pae

I would delete the unstable one (as root) with

rpm -e --nodeps alsa-driver-unstable-kmp-pae

Done, but I still have the same problem.

It is more likely that the recent update to pulse audio has caused your problem. Check the sound icon (bottom right corner of the screen) and see if the sound is shown as muted.

If so then it will be pulse audio the problem. The easiest way to correct this is to go into yast - software and uninstall all the bits with pulse (except libpulse - which should be left). Then re-start your p/c and see if the sound is back to normal.

No, it’s not muted. That was one of the first things I checked.

Nevertheless, pulse can cause problems for some users (if installed), as mentioned here:

SDB:AudioTroubleshooting - openSUSE

Worth looking into.