My screen is turned off after 10 min after the first boot

Hi,

First of all I want to anticipate my apologies if this is not the right forum to pose my problem.

Every day, around 10 minutes after the first boot, my screen simply turns off. The computer keeps running, but by no means I can get the screen back without rebooting. After I reboot, the screen works fine, without being turned off again for the rest of the day.

I am coming from the 13.2 and I am a bit lost trying to find the right configuration options (apparently there are fewer in 42.1). I have “googled” to search a solution to no avail. :slight_smile:

I have tried the following without results:

  • In the configuration menu > Hardware > Energy Management > Energy Economy I unchecked every options.

  • I also set the option Autolock to false in the file kscreenlockerrc in my .config folder.

I thank you for any help!


Belzonte
Leap 42.1 - KDE4
Intel i7-4790 CPU @ 3.60GHz
Gigabyte H97-D3H 16Gb RAM
PNY GTX 970 - LG Flatron E2350V

When the screen is off, is it asleep or just black? If you’re on a desktop, does your monitor display no connection or anything like that?

I would suggest trying CTRL-ALT-F1 to see if it comes up to a command prompt while this is happening. If you get a command prompt, that means that something funky is going on with X and you can restart kdm or lightdm or whatever you may be using. If you can’t even get a command prompt, there may be something else going on.

I have had:

  • with TW a notebook NEVER turned off the screen although it should after 10 min
  • switching back to 13.2 resolved the issue
  • with LEAP 42.2 aarch64 (XFCE) I’m typing and installing and in the middle of typing the screensaver kicks in

There is something deeply flawed with this display handling somewhere…

Thanks for your help.

I will try the CTRL-ALT-F1 trick tomorrow (this mysterious phenomenon shows up only one time, after the first boot).

The screen is asleep (the screen turns to black and the on light starts blinking).

BTW, I have a dual boot with Windows 7. Yesterday I first booted on Windows and, after a few hours, rebooted on Leap 42.1. The problem did not show up.

Today, after booting on Leap 42.1 the problem occurred after 25 minutes and I had to reboot. After that, as before, the screen works fine.

Thanks!

OK. I spent this weekend testing my computer and trying to figure out what is going on.

First of all I would like to apologize for not having done first the tests described below.

I made the following observations:

1- apparently the problem is restricted to Leap 42.1 and to the video system (monitor, video card, etc.);
2- the failure occurs a few minutes (around 25 min) after the first boot of the day, when the machine is cold, and only when booting on Leap 42.1;
3- under these conditions, just after the problem occurs, I have noticed that the video card heat sink is very hot and the video card fan does not run.
4- the machine boots normally after this failure, in Leap 42.1 and Windows 7 (with the video card running);
5- when I first boot on Win7 this problem does not occur (I also never had this problem with openSUSE 13.2);
6- my video card is identified in the Yast kernel configuration as nVidia GM204 [GeForce GTX970] (0000:01:00.0).

As I am not an expert, I would like to know if there is a way to configure my system to make the video card (PNY nVidia GTX970) start the fan. I think there is no problem with the video card, since the fan runs normally in Win7 as soon as it starts the boot process.

I would be grateful for any help.

Thanks!

There is another question: Should I switch to the drivers from nVidia (like in 13.2) or should I continue to use Nouveau drivers.?

OK!

The problem is apparently solved by blacklisting Nouveau and installing Nvidia drivers…

Thanks!

Hi Belzonte,

Congrats on solving your problem yourself. Sometimes just browsing the issue - and writing about it - is enough to get it right.

I’ve both nvidia and amd GPUs, and every time I had a problem with suspend/resume and cpu/gpu performance/heating/fan control it was due, unfortunately, to the open source driver, and installing the proprietary blob usually solved it. This happened so many times that for many years now I got in the habit of installing the proprietary blobs right after the first update of a new installation, so I perhaps I’m being unfair to the more recent open drivers, which are without doubt a huge achievement of the community developers.

If you’re using nvidia I’d recommend installing with yast after adding the nvidia repo (at least that’s what I did up to leap 42.1, haven’t tried 42.2 yet). If you do that, you won’t need to compile the driver again after a kernel update, yast will do that for you “automagically”. Yast is a great tool for the lazy like me :smiley:

Abraço,

I did exactly as you suggested, with Yast.

I have never tried Nouveau before and will not do it again…

Abraço.

:slight_smile:

Back when one of my primary machines had an nVidia GPU and I upgraded the machine through many versions of openSUSE, I found that at various times I had to switch back and forth between the proprietary and community drivers.

Never is a long time…

TSU