My Review of 11.1

I could post this on my site, but I thought I’d do it here. I am running openSUSE 11.1 64bit.

The install:
The install looked very similar to 11.0. It was nice not having to accept a EULA, and how the installation was more streamlined. Detecting hardware, then partitioning. The partitioning tool was nice, but not what I expected. It took me a bit to figure it out (less than 5 minutes). Then on to picking packages. I selected other and it opened up a sub menu so I could select KDE 3. I went on to select more software (I usually install everything and the kitchen sink). When it came time to install, it was fast. I was surprised how fast. It then wrapped up with auto config.

First run:
Ok, now I’m in my desktop. Since I did not format /home, all my settings were saved. Now I gotta get my repos back. I open up YaST and add the community repos. OK, that helps a bit. When I switched the filter to display the repos so I could view the packages by repos, YaST all of a sudden was slow. It took a good solid minute to switch from search to repos. In KDE 4 (I did install KDE 4 as well), when I select a repo, YaST crashes.

I also noticed that they took out the description, when installing. Personally, I miss that.

My wife can’t tell the difference, so I consider that a good thing.

Overall, I think 11.1 is a good release. My main complaint is the 2 issues with YaST that I mentioned earlier.

Let’s hear what the rest of you think.

I installed the 32bit version and I’m very happy with everything so far with the following exceptions:
1.)KDE 4.x
2.)the lack so far of any available proprietary Nvidia drivers (NOT openSUSE’ fault!).

While KDE 4.x is much improved with this release I miss the lack of “fine grained control” one could achieve with 3.5.x (and, yes I know I could get the older version with the DVD media)and am not wild about the “slab” menu…have reverted to the old one there.

Other than these niggles, all else seems to be going well, fairly fast boot up, nimble performance, and all attempts at banging about the system have so far proven very stable.

I have not experienced any problems so far with YAST.


I decided to install 11.1 KDE over 11.0 KDE, worked until I rebooted without the DVD, found no OS’s. Installed grub mbr to extended partition:(, my bad for assuming all would be the same as 11.0, sorted I have my dual-boot.

Installed drivers/packages/codecs for Xfi and Nvidia, and to enable DVD playback. Then found DVD/CD would not play from Kaffeine/Smplayer/Vlc, Kaffeine crashed when I tried to play CD’s. I tried all the usual stuff I felt:Z and called it a night, I ran “zypper dup” this morning which updated Kaffeine, and Libxine now all working:).

Yast is a little sluggish compared to 11.0, and the repo title is missing in versions tab, ie.if you add the packman repo so you get repo1 etc.

Still an issue with Openoffice corrupting parts of the desktop, I presume that’s an issue with the Nvidia drivers I shall have to try it on an Ati system.

Overall impression so far so good apart from the issues mentioned above.:smiley:


What do you mean by number 2? I just upgraded to 11.1 64-bit and am running Nvidia drivers. Did you add the Nvidia repository?

Known problem, Bugs:Most Annoying Bugs 11.1 - openSUSE - there will be an online update to fix this soon.

That’s what I figured. Good to know though.

I had such a hard time with openoffice, that I finally uninstalled it, then went to and downloaded it directly from them.

I find that the opensuse repos are so far behind the curve that I usually just download from the projects web page instead of using the still terrible YAST(which has the crappiest dependency resolver I have seen in a long time, and also doesn’t provide all the dependencies for packages it has, funny eh?): openoffice, amarok, alsa, etc, etc, etc.

I really wish that they would drop KDE 4 and make a KDE 3.5 live disk. Yeah, I know I can do it myself, but KDE 4 is so bad, it shouldn’t be used as a live disk, which are often used for evaluation. KDE 4 is very buggy, and takes up far more resources for little gain, it is on par with Aero in its uselessness. They should also dump that poison pill known as mono as well, but this is Novell after all.

Overall, 11.1 isn’t that bad, although there is nothing here that can’t be had in 11.0, so I am not sure it is a big deal. At least the live CD can properly detect my laptop, something 11.0 didn’t do. But then again, everything works after a little tweaking and a lot of cursing. Of course this is the live CD, which doesn’t mean when I install it, everything will actually work. I don’t understand that at all but it is true. The biggest annoyance in 11.0 was the live cd ran my laptops mousepad perfectly, but when I installed it, the mousepad was all but unusable, no matter how much tweaking was involved. I fully expect this to be the case when I get brave enough to install it on my laptop. Like usual, there were no issues installing it on my custom desktop.

Oh yeah, one more complaint, using the first user login password as root is a terrible idea. Just because Ubuntu screwed up Linux security doesn’t mean everyone else needs to. At least it isn’t required, but it shouldn’t be the default either.

I’ve been using suse since it was called only suse, without the ‘open’… I think opensuse is one of the best distros I’ve seen, and I know that some releases were not perfect (like 10.0), and
I’ve installed 11.1 (clean install) coming from a 11.0.

Ok, I’m writting this lines again from my reinstalled 11.0… Too many small problems, audio problems, vmware vsock module not working, ati drivers working randomly (and of course X crashing), pulseaudio crashed my sound output, video output flashing randomly with video playback…

KDE 4.1 is great, and the new installer worked fine, included networked install, but there are too many small things giving troubles to keep my 11.1 working… :frowning:

I’ll wait to try 11.1 again…


Asus M3N78-Pro
Phenom 9550 4 core
4Gb ram

Are you saying you went back to 4.0.4 on 11.0 ?

Or back to gnome or kde3 on 11.0 ?

If you found KDE-4.1.3 on 11.1 buggy, why did you not try KDE-3.5.10 or gnome on 11.1 ? My experience is pulse on 11.1 works far better than pulse on 11.0.

openSUSE 11.1 for me is the best distro release so far. The increase in hardware support has made it much better on my primary laptop. There have been some annoyances though.

Amarok: no collection unless you install the mysql package.

  • this wouldn’t be a problem if mysql was added as a dependency to the Amarok 2 package. I know A2 shouldn’t need the mysql package since it’s supposed to use mysql embedded, still packagers could make this “just work” for users by changing the dependencies.

Internet: they fixed the problem of networkmanager & YaST talking past each other from oS 11, but on my computer sometimes webpages just don’t load or YaST can’t reach a repo. A refresh will bring it up, but the behavior is weird. Maybe there’s an error on my part with my settings, since I’m using the KDE3 nm-applet

YaST Package Management: No descriptions during package install…I miss this too. I can understand, since at that point you’ve already decided to install the packages…so it’s redundant. But when packages get pulled in as dependencies, it’s nice to know what they do.

YaST Package Management: Auto-close window after packages are installed. This is actually listed as one of oS11.1’s 230 ‘new features’. It would be nice if there was an easy to find option to change the behavior (is there an option at all, short of recompiling YaST without the change?).

So other than the networking issue, there are only minor annoyances which is par for the course with all operating systems. openSUSE 11.1 is the gold standard for me right now, although I have yet to try Fedora 10 which seems to have some earnest fans.

After having 11.1 on for a week, I have come to the conclusion that I will reinstall 11.0. With Firefox up, I noticed that npviewer.bin respawned uncontrollably about 15-20 times. Firefox, as well as other browsers seemed slow, yet I am downloading right now at over 1Mbs, with spikes of upwards of 1.36 Mbs. Can’t say it’s my hardware. I have a duo core 2+ GHz cpu and 3 GB RAM. As I mentioned before, I could never get OpenOffice to work. I had to get it straight from That tells me right there, that’s a packaging issue. The openSUSE OpenOffice packages seem to be corrupted. Then there is the known YaST bug. Since my system worked fine with 11.0, there can be only one conclusion. 11.1 is just to buggy.

I aint giving up on openSUSE. Maybe on 11.1, but not openSUSE. I am sure that 11.2 will be better, and 11.3 will be better still. I like the concepts and ideas their trying to impliment. They just need to iron out a few bugs.

I’ve run openSUSE on 3 PCs with 11.1. NO PROBLEM.

This suggests to me you had an installation problem, either because your DVD was bad, or your download was bad, or your DVD player is bad (and could not read the DVD properly).

oldcpu, I am rather disappointed. You and I both know that there can be other reasons. We can eliminate two right off. Not a bad download. How do I know, the md5’s matched. Also, the DVD drive is not bad, or I’d have other issues surrounding that. Could it be a bad burn? A bad DVD? Possible, but unlikely. K3B does those checks, and I burn at 4x, which is slow. So everything that you listed, is not applicable here.

Another possibility is that during the beta and RC stage, perhaps not enough people tested 11.1 and therefore, not enough hardware configurations were tested.

I am reasonably sure that the openoffice scenario, is a problem with packaging. I tried the DVD first, then the OSS repo, then the repo. Only when I went to download it directly from, did I get openoffice working.

We know that there is a bug with YaST.

As to the npviewer.bin, that sounds like a bug as well.

In my case, oldcpu, I think I just happened to find a few bugs. Others have also complained about 11.1, so I am not alone. Ofcourse, others have also expressed how pleased they are with 11.1. So it goes both ways.

oldcpu, I am disappointed, you know me, and know that I thoroughly research things. Two out of three of the things you listed implies laziness. The other suggests incompetence. If your going to suggest such, or imply such, then do so across the board to everyone who complains about the version of openSUSE.

Maybe you had a bad day. I know we all get tired and grumpy. You’ve seen me get grumpy a time or two. You also know that I could have fired back, and thoroughly chewed you out. Your post was a bit insulting. Maybe you didn’t mean it that way. Like I said, maybe you were tired, or had a bad day. I don’t know, and don’t care. What I do care about is our friendship, and the openSUSE team.

Now at this point, we have options. This ofcourse can be escalated and so on, leading to having the thread locked. Or you can recognize, that your post was not all inclusive, and was biased, and go from there. I am glad that you and others have had such good fortune with 11.1. I just wish I were. Another guy only put up with it for 24 hours. I thought that that was just to short.

Well, as one grump to another :slight_smile: … why is it my open office on 3 pcs works fine? What am I doing wrong to make it work?

My post was not biased. It was how I see things. Just the same as yours is how you see things.

We don’t always lock threads when there is disagreement. You know that. :slight_smile: At least I thought you did.

In my own install I’ve had no problems. I’m wondering if the Ooo problem might be a quirk of your system. In mine trivial,as it is, I don’t get the musical greeting after a reboot. Also in mine Yast doesn’t crash but takes a little while to load the packman repo when I use the repository filter.
These are problems I didn’t have in 11.0. This beginning to make me think that the point 1’s sucking is some kind of universal constant.

It’s been a busy new install at a busy time of the year. It’s very easy this time of year to get tired & say things we don’t mean.
Jon, this is written for you too.
Happy New Year to both of you.:slight_smile:

This problem you described, is a known bug, with YaST.

If it was quirk with my system, then downloading it directly from wouldn’t have worked either.

I wasn’t aware there was a musical greeting. Unless you’re talking about when KDE loads.

Well, YaST is a big thing. However, I can live with a slow YaST for a bit. That wouldn’t make it “suck” for me. I just don’t think 11.1 should have been released in the state it is in. It feels like a beta. Now if I were beta testing, I’d expect this, but I am not beta testing. I have my hands full with other projects.

Indeed I do. I was looking into the future and parallel dimensions and seeing several possibilities. :wink:

I am glad it works well for you. I just wish it did for me. I still can’t figure out why npviewer respawned so many times.