my openSUSE 11.2 can't mount USB device automaticaly

It can mount USB device automatically.

how can I fix this?

and before, all windows partitions can be mount automatically after boot up, now, don’t mount automatically too.

any help will be appreciated.

Is this a USB stick ? An external NTFS formatted USB hard drive drive ?

Esplecialy about the second one we need more information. Post the output of

cat /etc/fstab

and (as root):

fdisk -l

linux-dkkq:~ # fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd594d594

Device Boot Start End Blocks Id System
/dev/sda1 1 2611 20971408+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 2611 6528 31457160 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 6529 10444 31455270 83 Linux
/dev/sda4 10445 14346 31342815 f W95 Ext’d (LBA)
/dev/sda5 10445 10705 2096451 82 Linux swap / Solaris
/dev/sda6 10706 14346 29246301 b W95 FAT32

linux-dkkq:~ # cat /etc/fstab
/dev/disk/by-id/ata-FUJITSU_MHV2120BH_PL_NW9ST6C262YM-part3 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-FUJITSU_MHV2120BH_PL_NW9ST6C262YM-part5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

the important thing is after the installation of openSUSE 11.2,
all windows partitions would be mounted automatically.

and if I connect a USB harddisk, it can be mounted automatically too.

but these days, the behavior changed, no automatic mount any more.>:(

When you ran the “fdisk -l” command above, was your external hard drive plugged in ?

If your external hard drive is an NTFS formatted hard drive, I recommend you connect it to an MS-Windows PC, run chkdsk against it (in case it is not clean) and then ensure you remove it properly from MS-Windows (ie use the remove icon in the lower right corner of MS-Windows). Dependant on how “dirty” your NTFS formatted drive may be (assuming it is ntfs) then your Linux PC may not see it.

My USB is formated as FAT 32;
fdisk -l again here:

linux-dkkq:~ # fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd594d594

Device Boot Start End Blocks Id System
/dev/sda1 1 2611 20971408+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 2611 6528 31457160 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 6529 10444 31455270 83 Linux
/dev/sda4 10445 14346 31342815 f W95 Ext’d (LBA)
/dev/sda5 10445 10705 2096451 82 Linux swap / Solaris
/dev/sda6 10706 14346 29246301 b W95 FAT32

Disk /dev/sdb: 4021 MB, 4021288960 bytes
124 heads, 59 sectors/track, 1073 cylinders
Units = cylinders of 7316 * 512 = 3745792 bytes
Disk identifier: 0x04030201

** Device Boot Start End Blocks Id System
/dev/sdb1 1 1074 3927036 b W95 FAT32**

try this in a su - terminal

mount /dev/sdb1 /media

Please tell us if you use gnome or kde

OK, so it appears your external drive is recognized as /dev/sdb with the partition in it being /dev/sdb1.

In addition to answering caf4926’s question, can you also, with your extra drive NOT plugged in, provide the output of:

dir /media

We are looking for a directory (possibly called ‘disk’ or something else) that should not be there. But don’t remove anything, just report the output of that command.

Note if you create a directory /home/baijingjiao/extdrive
you can likely then insert your external drive, and if it is not auto-mounted, you can then manually mount it via:

mount -t vfat -o rw,users,uid=baijingjiao /dev/sdb1 /home/baijingjiao/extdrive

but lets see if we can get automount to work.

… deleted … information already provided …

**
linux-dkkq:/opt/bugzilla # fdisk -l**

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd594d594

Device Boot Start End Blocks Id System
/dev/sda1 1 2611 20971408+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 2611 6528 31457160 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 6529 10444 31455270 83 Linux
/dev/sda4 10445 14346 31342815 f W95 Ext’d (LBA)
/dev/sda5 10445 10705 2096451 82 Linux swap / Solaris
/dev/sda6 10706 14346 29246301 b W95 FAT32
linux-dkkq:/opt/bugzilla # dir /media
total 0

A silly question , but I need the answer :slight_smile: … does this external hard drive still work with another Operating system or another Linux distribution ? Or is this behaviour ONLY noticed on openSUSE ?

;);):wink:
this hard disk works well even with this openSUSE 11.2
it just can’t be mount automatically.

linux-dkkq:~ # fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd594d594

Device Boot Start End Blocks Id System
/dev/sda1 1 2611 20971408+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 2611 6528 31457160 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 6529 10444 31455270 83 Linux
/dev/sda4 10445 14346 31342815 f W95 Ext’d (LBA)
/dev/sda5 10445 10705 2096451 82 Linux swap / Solaris
/dev/sda6 10706 14346 29246301 b W95 FAT32

Disk /dev/sdb: 4021 MB, 4021288960 bytes
124 heads, 59 sectors/track, 1073 cylinders
Units = cylinders of 7316 * 512 = 3745792 bytes
Disk identifier: 0x04030201

Device Boot Start End Blocks Id System
/dev/sdb1 1 1074 3927036 b W95 FAT32
linux-dkkq:~ # mount /dev/sdb1 /mnt/USB1
linux-dkkq:~ # cd /mnt/USB1

linux-dkkq:/mnt/USB1 # ls
2010-1-18-??-???.doc Linux-info.txt~ Screenshot-YaST2.png TAV_32Bit_Kingston.exe e1000e-1.1.2.1a.tar.gz perl-code vidalia-eeprom-mod-script.txt
2010-1-18-resume-Bai-Jingjiao.doc Linux-info2.txt Screenshot.png WMPInfo.xml e1000e-1.1.2.tar.gz perl-lib
Linux-info.txt Music TAV_16.1_Guidebook.pdf e1000e-1.1.2.1a new file tav

before , this openSUSE 11.2 works very well.

my 2 NTFS windows partition can be mounted automatically when the system start up.

if I clicked one the icon(NTFS windows partition), it ask me the root password, then i can access the files on this partition.

before, when I connected the usb hard disk, it will be mounted automatically, and there was an icon for this usb add on the desktop automatically.

but now, I have to mount manually,for any windows partition and usb.

I don’t know what I did which changed the behaviror of openSUSE.>:(

This reads like a problem with “hal”. … We need someone who knows their way around hal to adjust the settings, after which the automount will take place.

While most of the discussion here is about the mounting of a dynamicaly added devive (USB stick), we also have the problem of your so called 'Windows partitions" not mounting staticaly at boot. That is of course very logical because there is no entry in /etc/fstab for them. I suppose these are:
. partition 1 (with NTFS)
. partition 6 (FAT32)
But also you make no use of
. partition 2 (a Linux one)
Can you tell us which one you want to be mounted at boot and where so we can help you to create the fstab entries for them?

Also, please put computer output between CODE tags. This will help avoiding head ache for at least me. And you can the stop making bold what you type because evryting will look very readable. As an example I show you my /etc/fstab:

henk@boven:~> cat /etc/fstab
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part5 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part3 /home                ext3       defaults              1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part2 /mnt/oldroot         ext3       ro,acl                1 2
henk@boven:~>
linux-dkkq:~ # fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd594d594

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        2611    20971408+   7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2            2611        6528    31457160   83  Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3   *        6529       10444    31455270   83  Linux
/dev/sda4           10445       14346    31342815    f  W95 Ext'd (LBA)
/dev/sda5           10445       10705     2096451   82  Linux swap / Solaris
/dev/sda6           10706       14346    29246301    b  W95 FAT32

ok, I want /dev/sda6 is mounted at boot. mount to /windows/DATA
I also want /dev/sda2 is mounted at boot, it’s another Linux partition(CentOS). mount to /CentOS
and I want my USB is mounted automatically when I connect it. mount to /mnt/USB
thanks:)

USB devices are not added to fstab mounts.

Regarding the others.
You need to actually have directories in place for the partitions to mount to. Do you have them?

and I want my USB is mounted automatically when I connect it. mount to /mnt/USB
thanks

With KDE 4.X, external storage is not automatically mounted. You can mount via Dolphin (or via device notfier AFAIK). I don’t run KDE 4.3/4.4, but I understand you can now set auto-mounting behaviour if desired.

http://www.freetechie.com/blog/kde-4-4-solid-auto-mount-enhancements/

Others may be able to offer more info on this.