My monitor keeps blinking as if losing signal

Hello everyone,
A few months back i switched rig to one that runs a saphire pulse rx570.
Since then i would have my monitor hold black screens whenever the GPU would get under higher load, usually while gaming or watching HD video though more often in the former instance.
The monitor is connected to the gpu via a DVI-D to VGA adapter since its rather old.

inxi -Fxz output

System:    Host: Tessa Kernel: 5.3.12-1-default x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: KDE Plasma 5.17.3 
           Distro: openSUSE Tumbleweed 20191128 
Machine:   Type: Desktop System: Gigabyte product: AB350M-DS3H V2 v: N/A serial: <filter> 
           Mobo: Gigabyte model: AB350M-DS3H V2-CF v: x.x serial: <filter> UEFI [Legacy]: American Megatrends v: F2 
           date: 12/25/2018 
CPU:       Topology: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 102192 
           Speed: 1497 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 1376 2: 1454 3: 1436 4: 1448 5: 1377 6: 1395 7: 1545 
           8: 1548 9: 1446 10: 1543 11: 1393 12: 1381 13: 1376 14: 1377 15: 1376 16: 1377 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 06:00.0 
           Display: x11 server: 1.20.5 driver: amdgpu resolution: <xdpyinfo missing> 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.33.0 5.3.12-1-default LLVM 9.0.0) v: 4.5 Mesa 19.2.6 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Sapphire Limited driver: snd_hda_intel 
           v: kernel bus ID: 06:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 08:00.3 
           Sound Server: ALSA v: k5.3.12-1-default 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus ID: 04:00.0 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 1.02 TiB used: 58.74 GiB (5.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB 
           ID-2: /dev/sdb model: BIOSTAR S100-120GB size: 111.79 GiB 
Partition: ID-1: / size: 107.77 GiB used: 10.61 GiB (9.8%) fs: ext4 dev: /dev/sdb1 
           ID-2: /home size: 818.80 GiB used: 47.05 GiB (5.7%) fs: xfs dev: /dev/sda1 
           ID-3: /var size: 112.26 GiB used: 1.08 GiB (1.0%) fs: xfs dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 38.2 C mobo: N/A 
Use of uninitialized value $val2 in string eq at /usr/bin/inxi line 5759.
Use of uninitialized value $val2 in split at /usr/bin/inxi line 5764.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5766.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5767.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5768.
           Fan Speeds (RPM): N/A gpu: fan: 1312 
Info:      Processes: 369 Uptime: 3h 48m Memory: 15.58 GiB used: 2.61 GiB (16.7%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.2.1 Shell: bash v: 5.0.11 inxi: 3.0.32 

sensors output to suplement the missing info:

Adapter: PCI adapter
vddgfx:       +0.84 V  
fan1:        1313 RPM  (min =    0 RPM, max = 3500 RPM)
edge:         +31.0°C  (crit = +94.0°C, hyst = -273.1°C)
power1:       41.09 W  (cap = 120.00 W)

Adapter: PCI adapter
Tdie:         +29.8°C  (high = +70.0°C)
Tctl:         +29.8°

One error I found happening throughout my sessions is:

 27289.615] (II) config/udev: Adding drm device (/dev/dri/card0)
 27289.615] (II) xfree86: Adding drm device (/dev/dri/card0)
 27289.615] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

In the Xorg.1.log file and all the search resaults for this problem i found were tied to nvidia drivers which I don’t have.
I am fairly certain it’s some sort of driver issue and not faulty hardware since this monitor/gpu setup works without a hitch on windows 10 to which i switched just to eliminate any other type of issue.
The GPU does not have thermal issues when under load.

What i have tried so far to fix the issue:
Experimentig with refresh rates and resolutions through xrandr which had little effect but the problem still occurs.
Tried installing amdgpu pro driver but i get the following issue ->
which i understand is more of an amd problem than a opensuse one.

Is there any chance you can test if it happens connecting to the HDMI port on a TV, using a DVI-to-HDMI adapter if necessary? I don’t believe software developers do very much if any testing using analog video any more. Newer GPUs often have no analog outputs any more. Adapters can be flaky.

Tested today with a HDMI cable on my friends monitor without any issues so it is a VGA cable problem, tnx for the help.