My laptop behaves as if the function key is pressed all the time

Hello,
I searched the forum for similar entries, but no luck; so I decided to post a new thread.

I would like to give a small example, when I press F2 without pressing the function button, the brightness decreases, but it must be function key + F2 to show this result. If I really needed the function of F2, for example, renaming a file, I have to press function key + F2 for the normal effect of F2.

Do you have any suggestions?

Thank you.

BA

This is peculiar. I had something like this happen during first boot… but after a reboot of the system, things returned to normal, and so I didn’t give it much thought. I’m curious if you come up with a resolution.

On Fri, 27 Jul 2012 16:06:02 +0000, bakkurt wrote:

> Do you have any suggestions?

It would really help if you told us what brand/make/model laptop you have
and what version of openSUSE you’re running.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 07/27/2012 06:06 PM, bakkurt wrote:
> Do you have any suggestions?

maybe a hardware problem…if you boot a live CD (or boot a different
OS, if you have one) do you see the same problem?

maybe there is a little chicken bone under that Fn key that needs to be
cleaned out :slight_smile: a not so strong vacuum cleaner might get those or
cookie crumbs out?

have you spilled a liquid on the keys?

press the Fn key a few times while you got the vac going…

in addition to the basic missing info that Jim requested, tell us if
it ran great for a while and then started giving this problem…


dd

Am 27.07.2012 18:06, schrieb bakkurt:
> I would like to give a small example, when I press F2 without pressing
> the function button, the brightness decreases, but it must be function
> key + F2 to show this result. If I really needed the function of F2, for
> example, renaming a file, I have to press function key + F2 for the
> normal effect of F2.

Please post your model as requested by others.
My ThinkPad by default (means factory settings) has this behavior, this
is not a bug it is a deliberate choice made by Lenovo, I do not like it
so I went into the BIOS and switched the setting how function keys are
handled back to the legacy setting.
Check your user manual for your machine or simply look into its BIOS for
such a setting.


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

This behavior can be set at the BIOS - an HP dm1 I bought came with this option, but unselected.

On my current laptop, I believe that is a BIOS setting. It defaulted to what you describe. I changed to more traditional behavior.

Sorry for being so long, and thank you very much for your replies.
My laptop is Compaq Presario CQ57 and I will first consult to the BIOS settings; however, when Windows XP or Windows 7 was installed to this machine, the function keys worked as usual, if I recall correctly.
I will look at the BIOS settings and give information later.
Thank you.

Hello,
The problem is solved; I found the appropriate setting in BIOS and disabled it to function like when I press F2, it will rename a file, not decrease brightness as if I pressed Function key + F2. So I thank everyone who were interested in the topic, and posted replies.
Cheers!
BA