My keboard duplicates the pressed keys

Hi all!
I’m having a problem with my keyboard, because it is duplicating (or mullltipplyiiiing the keys pressed - as you can see ;)). It happens in any application.

I’m using OpenSussse 11.1 on a HP Pavillion dv5-1235la laptop.

I’ve trying on plugging an usb keyboard and the rrrresults are the same. So I believe that it is not a hardware problem, but I don’t kkknow what to thinnk…

Thanks in advance if anybody can help me!

Beto…

are you hold down the keyyyyyyyyyyyyyyyy (like i just did)…
getting multiple letters when holdddddddddddddding down a key is
normal

you can adjusttttttttttt the time delay between when it ‘sees’ just
one keypress and when it begins to repeatttttttttttt, go:

Personal Settings, Configure Desktop > Peripherals > Keyboard

where you can either turn repeat completely OFF by UNchecking “Enable
keyboard repeat” or you can leave the (imo) convenient repeat function
and increasing the “Delay” to a higher figure…

mine is (default i think) set to 660 msec (66% of ONE second) increase
it to (say) 1000 msec (one second) if you wish (and, don’t ‘rest’ your
finger on a key…make each key strike crisp down-up…like the old
people here learned to do on stone age MANUAL typewriters in which the
force of the down stroke was actually USED to cause the letter anvil
to fly up and contact the paper…and, if you held the key down for
even most of a second, the resulting type would be smudged because the
paper carriage would MOVE)…

i think it is convenient to have the repeat feature if you (for
example) want to draw a line across the page/screen, like this:


or these


each of which can be done with ONE key press–if that box is checked!!

but, on the manual typewriters of yore, one would have to strike the
key multiple times…(see how lucky you are to be young?)

and, try deleting a line of info using the Delete/backspace keys or
navigating around a document with the arrow keys without a repeat
function!

fun huh? :wink:


Andy Sipowicz

I wish that it were as simple as Andy suggests.

I have the same problem that betoceli has. I have tried all the twiddles and twists available with KDE configuation gimmicks. It is a “double double” nuisance in my case, because it is unpredictably intermittent. In other words, it picks its own random moments to toggle back and forth between behaving (giving ONE character per keystroke) and misbehaving (putting TWO characters on the screen for every key I touch, even when I try to make that a lightening speed touch, lifting my finger off the key as quickly as is humanly possible).

In composing this forum contribution with KWrite, for example, it switched me back and forth at least 11 different times.

My guess is that betoceli and I somehow got an imperfect download of an otherwise perfect openSUSE and that it may be solvable in the KDE forums more quickly than here. "]http://forum.kde.org/installation-configuration-f-16.html](I wish that it were as simple as Andy suggests. I have the same problem that betoceli has. I have tried all the twiddles and twists available with KDE configuation gimmicks. It is a “double double” nuisance in my case, because it is unpredictably intermittent. In other words, it picks its own random moments to toggle back and forth between behaving (giving ONE character per keystroke) and misbehaving (putting TWO characters on the screen for every key I touch, even when I try to make that a lightening speed touch, lifting my finger off the key as quickly as is humanly possible). In composing this forum contribution with KWrite, for example, it switched me back and forth at least 11 different times. My guess is that betoceli and I somehow got an imperfect download of an otherwise perfect openSUSE and that it may be solvable in the KDE forums more quickly than here. [http://forum.kde.org/installation-configuration-f-16.html)]

hmmmm…i think you two should compare hardware…sure sounds like a
keyboard controller problem…

if you two have an HP still in warranty i think i’d see if they can
fix it…or or or try a Live CD and see if you can duplicate it that
way…yep, try a Live SUSE and also at least one other distribution…

oh no, let me guess: when you boot to Redmond’s finest you have no
problem…hmmm…could be a KDE prob…are both of you running KDE4?
with desktop effects turned on?? turn off the effects and see what
happens…if that doesn’t solve it try logging into GNOME…

think that kinda way…try stuff…

google (for example)
keyboard stutters linux
and do some reading and thinking


Andy Sipowicz

Thanks Andy,
I do have KDE4. Here are the details:
OS: Linux 2.6.25.20-0.1-default i686
System: openSUSE 11.0 (i586)
KDE: 4.0.4 (KDE 4.0.4 >= 20080505) “release 15.2”
I suspect it’s a flaw in KDE, maybe came with it, but probably occurred during download. (I used GNOME from a Fedora8-LiveCD for a couple of weeks while I was correcting an earlier KDE problem. The double keystroke problem did not occur there [GNOME], nor in my lesser OS, Vista Home Premium-32bit, which came pre-installed on my 64bit Acer laptop. Thus, I presume it’s a software problem.) I expect to try to reinstall KDE (which I prefer over GNOME) as soon as I back up everything and get my courage up. Though experienced in MS OSs, I’m a Linux newbie and haven’t ever tried to install new software yet, so I’m tending to be cautious. There’s no prize for smoothing out a tiny bump on your car’s hood if you end up breaking the windshield instead. Meanwhile, I’m following your advice which agrees with my own instincts:
“and do some reading and thinking.”

> KDE: 4.0.4 (KDE 4.0.4 >= 20080505) “release 15.2”

STOP! do not reinstall that old KDE4.0.4

instead, read the forum here and learn how to upgrade to KDE4.2.x

there have been a TON of patches, updates, bug fixes etc since the
VERY BETA and buggy 4.0.4 you are dealing with…

i’d tell you how to do it but i don’t know how (i still use stable,
dependable, fast, and wonderful KDE3.5.9)


Andy Sipowicz

Hi!
I’ve increased the keyboard delay to 800 and I have no problem anymore. I don’t actually know what the problem was, but this solve my trouble.

Thanks!!

Beto.

Still, take Andy’s advice and get rid of this old KDE version. You won’t know what’s happening to you. If you’re already satisfied with what 4.0.4 is doing for you, fasten your seatbelts before updating to 4.2.x, and put on a helmet to avoid your mind blowing out…