My KDE desktop has disappeared!

I have used SuSE since 6.3 (1999(?)) & am now using 13.2; I have always used KDE as the Desktop. Last night I closed my machine down; I started it this morning and IceWM appeared as the Desktop. I rebooted & pressed the spanner on the Log-in screen but KDE has disappeared from the menu!

I can run a “sort of” KDE system by pressing “KDE System Settings” from the IceWM drop down launcher and running anything I cant find there from the Xterm

In 15 or so years of using SuSE with KDE this is the first time this has happened. Does anyone have any idea about what’s going on?

Confused & Unhappy:?:frowning:

dmk

Samsung RV511
Intel i5 M 480
memory: 5839.9
HDD: 644.1gb

Probably kdebase4-session has been uninstalled for some reason.
Enter YaST and install it again, or run:

sudo zypper in -f kdebase4-session

And please also post your repo list. Something like this should not happen by itself with only the standard repos…

zypper lr -d

Wolfi - Thanks for that - it looks as if you’re bang on the button. I’m putting together some stuff for you but I can’t work out how to connect to the internet thru’ IceWM - SuSE keeps getting snotty about NetworkManager being in charge of communications and I can’t get to it! Fortunately, I’ve got 2/3 other distros on this machine; when I’ve assembled the info, I’ll send it from one of them.

Thanks for the help!
A slightly less confused & unhappy:|

dmk

You can switch between NetworkManager and Wicked (similar to the older ifup) in YaST->Network Devices->Network Settings->Global Options.

And you can also use any NetworkManager frontend in IceWM.
nmtui, the text mode interface, should be available in any case, just run that in a terminal window.
And if you have NetworkManager-gnome installed, you should also be able to run nm-applet.

Wolfi - Thanks again for your help. I had no idea of what was going on; I grew-up with CPM, Windows3, DesqView & OS/2; in the early days of Linux I used ifdown & ifup (& still do with antiX on an old Dell Inspiron Mini 10 which has a regrettable habit of remaining connected to the network but - apparently - losing the signal). I have often looked at Wicked but it’s always appeared too complicated. I did, however, find the post:

https://www.suse.com/documentation/sles-12/pdfdoc/networking_with_wicked_in_suse_linux_enterprise_12_guide/networking_with_wicked_in_suse_linux_enterprise_12_guide.pdf

and managed t0 recreate the KDE Desktop (although I’m not entirely sure how).

I am in your debt.

Here is the screenshot of the repo directory when it all went wrong

Now, thanks to you, laughing & merry :smiley:

file:///home/MyStuff/Dropbox/CherryTree/LX_Notes/Pics/Settings/SuSE-Repos.png

Besides something uninstalled (is that really a likelihood?)

It’s also possible your display manager and/or window manager was disabled or changed.

Check this…

YAST > /etc/sysconfig editor / Desktop / Display Manager / DISPLAYMANAGER
value = kdm

YAST > /etc/sysconfig editor / Desktop / Window Manager / DEFAULT_WM
value = kde4
can be kde

If you make any changes, logout (or reboot) and log back in to restart the display manager with these settings.

TSU

Here is the screenshot of the repo directory when it all went wrong

Sorry about that - I was trying to send you an attachment but wasn’t allowed to. This is not quite the same thing but is similar. What I was trying to send were screenshots of the repo directory from Yast. When I discovered that I couldn’t do that I ran

zypper lr -d

over the new system & backdated it with info from the screenshot.

I hope this is some use & thanks (as usual) for all your help

dmk

Repo’s before kdebase4-session:
-±-----------------------------------±--------±----------±--------±---------±-------±-------------------------------------------------------------------------------±-------
1 | home:X0F | home:X0F | yes | ---- | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/X0F/openSUSE_13.2/ | !
2 | home:frispete:tools | home:frispete:tools | yes | ---- | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/frispete:/tools /openSUSE_13.2/ |
3 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | ( p) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-SlimtypeDVD_A_DS8A5SH_104250078804 |
4 | repo-debug | openSUSE-13.2-Debug | no | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ |
5 | repo-debug-update | openSUSE-13.2-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
6 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | no | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/ |
7 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |
8 | repo-oss | openSUSE-13.2-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ |
9 | repo-source | openSUSE-13.2-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |
10 | repo-update | openSUSE-13.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
11 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |

And after:
—±--------------------------±-----------------------------------±--------±----------±--------±---------±-------±-------------------------------------------------------------------------------±-------
1 | home:X0F | home:X0F | No | ---- | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/X0F/openSUSE_13.2/ |
2 | home:frispete:tools | home:frispete:tools | No | ---- | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/frispete:/tools/openSUSE_13.2/ |
3 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | ( p) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-SlimtypeDVD_A_DS8A5SH_104250078804 |
4 | repo-debug | openSUSE-13.2-Debug | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ |
5 | repo-debug-update | openSUSE-13.2-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
6 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/ |
7 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |
8 | repo-oss | openSUSE-13.2-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ |
9 | repo-source | openSUSE-13.2-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |
10 | repo-update | openSUSE-13.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
11 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |

Not really.
Fallbacks are used in this case.
And even if /etc/sysconfig/windowmanager is set wrong, the KDE session should still be selectable at the login screen, but it was missing there as well.

So yes, there is a likelihood that something (kdebase4-session in particular) was uninstalled.
And that reinstalling it fixed the problem makes it extremely likely I suppose… :wink:

YAST > /etc/sysconfig editor / Desktop / Display Manager / DISPLAYMANAGER
value = kdm

That’s unrelated to the desktop. It only sets which login screen to use.

YAST > /etc/sysconfig editor / Desktop / Window Manager / DEFAULT_WM
value = kde4

“kde4” is invalid, since 2011 actually.
For a KDE desktop it should be kde-plasma.

If you set it to “kde4”, you will actually cause KDE not to start. Reinstalling kdebase4-session will fix that too though, because it replaces “kde4” with “kde-plasma” in /etc/sysconfig/windowmanager to cater for upgrades from old openSUSE versions.
So actually this might have been the reason, but “kde4” was last used in openSUSE 11.4, and nothing would set “kde4” automatically in 13.2.

can be kde

That’s KDE3.

If you want to add images, you have to use some external site like http://susepaste.org/.

Repo’s before kdebase4-session:

And after:

The debug repos should not matter, and at a glance I see nothing that would cause removal of kdebase4-session in the [noparse]home:X0F[/noparse] repo (it only contains non-KDE stuff).

So no, this doesn’t hint at all at the reason why it happened, sorry.

Wolfi -

It’s always worrying when you don’t know what’s happened - but your advice got it up & running again AND I am now approaching the foothills of Wicked (which is good)

Thanks - dmk

And thanks also for this bit of advice!

**Edit: **It seems that I might have posted too soon…
Interestingly although the login was IcdWM, when the system fully loaded, a display manager obviously was loaded “after the fact” even when none was specified. So, at least my test requires further investigation. Seems is a weird hybrid mix of a full KDE Desktop but with IceWM functionality (eg the persistent xterm window echoing your actions).


I just ran a test…

From a system with KDE Plasma 5 as the designated desktop,

Using the /etc/sysconfig editor,
I modified <only> the Display Manager which had sddm configured, I instead replaced it with nothing (an empty null).

Upon reboot,

The IceWM Window manager isplayed for login, there was no option to select a Desktop on login obviously because no Display Manager was running (only a Window Manager which fell back to IceWM).

IMO, this is likely what had happened, KDE does not have to be uninstalled for this result.
Of course, re-installing KDE would reset configuration defaults, so resolved this OP’s problem as well.

TSU

Wouldn’t be the first time, I suppose… :wink:

Interestingly although the login was IcdWM, when the system fully loaded, a display manager obviously was loaded “after the fact” even when none was specified.

Of course a display manager is loaded, otherwise not even IceWM (or X itself) would start and you would end up in text mode on boot.

If none is specified (or the specified one is not installed), the system falls back to xdm (which should always be installed).
xdm is quite basic and does not allow you to choose a desktop session, it always uses what’s set as DEFAULT_WM in /etc/sysconfig/windowmanager.
If that is set to “kde4” as you suggested earlier, IceWM would be used as fallback because “kde4” is invalid and doesn’t exist (since 2011), as I wrote.

sddm OTOH ignores /etc/sysconfig/windowmanager completely and always defaults to plasma5 (or what you chose at the login screen before).

And read the original post again, the OP was able to choose a desktop session at the login screen, but KDE Plasma Workspace was missing from the list.