My internal microphone in laptop is not working after update from 11.3 to 11.4

Please help, I don’t know what to do. All my attempts to make changes with alsa-mixer failed.

What desktop are you using ? KDE ? Gnome ? LXDE ?

When trying to record with a mic, I recommend you test from a terminal, using the command:

arecord -vv -f cd test.wav

and press to stop the recording and then play back test.wav in a media player.

I also find in openSUSE-11.4 it is helpful to install the application pulse audio volume control ‘pavucontrol’ and then run ‘pavucontrol’ at the same time as ones record application (in this case arecord) and tune pulse audio for recording.

If you still fail after those hints, then please provide more information on your software and hardware audio setup per our stickie in our multimedia section of this forum: Welcome to multimedia sub-area and I’ll quote the salient section for you to make it easier to find what you need to provide:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.comand press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](

followed by this (where in RED is the URL).](

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload
which will create the file /tmp/alsa-info.txt. Copy that file and paste it on []( and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Dear oldcpu, thank you so much for your quick response.
Unfortunately arecord -vv -f cd test.wav results with a silent data with all my tunings by alsamixer or pavucontrol.

**rpm -qa '*alsa*'**
**rpm -qa '*pulse*'**
**rpm -q libasound2**
**uname -a**
Linux #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux

My result is here
Thank you in advance!

Please do NOT forget … I need the output of:

cat /etc/modprobe.d/50-sound.conf

Now while waiting for that, lets look at your mixer settings from the script …

“arecord -l” gives this:


**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

Indicating your mic hardware is hw:0,0 and hw:0,1

I note this in your mixer:

**!!Amixer output**
**!!-------Mixer controls for card 0 [Intel]**
Card hw:0 'Intel'/'HDA Intel at 0xd8a00000 irq 47'
  Mixer name	: 'Intel Cantiga HDMI'
**Simple mixer control 'Front Mic Jack Mode',0**
  Items: 'Mic In' 'Line In'
  Item0: 'Mic In'
**Simple mixer control 'Mic',0**
  Front Left: Capture 3 [100%] [30.00dB]
  Front Right: Capture 3 [100%] [30.00dB]
**Simple mixer control 'Capture',0**
  Front Left: Capture 15 [100%] [22.50dB] **[off]**
  Front Right: Capture 15 [100%] [22.50dB] **[off]**
**Simple mixer control 'Capture',1**
  Front Left: Capture 15 [100%] [22.50dB] **[off]**
  Front Right: Capture 15 [100%] [22.50dB] **[off]**
**Simple mixer control 'Digital',0**
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]

You have Capture 0 and Capture1 muted. Presumably because those are external jacks ? Try unmuting them anyway.

The next step would be to force a boot configuration for the IDT 92HD88B3 hardware audio codec that may have been misconfigured by alsa, but even IF you provide the output of “cat /etc/modprobe.d/50-sound.conf” that will NOT HELP because there are no hardware audio codecs in the HD-Audio-Models.txt file these model options for the STAC 92HD88 …

Try these commands:

arecord -D hw:0,0 -vv -f cd test.wav

and if that fails this one:

arecord -D hw:1,0 -vv -f cd test.wav

Again, tune pavucontrol to record the audio. You could also post images of the pavucontrol configuration, input devices (ensure all devices selected in show), and record (ensure all streams shown in show) to this forum via a site such as Fast, Free Image Hosting - ImageBam, so we can check those settings.

If all that fails, then IMHO you are into bug reporting territory per this guide: openSUSE:Submitting bug reports - openSUSE where you need to write a bug report on openSUSE-11.4 component sound and attach a copy to the bug report of the /tmp/alsa-info.txt file from running:

/usr/sbin/ --no-upload

Dear oldcpu!

sergey@linux-393i:~/ovpn> cat /etc/modprobe.d/50-sound.conf

options snd-hda-intel model=hp
options snd slots=snd-hda-intel
# u1Nb.otDuTl8IKL6:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

You’ll see model=hp (my experiments), but it cases nothings (nor with this parameter, neither without is - no recording)
Also please find below my pavucontrol images](](](](

This command arecord -D hw:0,0 -vv -f cd test.wav records silence:
Another one fails with error:

sergey@linux-393i:~/ovpn> arecord -D hw:1,0 -vv -f cd test.wav
ALSA lib pcm_hw.c:1401:(_snd_pcm_hw_open) Invalid value for card
arecord: main:660: audio open error: Нет такого файла или каталога

Also sometimes after booting I receive the message (not every time and I don’t know what it depends on): device STAC92xx Analog is not working… the default device will be used.

I’m bad …

Try instead:

arecord -D hw:0,1 -vv -f cd test.wav

IMHO unless you specifically know that the model “hp” is for your PC’s hardware audio codec, then that test is not worth posting about.

You SHOULD REMOVE THAT. Its quite possible breaking your mic functionality. It makes no sense to me.

Reference the screen prints - I don’t speak that language so they mean nothing to me. Maybe someone who speaks your language can help …

If the above post (with arecord) does not work then you should following this previous recommendation of mine, and I quote:

Dear oldcpu,
I’ve deleted model, now after booting of KDE I receive the message like (my translation) The audio device HDA Intel (STAC92xx Analog) is not working. Will be used default.
It seams that it’s not working. Even

sergey@linux-393i:~/ovpn> arecord -D hw:0,1 -vv -f cd test.wav
arecord: main:660: audio open error: Нет такого файла или каталога (my translation: no such file or directory)

Could you please recommend me how to switch alsa / pulse off. I need any simple way to communicate with skype. Thank you!

Did you try with an external headset mic, as opposed to an internal mic. That likely has a greater chance of working (internal mics are always tricky).

The problem is that it worked well in 11.3 and of course I’d like to have it in 11.4. Probably you could recommend me how to switch this sound system off to come back to previous one. I really need something simple. My father is working in 11.3 and we are not able to communicate now as we recently could :slight_smile:
Anyway thank you for your time!

I understand.

External Head sets with a mic are dirt cheap. They are small. They are portable. Why not buy one as an interim, and in the mean time we can work to fix this internal mic issue.

You have IMHO one of two approaches:

  1. update alsa per this guide to the latest cutting edge alsa version (and please follow that guide carefully, and if you deviate ensure you KNOW what you are doing): SDB:Alsa-update - openSUSE I would venture over 50% of the time users who say they follow that guide (but who deviate) THINK they updated their alsa, when in fact they did not. So that is a caution in advance when attempting to update your alsa via rpm.
  2. write a bug report on openSUSE-11.4 which will get the SuSE-GmbH sound packagers attention (where that person is also an alsa sound driver developer) and they WILL solve the problem. Guidance is here: openSUSE:Submitting bug reports - openSUSE write the bug report against openSUSE-11.4 component ‘sound’. Ensure you attach to the bug report the file /tmp/alsa-info.txt that comes from the command:

/sbin/alsa/ --no-upload

I talk to my 85+ year old mother via Skype 4 to 5 times/week for 15-minutes or so in a video chat (we both run openSUSE). She lives in Canada and I live in Europe. So I understand and can relate to the importance of your motivation.

Tux-Tux. Please would you provide proof that you have done this correctly ?

ie provide the output URL/webaddress from running (with pc connected to internet, and select the SHARE/UPLOAD option):


I recommended you make some changes and I have seen no evidence you followed that recommendation. My apologies if I missed your proof/notification that you attempted what I suggested.

Dear oldcpu, Now I’m following your recommendations concerning alsa update. I’ll be back with results. Kind regards, you are very professional. Thank you!

Dear oldcpu, thank you very much! After update my microphone is working! Anyway, my computer is still writing me that HDA Intel (STAC92xx Analog) is not working. My alsa-info is here
Anyway thank you for your help!

Great! Congratulations.

I do not know where you see that, and its important to know EXACTLY when/where one see’s such an error else it is nigh impossible to figure out what one is referring to. Is that a message from KDE ?

My alsa-info is here

OK, … are you sure speaker sound is working? I note from your mixer that phones are ON, but speaker OFF.

**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Front Left: Playback 64 **[100%]** [0.00dB] **[on]**
  Front Right: Playback 64 **[100%]** [0.00dB] **[on]**
**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Front Left: Playback 0 **[0%]** -48.00dB] [on]
  Front Right: Playback 0 **[0%]** -48.00dB] [on]

Dear oldcpu!
The message “HDA Intel (STAC92xx Analog) is not working, the default device will be used” occurs when I’m login in KDE (in informational box of tray). As for Mic and sound they start working when I choose HDA Intel soundcard in alsamixer and increase all channels (Speaker, Internal Mic).

I get that myself sometimes. I recommend you ignore it. I think there was a bug report on it sometime back. There may be a technique to get rid of it, but I’ve long since forgot the method to do so.

Glad to read you found a way to get this to work.

I use pulse audio’s volume control application (pavucontrol) on my openSUSE-11.4 test partitions (on two different PCs) to ensure a mic works properly with 11.4.

Thank you for your time, you’ve given me a real working solution. Now I’m falling in love with my openSUSE 11.4 again! Thank you so much. I’ll ignore this notification