my intel wireless 3945 card is: heavily asleep

dear linux doctors,

i’ve recently installed openSuse 11.0 on my laptop
(lenovo 3000 N100)
and my wireless won’t work.
i have read and tried to follow all kinds of threads in this forum and others and nothing worked.
i did manage to get the following output:


03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

03:00.0 0280: 8086:4227 (rev 02)

iwl3945: Microcode SW error detected. Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x
0000004B
iwl3945: Can’t stop Rx DMA.

iwl3945: WARNING: Requesting MAC access during RFKILL wakes up NIC
iwl3945: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.
usb 1-2: USB disconnect, address 4
iwl3945: MAC is in deep sleep!
iwl3945: MAC is in deep sleep!
iwl3945: MAC is in deep sleep!

iwl3945: MAC is in deep sleep!
iwl3945: MAC is in deep sleep!
iwl3945: MAC is in deep sleep!
ACPI: PCI interrupt for device 0000:03:00.0 disabled
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PM: Writing back config space on device 0000:03:00.0 at offset 1 (was 100102, wr
iting 100106)
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:01:29:23:01:4e
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:01:29:23:01:4e


i am just about totally clueless about this OS
and don’t even remember how to re-get this output…

please, if anyone can help me i’ll be thrilled!

Ori

to everyone who has this problem:
i just found in another forum (myopera) a solution and in just 3 minutes am surfing via wifi

type (as su) these two lines:

rmmod -f iwl3945
modprobe iwl3945 disable_hw_scan=1

that’s it! it worked perfectly for me (though i have to say i have no clue as to what it does)

enjoy

operry5 wrote:
> to everyone who has this problem:
> i just found in another forum (myopera) a solution and in just 3
> minutes am surfing via wifi
>
> type (as su) these two lines:
>
> rmmod -f iwl3945
> modprobe iwl3945 disable_hw_scan=1
>
> that’s it! it worked perfectly for me (though i have to say i have no
> clue as to what it does)

What that command does is to tell the driver to let the software, rather than
the hardware, scan for nearby access points.

Larry

It worked also im my HP Pavilion dv6660

carlos

carlosalmonteiro wrote:
> operry5;1908487 Wrote:
>> to everyone who has this problem:
>> i just found in another forum (myopera) a solution and in just 3
>> minutes am surfing via wifi
>>
>> type (as su) these two lines:
>>
>> rmmod -f iwl3945
>> modprobe iwl3945 disable_hw_scan=1
>>
>> that’s it! it worked perfectly for me (though i have to say i have no
>> clue as to what it does)
>>
>> enjoy
> It worked also im my HP Pavilion dv6660

The 3945 is capable of doing scans for nearby Access Points without any software
intervention; however, when you do it interferes with the operation of mac80211,
the wireless Media Access Control software. That line above disables the
hardware scanning.

To eliminate having to keep reentering those commands every time you reboot,
open the file /etc/modprobe.conf.local as root and add the line

options iwl3945 disable_hw_scan=1

Larry

How is it possible to have active wifi under the live CD but a dead one after installing to the hard disk is impossible for me to comprehend. By the way, the graphics card (nvidia) also works better under the live CD than after installing to the hard disk (installation from the DVD, 64-bit). Actually this was not a fresh install but an update from 10.3 that worked perfectly. I don’t get it. Old system works, new system fails. By the way disable_hw_scan has no effect what so ever here.

samig wrote:
> How is it possible to have active wifi under the live CD but a dead one
> after installing to the hard disk is impossible for me to comprehend. By
> the way, the graphics card (nvidia) also works better under the live CD
> than after installing to the hard disk (installation from the DVD,
> 64-bit). Actually this was not a fresh install but an update from 10.3
> that worked perfectly. I don’t get it. Old system works, new system
> fails. By the way disable_hw_scan has no effect what so ever here.

What modules are loaded on the Live CD? Are they different that for
the installed system?

OK fixed it. It seems that kppp installed and disabled knetworkmanager. Grahics fixed once wifi was enabled by downloading the nvidia drivers.