My fonts are completely broken, HELP!!

Hi There,

I was following this tutorial:

https://en.opensuse.org/SDB:TrueType

And grabbed all the fonts from Windows 8.1 inside “C : \Windows\Fonts”

And dragged them into /usr/share/fonts/truetype

Then I ran the command

su -c “fonts-config --verbose”

And the terminal spit out hundreds and hundreds of assorted errors. After it finished when I launch Firefox or Chrome all the fonts are completely screwed up look like little squares and shapes and I cannot read anything.

Please help me to restore my fonts to the way they are supposed to be.

Remove all those cruddy MS font’s you added
Hopefully you kept them all in a folder of their own

Actually no, the tutorial did not say to place them in a subfolder so I just dumped them in the directory.

If somebody could do me a favor and take their “truetype fonts” folder and compress it into a rar or zip file so that I could download it that would really help me out so that I dont have to reinstall the entire OpenSuse again.

It is disturbing to me that an OFFICIAL tutorial from https://en.opensuse.org/ would actually contain instructions that will bork a person’s system.

I can understand some punk kid troll giving bad advice like that out of malice but to see something like this on the OFFICIAL website makes me wonder how I can contact them (the ones who maintain the WiKi) to have this tutorial revised before other people also screw up their fonts the way I did.

EDIT: Oh wait, I see that I can edit the WiKi myself so I added a sentence at the end warning future users to make a backup of the folder to prevent a catastrophe like mine. Now sadly looks like I will have to waste 2 hours of my time re-installing and waste the bandwidth of the OpenSuse server downloading all the updates once again at the end of the install. Not a happy camper, am I.

On 2014-12-20 03:46, fc321 wrote:

> And the terminal spit out hundreds and hundreds of assorted errors.

And you did not copy down those errors?

> Please help me to restore my fonts to the way they are supposed to be.

You probably just need to remove the fonts you added. Surely you can
identify them. If not… try this.

change to the /usr/share/fonts/truetype dirctory, and run this or a variant:


rpm -qf *

Those files that say don’t belong to any packages, are the ones you
copied. You probably have to delete them, then inform the system to
rebuild the font tables (I think).


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

If you’re using KDE, you could see if the system fonts were changed. Click the Kickoff Application Launcher, then Configure Desktop, then Application Appearance, then Fonts. Default settings are Sans serif, with Monospace for fixed width. HTH.
Howard

I’m preparing an archive for you
Actually I have seen this too with Windows 8 fonts, the result is different with XP or 7 fonts. But I leave well alone now.
It will be a few mins before I can post the link to the file

Here you are
https://dl.dropboxusercontent.com/u/10573557/truetype.tar.gz

I think I have Ubuntu fonts in there too

Are there any reasons not to just dump “non-system” fonts under user account? in a “.fonts” folder? Is what I did with my Windows and other fonts. Can see an issue when more than one user want same fonts but for single user it should be ok or preferable?

On 2014-12-20 06:36, caf4926 wrote:
>
> Here you are
> https://dl.dropboxusercontent.com/u/10573557/truetype.tar.gz
>
> I think I have Ubuntu fonts in there too

I have not looked at your archive, so I could be wrong; but as a general
advice, be careful with the license of the fonts you publish in a forum :wink:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

http://font.ubuntu.com/

No, I thought they where benign errors…didnt make a note of them.

In desperation I had emptied out the entire folder. Lucky for me somebody uploaded a working copy below so let me give that a shot.

The only place where the fonts where messed up was on Firefox and Chrome. Everything in KDE was set to the defaults and looked fine

THanks brother,

You are a life-saver. THat worked perfectly to restore my fonts back to normal.

But I learned a valuable lesson to make backup copies to always have something to restore back to when making system changes.

I needed help desperately. Now you want to criticize this man for helping me? Its not that big of an issue with the fonts licensing. Plus he did not attach the file, he merely linked to it and the archive is being hosted on dropbox.

Also there are no illegal fonts in the archive (just so you know).

So You “be careful”, Carlos. YOU are the one who should be careful.

Happy to hear that sorted it for you ;):wink:

Notebook 15" - screen.

I have not tested the fonts of Windows 8 yet.

I installed my fonts Windows 7 always at KDE-SystemSettings in root mode (terminal Konsole).

kdesu systemsettings

System Administration -> Font Management -> Add -> Select Windows 7 Fonts folder -> Select all fonts (CTRL + A) -> Open (to install) -> Click Auto Skip case appear any duplicate font -> Close SystemSettings (root mode).

I do not like the appearance of the mode of fonts in KDE by default system configuration.

So I set (normal user mode) -> Start button (Chameleon) -> Configure Desktop -> Application Appearance -> Fonts:

Font Settings: (no change of font or size)

Use anti-aliasing: enable

Force fonts DPI (selected): 120

Configure:

Exclude Range: not selected

Sub-pixel rendering type: None

Hinting Style: Slight

Log-Out KDE for the changes are fully implemented.

Log-In KDE.

http://s29.postimg.org/c86apf1kn/Fonts_KDE_Config_01.jpg

Firefox configuration:

Edit -> Preferences -> Content -> Advanced -> Minimum Font Size: 15

http://s13.postimg.org/a6o8nl3jb/Fonts_Firefox_Config.jpg

On 2014-12-20 17:36, fc321 wrote:

> I needed help desperately. Now you want to criticize this man for
> helping me?

No, no, I’m not criticizing him at all. You misunderstood.

I’m just worried for him. I would have sent the link on a private
message, out of sight of others.

> So You “be careful”, Carlos. YOU are the one who should be careful.

Please. Should I ask the moderators for protection against personal
attacks from you? It does look like you are threatening me.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On Sat, 20 Dec 2014 20:08:06 +0000, Carlos E. R. wrote:

>> So You “be careful”, Carlos. YOU are the one who should be careful.
>
> Please. Should I ask the moderators for protection against personal
> attacks from you? It does look like you are threatening me.

Guys - let’s dial it down a notch or ten. There’s no need to get
personal here (this isn’t directed at one person or the other - just a
general reminder to everyone involved).

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2014-12-20 17:26, fc321 wrote:

> No, I thought they where benign errors…didnt make a note of them.
>
> In desperation I had emptied out the entire folder. Lucky for me
> somebody uploaded a working copy below so let me give that a shot.

Oh, my, you emptied the directory…

You solved the problem, I see, but just for completeness, I’ll mention
that there are other ways.

You can run a query:


rpm -qa | grep -i fonts

which lists all fonts packages, hopefully. It produces a list.

Then passing that list through another query:


rpm -ql {NAME} | grep "/usr/share/fonts/truetype"

would find out if that package contains a truetype font and should be
re-installed. I don’t know of a onliner, but I could script it.

Something like:


echo > rpmstoinstall
while read FILES  ;
RESULT=`rpm -ql $FILES | grep "/usr/share/fonts/truetype"`
if  -n $RESULT ]; then
echo "$FILES" >> rpmstoinstall
fi
done < listofinterestingrpms

Then you could reinstall all those with zypper in a single line :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)