My CD drive doesn't work

My CD drive is attached as secondary slave but it doesn’t appear anywhere, eg. no /dev/hdd or /dev/cdrom. It is not listet in hwinfo either. I completely re-installed SuSE from network today, so it’s the newest version. The drive always worked fine in SuSE 9.x and also booting the Network Setup CD worked properly.

Does someone have an idea? May there be missing packages? What do I have to check next?

Why is it set as slave? Try switching it to master or cable select.
Also, tell us if it is alone on the cable or if with other devices.

The primary IDE cable has a hard disk as master (/boot, /, swap) and an Iomega Zip Drive as Slave. The secondary IDE has a hard disk as master (/home) and the CD as slave. All of the rest is working fine, and booting the SuSE Network Setup CD is also possible. I didn’t change the way the hardware is attached since I bought the PC in 2002, I formerly had SuSE 9.x and I could even record to DVD successfully from K3B. There is no entry to the CD drive in the fstab, and I think a device file to it is missing.

I put my hwinfo here: http://pastebin.com/m3d132062
And here is ll -R /dev: http://pastebin.com/m7ffed32e

(While performing those commands, a CD-ROM which I know that it has no damages was inside the drive.)

There is never any entry for cd/dvd in /etc/fstab

Can you boot from the CD. ie; a live cd

I can boot the OpenSuSE Network Setup CD. The boot manager and kernel is loaded from CD, anything else from the net (eth0,DHCP). During the kernel is loading, the “read” LED lights up. I don’t own any other live CD.

You didn’t say if the CD was on a cable with another drive. Is it. If yes, can you try it alone?

There are two components on the cable: the /home HD and the dvd-drive. If I disconnect the /home, I have to ensure that the system doesn’t try booting/auto login into KDE, default user. How do I tell him? I guess i must comment out the /home mount point, too, isn’t it?

No don’t do that.
Don’t you have another cable?

I would still try changing the jumper. And the way the devices are connected on the cable matters too if I recall.

Hi!
seems that is something with system settings - I can open some of my CDs and some not. I reboot to 11.0 and all disks work just fine.
So…

Hi. small update. I can mount any cd if I do it manually e.g.
mount /dev/sr0 /home/cdrom - it works fine so, but not automatically.
Any suggestions?

Which desktop? KDE4 ? Gnome?

If KDE4, does the device manager notify you if a CD is inserted in the drive?

Oops! Sorry.
Desktop is KDE4 (suse11.2). The device manager does not react on disk. CD spins for couple of seconds and than stops. If I mount manually - everything is just fine.
I wish I have my 11.0 installation - to check fstab etc for any differences, but…

fstab does not control cd mounts

Have you tried different discs?

Yes. Actually write it earlier - it’s 4 older CDs - other are fine. Well not a big deal actually - mostly just curious.

Try adding cdrom to your user in yast2-security and users-user and group management

Small update: I guess, my drive simply is kaput. Even booting some definitely functioning live-CD (Ubuntu, I guess) does not succeed. I’ll never understand why the BIOS still succeeds in loading the kernel. Well… and here the miracle occours.

Thanks however for your helping hands.

No effect. Well I don’t think it is in any connection - other CDs work just fine.